Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


HP DV6-7014nr DSDT help

3 posts in this topic

Recommended Posts

Hello all,


I have an HP DV6-7014nr (details in signature). I'm still trying to install OS X Mountain Lion from a USB stick. I'm having problems with the DSDT I tried to patch with MaLd0n's auto patcher for my system. When I try to boot up into the installer, I get a "Still waiting for root device" error unless I use "USBBusFix=Yes." Even then, the USB stick will only boot into the installer if I use the 1 USB 2 port, the other 3 USB 3 ports on my computer give the root device error.


So, when I finally got into the installer, it can't see my hard drive. Maybe this is a BIOS problem??? I'm not sure. I wanted to try something, so I installed OS X to a 16GB flash drive. That won't boot, no matter which USB port I use, I get the root device error and something like "unable to take control from BIOS."


When I patched with MaLd0n's auto patcher, iasl recompiled my DSDT with 5 errors. I'm uploading my original DSDT.aml and DSDT.dsl that I extracted from linux.


Thank you for any help!!


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kylon

      Cloud ACPI Editor
      Beta 2 coming soon..
      Cloud ACPI Editor is simple Web Editor to create and edit ACPI tables.
      It uses session variables to store the files.
      No changes will be lost on page reload.
      You can host it at home and add custom iASL binaries (see README).
      *This is still a WIP - expect bugs*
      Feel free to reply if you find broken stuff or you have a question!
      Create a new file Load .dsl and .aml files Load multiple files Edit files Compile Show compiler output Settings  Missing/Issues:
      Namespace (Tree) generator Patches Menu Code is not optimized Syntax Highlight Other stuff  
      Sources: here
    • By Pink Waters
      Hi guys, I have my dsdt.aml extracted from windows.
      I compiled just fine no errors, but when I try to add audio in it following this guide I get a lot of errors

      I am running High Sierra
      my audio is ALC889

      The errors are attached

    • By uzmi
      Para los usb 3 de mi placa uso un inyector USB_Series8_Injector.kext modificado para mis puertos.
      Deseo eliminar dicho inyector poniendo los datos de los puertos en el DSDT directamente pero no se si es posible ni como hacerlo.
      Tengo dos instalaciones en dos discos con 10.13.3 
      Uno con un DSDT basado en el que crea Clover y luego modificado para mi equipo.
      Otro con un DSDT basado en el de Pikeralpha y luego modificado para mi equipo
      ¿Podrían echarme una mano?
      Dejo el inyector o un SSDT-UIAC con los datos de los puertos.
      Muchas gracias.
    • By End3rPwr50
      Hi, I wanted to install macOs 10.13 on my notebook.
      Here are the technical specifications:
      -Intel i7 6500U 2.50GHz Skylake (CPU)
      -12GB ram dd4 (RAM)
      -hp 81EC (MOTHERBOARD) with BIOS insyde F09
      -Intel HD Graphics 520 - AMD Radeon R7 M440 (Graphics cards)
      -Realtek PCIe FE Family Controller (Ethernet)
      -Broadcom BCM43142 802.11 bgn Wi-Fi M.2 Adapter (Wifi and Bluetooth)
      -Realtek High Definition Audio - Audio Intel® per schermi(HDMI)
      Thanks in advance

    • By quattrofx
      Hi to all,
      I just wont to give inough informations on one place for all the people with same Hardware with
      costimization steps witch i have done. I have fast perfect working High Sierra 10.13.3 on my PC but
      still needs to be actualized thru the DSDT, because it ist the only way to get all the hardware 
      properly working.
      Gigabyte Z370 Aorus Ultra Gaming - BIOS F7h
      Intel i7-8700K (4.8GHz)
      Gigabyte GTX 1080 G1 Gaming  8G
      DDR4 64GB PC 3000 CL15 G.Skill KIT (4x16GB) 64GVR Ripjaws V
      Dual-Band PCI-e Adapter TP-Link TL-WDN4800
      Firewire PCI-e Digitus (Texas Instruments Chipset)
      Bluetooth 4.0 USB Dongle ASUS BT400 (Broadcom)
      PSU: LC-Power Metatron Prophecy 2 LC8750II V2.2, 750 Watt
      2 x NVMe SSD 960 Evo 500GB (Win10Pro & High Sierra 10.13.3)
      1 x SSD Crucial 500GB (Sierra 10.12.6)
      1 x 4TB Segate Barracuda SATA 3 (Multimedia)
      Tripple-boot Win10Pro, Sierra 10.12.6 & High Sierra 10.13.3
      Bios Settings:
      1.       M.I.T. → Advanced Memory Settings  Extreme Memory Profile(X.M.P.) : Profile1
      2.       BIOS → Fast Boot : Disabled
      3.       BIOS → LAN PXE Boot Option ROM : Disabled
      4.       BIOS → Storage Boot Option Control : UEFI
      5.       Peripherals → Trusted Computing → Security Device Support : Disable
      6.       Peripherals → Network Stack Configuration → Network Stack : Disabled
      7.       Peripherals → USB Configuration → Legacy USB Support : Auto
      8.       Peripherals → USB Configuration → XHCI Hand-off : Enabled
      9.       Chipset → Vt-d : Enabled
      10.   Chipset → Wake on LAN Enable : Disabled
      11.   Chipset → IOAPIC 24-119 Entries : Enabled
      Dedicated graphics card:
      1.      Peripherals → Initial Display Output : PCIe 1 Slot
      2.      Chipset → Integrated Graphics : Enabled
      Chipset → DVMT Pre-Allocated :128M   
      Wake for Ethernet Network access - Unchecked
      Enable Power Nap - Unchecked
      First step:
      I have a perfect Sierra 10.12.6 working on my HP Z800 witch i use to clone to one SSD
      Second step:
      Delete old EFI on cloned SSD and put the new one from here:
      Adjusted Kexts and Config.plist for my Rig:
      Kext Folder:
      FakeSMC.kext + Sensors Kexts
      Thread step:
      connected new cloned SSD on the SATA port and Sierra started up and working.
      Fourth step:
      regulary updated to HighSierra 10.13.3 running installer from App folder.
      Fifth step:
      Cloned Sierra SSD to NVMe SSD 960 Evo 500GB
      Made changes to BIOS & Config.plist to become hardware encoding acceleration  in FCPX and HEVC support:
      BIOS Gigabyte:
      §  Chipset → Integrated Graphics : Enabled
      §  Chipset → DVMT Pre-Allocated :128
      §  Peripherals → Initial Display Output : PCIe 1 Slot
      1.       Inject Kexts is set to Yes
      2.       In Boot Under Custom flags added:
      Nvidia users: shikigva=60
      3.       Kaby Lake & Coffee Lake Users:
      In Devices Using Nvidia 
      - Set ig-platform-id to: 0x59120003
      DSDT Patching:
      1.       HECI -> IMEI Patch
      1.       Comment: change HECI to IMEI
      2.       Find* [Hex]: 48454349
      3.       Replace [Hex]: 494d4549
      2.       GFX0 -> IGPU Patch
      1.       Comment: change GFX0 to IGPU
      2.       Find* [Hex]: 47465830
      3.       Replace* [Hex] : 49475055
      3.        PEGP -> GFX0 Patch
      1.       Comment: change PEGP to GFX0
      2.       Find* [Hex]: 50454750
      3.       Replace [Hex]: 47465830
      I think that in my Config.plist (used EFI from here https://hackintosher.com/guides/high-sierra-install-full-guide/  and edited by me)
      are the double entries, but i am not shure and i dont wont to make a mess myself.
      It is beter to leave it to the profis like Maldon!
      Maldon, i have attached my Send me iMac_4FX.zip file generated with RunMe.app
      Can you post the list of maded Patches for this RIG please.
      THX in advance
      Send me iMac_4FX.zip