Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Sign in to follow this  
progress44

64bit Lion kexts don't work on ML

Recommended Posts

Hi,

 

The situation:

 

I installed Mac Lion 10.7 and have the following things working using kexts

  • CPU all cores using VoodooTSCSync (thanks to members of this forum)
  • Audio using VoodooHDA 2.7.2
  • Graphics, I think the graphics kext is NVClockX or GeForce or NVDAResman - With QE/CI
  • PS2 VoodooPS2... (not needed if I turn USB Legacy to off from BIOS)
  • WiFI IO80211 IONetworkingFamily (AirPortAtheros40.kext)

Everything works nice (except battery, brightness, bluetooth and ethernet which I can live without)

 

I read around on how to install 10.8 and I read that 64bit drivers would work fine on it. Well, I checked my drivers and they were all 64bit.

post-1078598-0-57213700-1349363590_thumb.png

 

So next I prepared an installation USB from the ML bought from app store and after a few tries I managed to install Mountain Lion and launch it without any kernel panics.

 

I tried to install the kexts I use for my Lion partition.

Few of them worked (PS2, TSCSync)

Many didn't work (Graphics, WiFi, Audio)

 

This also happened when I updated to 10.7.5 from 10.7.4 (fortunately Time Machine works very good in these cases)

 

My question is:

 

What are the requirements for the kexts to work? Is being 64bit enough? Am I doing something wrong?

 

Any help is appreciated.

 

Thanks

 

PS: here is a screenshot of 10.7.2 in action

post-1078598-0-59508300-1349364176_thumb.png

 

I've attached the kexts I use if anyone else has my hardware or the same model laptop

Toshiba Satellite C660-1MG i3 2310m, GeForce 315m 1GB, 4GB DDR3 1333MHz, Toshiba Audio

Will update for the correct WiFi card, BT card (both Atheros), Lan (Realtek),

working.zip

Share this post


Link to post
Share on other sites
Advertisement

Your kinda going about it wrong. Just because a kext is 64bit does not mean it will work in ML, it has other dependencies, and for the ones your having problems with, there are ML versions that will work anyways. The initial test to do was not to see if all your kexts were 64 bit, but if you are running 64bit kernel now so you know no problems with ML since it 64 bit only. Chances are if you already running 64bit in Lion, ML won't be problem, but u will still need to find compatiable kexts, Type in terminal from Lion:

uname -a

you'll get a couple lines, the last thing it will say is either i386 for 32bit or x86_64 for 64bit.

To help locate kexts for any of your devices, device ID and vendor ID of each will be needed

 

PS, you don' actually need to do the uname -a since you already installed somewhat working ML, your fine, just example.

Share this post


Link to post
Share on other sites

My first question is do you have a perfectly compatible DSDT generated only for your machine? That would fix graphics and sound for the most part. The less extra kexts you are running the better.

Share this post


Link to post
Share on other sites

@eep357

I read on forums that if you checked that the kexts were 64bit it would work, I didn't think of the dependencies. I'll check the architecture Lion is running in, but I'm pretty sure it's 64bit.

The kexts I found and attached to the original post were selected having in mind device id and vendor id, but I guess I have to look again for ML kexts matching those ids.

(your computer seems awesome)

 

@bugpoppa206

I don't use a DSDT on my pc because I haven't understood how to do it properly. And I haven't had the necessity until 10.8.2 came out. I've always tried finding kexts because it seems easier to me.

 

@Lord Kamina

I don't use kernel cache, but I'm not sure. How do I check it and how do I specify to use only 64bit version of the kexts?

 

Thank you all for the replies.

I had given up due to my limited free time to work on the computer and being my only one I couldn't waste to much time.

Share this post


Link to post
Share on other sites

You should find the Toshiba forums where they are have working DSDT files and ask them how to do it for your machine first. That will clear up some things. Even if you find a Toshiba thread with an older version of OSX, read it to learn how to fix your laptop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×