Jump to content

Still Waiting For Root Device on Sony Vaio


Guest lefandegta
 Share

11 posts in this topic

Recommended Posts

Guest lefandegta

Hi guys,

 

I'm trying to install Mountain Lion on my new Sony Vaio Laptop, using this guide http://www.macbreaker.com/2012/07/install-mountain-lion-######.html ("How To install Moutain Lion on your PC, same tuto here http://www.youtube.com/watch?v=xaNp8Pg964I )

I'm stuck at booting the installer (USB drive).

I need to boot with "GraphicsEnabler=No" or else it stops as soon as the booting process starts, but it stops again to say "Still Waiting for root device".

I've tried a lot of booting flags and nothing could solve the problem...

 

There's nothing I can modify about SATA/AHCI in the BIOS.

 

Here are my specs:

 

-Intel core i5 2450M 2,5GHz

-6 GB 1333MHz DDR3 SDRAM

-AMD Radeon HD 7650M 1GB

-500GB SATA hard drive

 

Any help?

 

Thanx

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
  • 1 month later...

Long time reader First time contributor

 

I would like to share my expericence about the sony vaio SVE1512Z1EB and mountain lion 10.8.2

 

1 I create my WIN 8 dvd really important indeed it cost a lost to make a recovery in my country.

2 boot my machine with the "assit" button it allow a welcome screen giving you access to the bios

3 Set the bios to legacy in the boot menu + enable external device boot

4 use Gparted to remove all the partitions

5 create bootable usb key by following this guide https://www.youtube....h?v=1sGICm2tXkU

6 edit the org.chamelon.boot.plist on GraphicsEnabler change Yes to NO

7 edit smbios.plist to macbook pro 9.2

8 add PXHCD.kext for the usb 3 in the E/E folder

9 add RTGNIC v 2.0.6 for 10.7 from realtek ftp for the rtl 8111/8168b network card in the usb key when your mountain lion is up

 

my E/E folder do have the following

 

AHCI_3rdParty_SATA.kext

FakeSMC.kext

NullCPUPowerManagement.kext

PXHCD.kext

 

Boot with the -v option and then install it

 

Now here is where i am

bluethooth work

lan work

camera work

need external mouse and keyboard but work

Video card block on 1024x768 strangely the win id of the card is on the ATI6000.kext of mountaint lion (Dev 841)

About this mac crash but i understand it is due to DSDT

 

I was going to try to create a DSDT (never did it before) until i found Clover and read that you do not need DSDT anymore sadly the downsize is that you need to be on UEFi wich is nice like this i can have win 8 and mountain lion.

 

So i found the article of Kogen Mantis Lenovo ThinkPad T420 with UEFI only

Create a usb key and copy is lenovo pack inside by comparing the key and his folder

 

I was not only able to boot in UEFI but have my mountain lion seen in the main menu and able to boot to a certain extend i am block after 5 displayed screens.

 

Now here is my question if someone can help

 

A is it real that we no longer need DSDT when we are booting in UEFI ?

 

Thanks by advance for anyone who will help

Link to comment
Share on other sites

I am perfectly able to boot with chameleon and i can if i want make a bootable hackintosh on the sony vaio in legacy mode

my goal is to achieve a bootable hackintosh in UEFI mode with Clover

 

Thank you for your help i will continue my learning journey with clover :)

Link to comment
Share on other sites

  • 4 weeks later...
 Share

×
×
  • Create New...