Jump to content

[How To] Lenovo z370 (i3-2330m) Mountain Lion


6 posts in this topic

Recommended Posts


Generic update information lower down



*****Last updated: 16/7/2012*****


This guide is how to install a vanilla copy of OS X which you have created yourself, it requires a little more work than one-click installers but leaves you with a better system. Please note this is the initial guide so if I've missed something let me know. For those looking for a one-click installer I suggest you try myHack with a combination of the included kexts & extra folder.


For those wishing to update there Lion install they'll have to wait for ML to be available in the app store then follow the generic update information below. Having said that this is untested by me and I suggest searching the forum first for advice on updating Lion to ML.


I've had a few people contact me for help. I'm more than happy to help where possible but please read through the entire guide & installer page before contacting me. It may look complicated at first but it's really quite simple. Also I'd prefer comments on this page rather than PM's since other people that may be struggling can read it.


Hardware spec:

core i3-2330m (4 thread dual core)

hd3000 graphics (8086 0116) (note this is the 0116 revision not the 0112 you might read about for different HD3000's)

Atheros AR9285 wi-fi (168C 002B)

Realtek ALC269 sound (10EC 0269)

Realtek ethernet (10EC 8136)

4GB RAM (upgraded mine to 8GB)


What works:

Graphics with full QI / CE.


Touchpad & keyboard



Audio output (speakers & headphones)

App store




What doesn't:


Battery Sensor

Card Reader

HDMI audio


I've had no luck in making the system stable with a battery sensor and it currently won't wake from sleep (on ML, it would on Lion), I don't really have time to work on these issues and I don't require them so unless someone else picks up development then the issues won't be solved for the foreseeable future.


A couple of things to note before you start:

1. To prepare the installer you need a working copy of OS X, this can be done in a virtual machine or by installing an older version first, see here:



2. Open the attachment in OS X not windows / linux (otherwise folder structure wil look screwed).

3. If you get boot0 error its a simple fix, see here:




The guide:

1. Use the following tutorial up to and including part 4:


2. Install the latest version of chameleon (included in the attachment) to your usb stick.

3. Copy the extra folder for your z370 model to the root of your usb stick.

4. Continue from part 5 of the above guide up to and including part 7 (note you need to use the boot-loader on the usb stick to boot into your OS X install initially.

5. Install the latest version of chameleon to your HDD (included in attachment).

6. Drag and drop the kexts in the attachment onto kext utility - NOTE: if you have the i5/NVIDIA combination ignore the AppleIntelSNBGraphicsFB kext.

7. Copy the extra folder for your z370 model to the root of your hard drive.

8. Delete NullCPUPowerManagement from /System/Library/Extensions.

9. Fix permissions and reboot - you should have a working copy of OS X.


I've been using it for a few days and haven't had any issues so I would be confident in saying its stable.


Generic update information, as new ones are released I'll test them and report if they work:

1. Install nullcpupowermanagement.kext using kext utility (you WILL get kernel panic on reboot if you don't do this).

2. Reboot.

3. Update system as normal.

4. Use kext utility to reinstall the blue kexts.

5. Repair disk permissions in disk utility.

6. Reboot.

6. Delete nullcpupowermanagement.kext from /system/library/extensions

7. Reboot & enjoy!

z370 ML.zip

Link to comment
Share on other sites

  • 2 weeks later...



Great work as usual. I wish you applause and comely women.


Just one thing; I created an install medium using this post and your other post with the generic instructions. I believe it's worked since I can boot into the OsX installer on an HP laptop. However, whenever I try to boot into the z370, the screen goes blank sometime after "DSMOS has arrived". I then have to reboot and repeat the entire process.

I've tried using the 'Extra' folder from your attachment as well as every kernel flag Chameleon supports.

Any idea what might be happening?


Again, thanks. :)

Link to comment
Share on other sites

If its booting normally then the screen is turning off try plugging a HDMI lead in and see if that helps if not could you boot with -v and post a screenshot?


I've a feeling its graphics related but let me see the -v screenshot to see if I can figure out how to help you.


Just to check when you go for the first boot you should use the bootloader from the usb not the HDD until the Extra folder is placed at /


EDIT: also try booting with DSDT=null @ chameleon prompt

Link to comment
Share on other sites



Sorry for the delay. The laptop wasn't within immediate reach.


I tried DSDT=null. Same deal as before.

I've included a photo of my screen just before it shuts down. The boot flags are: -v GraphicsEnabler=No npci=0x2000 DSDT=null

(Link to screen)


I tried booting to an iAtkos L1 USB for {censored} and giggles. That part still works fine.

I've also looked around the forum. It seems a lot of people are complaining about a similar "blank screen" but that seems to be for Nvidia cards only.


Again, thanks for the help.


Edit: I was wondering... Should/Can I just install Lion (iAtkos L1) and upgrade using the Mountain Lion dmg within Lion itself? I'll have to do a lot of purging from within the /S/L/E directory, right?


Edit 2: Yes, the unchanged setup doesn't install to an MBR partition table. And the modified install errors out from within OsX.


Edit 3: So yeah, I got the ML installer to boot using the ancient tradition of hit and trial.

1. I installed ye olde Lion on first (for MyHack)

2. Made a MyHack install. Saw it crash promptly on the next boot.

3. Replaced the Extra folder in the USB with the i3 Extra in the attachment above. Also put the two kexts mentioned separately above into the /S/L/E directory on the USB drive.

4. Installed and rebooted to installer. Copied the two kexts to the /S/L/E on /

5. Deleted the default myHack Extra on / directory and replaced it with the i3 Extra from the attachment.

6. It's working now. Except for the Battery indicator.


Also, Contacts and Reminders seem to error. And there're some weird graphical glitches. You getting any of this?

Link to comment
Share on other sites

ML's been solid on mine so not sure whats wrong there, you have installed the kexts using kext utility haven't you? (just checking since you don't mention it above).


Also as mentioned above unfortunately I currently don't know of a fix for the battery indicator...


Only other thing to do would be go to /system/library/extensions and delete NullCPUPowerManagement - it should work fine without it.

Link to comment
Share on other sites

  • 1 month later...

  • Create New...