Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

ML GM Install Black Screen

10 posts in this topic

Recommended Posts

Trying to install ML GM, my system is


i5 760

Asus P7P55D-E Pro

nVidia 550ti


Im getting a black screen after showing the apple boot screen. I think its a video problem have tried the following




both options don't do anything. Any tips

Share this post

Link to post
Share on other sites

Same problems here!

Tried GE y/n, PCIRootUID= 0 / 1.....

Seems to start fine, then gets stuck at a black screen....

Share this post

Link to post
Share on other sites

Me too getting black screen even after using npci=x3000 black screen after [iOBluetoothHCIController][start]--completed.It is so fast that I cannot even take a pic. Please some one help,Lion works fine on my PC.

Configuration of my PC is:

Intel core2duo 2.93GHz,4GB DDR2,Geforce 8800GT.Gigabyte G31M-ES2C mobo


Please Help

Share this post

Link to post
Share on other sites

I've solved it by putting the Lion's Extra folder in ML


Could you post on how you done this? sorry still a n00b learning.

Share this post

Link to post
Share on other sites

I had a similar issue and after i knew it had booted to the install screen (but i couldn't see anything), i pushed the power button on my hack to put it to sleep. Then i woke it up and the screen showed up and i could proceed with the install.

Share this post

Link to post
Share on other sites

I got it working finally. I deleted following kexts , I did the deletion manually of those kexts and it boots into installation. Installing now......



rm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/AppleIntelGMA*

rm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/AppleIntelHD3000*rm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/AppleIntelHDGraphics*rm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/AppleIntelSNBGraphicsFB.kextrm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/AppleIntelIntegratedFramebuffer.kextrm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/AppleIntelSNBVA.bundlerm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/ATI*rm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/GeForce*rm -rf /Volumes/Macintosh\ HD/System/Library/Extensions/NVDANV*

Share this post

Link to post
Share on other sites

Thanks so much Sharon, I deleted the kexts u mentioned plus 2 additional ones and it works, without any parameters like GraphicsEnabler:
















Now I got it installed but the only possible resolution ist 1280x1024, with NVDAGF100Hal.kext it keeps crashing after loading the kexts... + Can't even boot to single user anymore :P

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies