Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Marta Reis

[HELP] Error Creating Installer with myHack

10 posts in this topic

Recommended Posts

Hi,

 

I'm using myHack to create the installer but I always get the same error message...

 

Mounting InstallESD.dmg

2012-07-05 22:17:34.034 defaults[3197:b07] The domain/default pair of (/Volumes/Mac OS X Install ESD/System/Library/CoreServices/SystemVersion, ProductVersion) does not exist ERROR: Selection does not appear to be a valid OS X installation source.

Exiting.

 

:wallbash:

 

The Lion.app or InstallESD.dmg is not corrupted. I've used different files but I always got the same error. I can mount the dmg file normally and run lion.app. The files only became corrupted after I use myhack.

 

I'm using a USB stick and a macbook running 10.6.8.

 

Any clue of what might be wrong?

 

Thx

Share this post


Link to post
Share on other sites
Advertisement

I'm letting myHack do everything. I'm just using the browser to locate the file once it is not able to do that.

 

Verify that the DMG is InstallESD.dmg (the volume name should Mac OS X Install ESD) and not something else.

 

I can't download the file from apple store it says I need a more powerfull machine. I'm just using this macbook to create he installer. But I'm using the same file you purchase online, exactly the same.

 

I've download two different files of that version of Lion and used them with myHack... the same error ocurred. Two different downloads, two different files but still the same error on myHack, which is beyond strange. I can assure you I could mount and run those same applications without any kind of error which is even more strange.

 

I really want to use myHack but I'm almost giving up. I guess I will be forced to use the method Hangten suggested on one of these posts.

 

Do you suggest something else?

Share this post


Link to post
Share on other sites

Have you looked to see that the 2 files in that error message are present on the completed install USB? They are responsible for making sure your hardware is a mac that meets the minimum system requirements and a good, valid smbios is needed to pass the machine check. So make sure you have one, Chameleon Wizard can help you generate one. It will need to go in /Extra on the install USB. I can get u new copies of both those files to copy over to the USB manually and replace the 2 that are corrupt or missing, but need to know what version of Lion you have i.e. 10.7.3, 10.7.1 etc.

Share this post


Link to post
Share on other sites
Copy to same file path as the error message in your first post

 

 

I'm not sure if I understood that right but I'll try it.

Share this post


Link to post
Share on other sites

I'm not sure if I understood that right but I'll try it.

/Volumes/Mac OS X Install ESD/System/Library/CoreServices/SystemVersion

or /Volumes/Mac\ OS\ X\ Base\ System/System/Library/CoreServices/SystemVersion

Share this post


Link to post
Share on other sites

Hello,

 

I had this problem, and it is solved:

my purchased download had something wrong: was the good size, was able to install OSX, but a checksum was not good.

Downloaded it again, and now it is ok.

To check, right clic on the install mountain lion app, then "show contents", go to shared support > InstallESD.dmg

Try to mount it: it is verified, then you may have something about cjecksum error.

 

Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Hello! In my signature system the program does not show the life of the hard drives but only that of the ssd.   High Sierra 10.13.4
    • hello   try this one   DSDT.aml.zip   for graphics and backlight are needed ssdt files   good hack
    • Non ti ho messo io quelle impostazioni I sul config.. Poi aggiorna i kext.. 
    • So, i am thinking about pubblishing the stable release of tinu 2.0, just with a few minor chenges from the last pre-release, and to focus my work on the next one, i have just chenged a couple of UI things for the stable release and add a warning message if you try to use a time machine disk as a target drive to create the macOS install media, for the release that will come after the stable 2.0 release (and maybe also after a bug fix release for the 2.0 if needed) i am trying to use the system apis to manage the tasks which needs special priviladges to be executed, instead of the "sudo" based system which i am using now, this will make the application more secure and reliable, and also you will have to do the authentication only one time, when creating an install media, and using this system maybe i can also pubblish the application on the app store (obviusly just a limited version for mac users, but a version with all the features unlocked will be always available outside the app store and will have all the hackintosh-friendly features as well). But to do that i need to re-write a large amount of code into the app, because all the tasks which needs special permitions needs to be re-implemented differently, so that's why i do not want to use this in the 2.0 release, so because i am going to finish with tinu 2.0 tell me every complain or problem you are having with the latest pre-release or the latest release of tinu, so i can work on that before releaseing the stable 2.0 version
    • here it is,
      https://drive.google.com/file/d/1_FwNFczk4CdIfiIQ-T1pX_LY1takRuny/view?usp=sharing


×