Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • 0

Ajuda com kext de Som [ALC892]


Olá pessoal.

Finalmente eu consegui instalar o Mac no meu pc AMD, e ficou tudo 101%, exceto o som. Minha mobo é a ASUS SABERTOOTH 990fx, sendo o codec de áudio: ALC892

Alguém sabe se existe alguma kext que resolva meu problema?


Versão: 10.6.8

Share this post

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Ok, irei tentar aqui e logo posto o resultado! :)




Ficou chiando, e os processos para corrigir não funcionaram. Não funcionou os 5 canais, apenas 2. O volume ficou muito baixo.

Será se eu fiz algo errado?

Share this post

Link to post
Share on other sites
  • 0

Olá, obrigado por me ajudar.

Eu removi a kext anterior, instalei a nova do link utilizando o Kext Utility, reiniciei: agora não funcionou nada. :worried_anim:


Obs. Eu achei em algum lugar uma que funciona certinho no Lion (segundo comentários do arquivo). Será se eu consigo atualizar meu hack para testar? Ainda não sei se existe legacy kernel para o Lion...

Share this post

Link to post
Share on other sites
  • 0

Não funcionou mesmo, mas o pessoal diz funcionar no Lion. Já existe uma kernel legacy pro Lion? Talvez eu deva tentar atualizar para testar aquela kext...

Share this post

Link to post
Share on other sites
  • 0

Consegui instalar tudo certinho, e o som funcionou legal. Agora vou tentar instalar no meu notbook. Caso precise eu abro outro tópico referente a ele.

artur-pt, muuuuuuito obrigado por ajudar. :D

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fietipaldi
      Hi there,
      I had to reinstall El Capitan on my Hackintosh, as it was installed in Clover Legacy Mode before (with everything working just fine).
      Now I installed it again in UEFI mode and since then, Audio (ALC892) is not working anymore (Neither in UEFI or Legacymode).
      I tried to install the same 2 Kexts as before (AppleHDA modified and HDAEnabler1) using Kextutility (wich was working fine before as well).
      It always fails to install AppleHDA, as it cannot Backup or modify the Original AppleHDA in System/Extensions (Can't copy sourcefile).
      I also tried the same, using the root Account, using terminal with kextunload / load and even a script for clover.
      They all fail to modify / delete the Original AppleHDA. Trying to rename / move or delete the Original file with Terminal or Finder is not working as well, I get an Error, saying that the file cannot be modified because OS X requires it.
      So how can I install the Kext to get my audio working again? System is El Capitan (10.11.6)...

      Thank You!
    • By MrAnty
      My alc892 audio has an issue. My Motherboard model is ASROCK b350 K4 Gaming. I installed voodooHDA 2.9 and it works. Alc892 has been successfully recognized.
      But there is nothing like 5.1 or 7.1(green rear) in the audio output. There is only Headphone(green front) output.
      So I can only use headphones via the front audio output jacks of my chassis, but cannot use my speakers via the rear audio output jacks(the green one).  Please help me. Any reply will be appreciated.
      Forgive me for my poor ENGLISH....
    • By none20
      I am having two problems with Sierra. (Final official release from AppStore).
      1. My onboard desktop Intel HD 4600 is not working anymore by clover's injection method (it was working perfectly on previous systems like Mavericks, Yosemite and El Capitan). For some reasons with same kexts and config.plist with latest clover I am having reboots soon after I reach DSMOS HAS ARRIVED. 
      I noticed that giving lg-platform-id: 0x04128086 stops the rebooting. But my video card is recognized as Intel HD 4600 with 7mb vram. No acceleration.
      Before I reinstalled OSX I checked what is my ID on working El Capitan by DPCIManager, and it also said it is 0x04128086. I tried few different ID's found on the web, but nothing seems to help. I even tried solution with FakeID kexts. Problem remains the same.
      2. My audio card is not working by the same injection method as it was working on El Capitan and Yosemite. I always installed my audio in post process using this app "Clover OS X El Capitan-V7". I know its novice solution, but previously was working perfectly for me with minimal effort.
      My specs are:
      MB: MSI B85-G43 Sc
      CPU: i5-4570
      Mem: 16GB Corsair Vengeance Pro
      GPU: Intel HD 4600 (I'm connecting Monitor to PC via DVI-HDMI cable)
      Audio: ALC892 (previously was working on ID 1 after patching AppleHDA with given app)
      I used latest clover, and I am of course installing everything using UEFI (EFI Partition). 
      I will attach everything I have in my EFI.
      Any suggestions guys? 
      My EFI Stuff.zip
    • By AnssaienlyMac
      Hello, guys! 

      I was wondering if anybody had managed to get a working AppleHDA.kext for MSI X99A SLI PLUS (ALC892). If so, would you share the method you used, please?


    • By giorgio67
      salve a tutti, due giorni fa ho deciso di aggiornare il pc e di passare da yosemite a El Capitan... solo che ora mi non mi funzionano più audio (ALC892), bluetooth e USB3...
      Avendo un DSDT funzionante e il file di clover "config.plist" penso configurato correttamente, ho deciso di effettuare l'aggiornamento diretto da Yosemite, supponendo che quest'ultimi funzionassero anche su El Capitan... Ma mi sbagliavo...
      Per poter risolvere i problemi di audio ho usato il tool aggiornato di toleda... ma non ha funzionato... mi spiego meglio... se ottengo le informazioni di sistema da resoconto di sistema... l'audio viene rilevato ma non si attivano i dispositivi cioè se clicco su suono da pannello di controllo... i dispositivi di uscita audio nn spuntano...
      Per quanto riguarda il bluetooth ho caricato il kext IOath3kfrmwr.kext nella cartella 10.11 della EFI di clover... e viene rilevato come dispositivo USB... e non bluetooth... Ho provato anche a riparare i permessi e a ricostruire la cache di sistema... ma nnt...
      Non capisco se sia un problema di DSDT... o se il problema sia nel file di config.plist... allego dunque il file config.plist e il DSDT sperando che mi possiate aiutare xD
      config + dsdt.zip