Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
spinnerator

NIC conundrum

6 posts in this topic

Recommended Posts

I've installed Hazard's Snow Leopard and Hazard's Snow Leopard Server on an old P4 machine. They run on separate harddrives. Here's my conundrum. Snow Leopard runs fine, no issues. The server as originally installed by the Hazard disc was v. 10.6.2 and ran but was buggy. It did however access internet and home network. I downloaded the 10.6.8 update and that version installed. Now, however, does not access my home network or the internet despite Network Utility reporting it as connected. Currently it has RealtekR1000.kext installed on the server. Snow Leopard on the other drive reports AppleRTL8169Ethernet.kext installed and access both internet and home network. The conundrum is, that I cannot remove or install the kexts for the NIC on the Server. I have tried every kext installer I can find. I've even tried to do it manually. I have deleted every version of RealtekR1000.kext that shows up in a search yet System Info app still reports the R1000 as installed. It's almost like malware. It won't go away and it won't let anything install in it's place.

Share this post


Link to post
Share on other sites

I've done that, I've deleted every version of the kext that shows up anywhere. I have used 'showhiddenfiles' app to make sure I'm seeing every file. And again, as I said, I've used every kext installer I can find. Kext Utility, Kext Wizard, OSX86 tools, .Kext Helper b7, ###### (where I tried to install the lnx2mac kext) and I've even used this :

 

http://osxdaily.com/...ns-in-mac-os-x/

 

All report the kext as installed, but after every reboot the Sys Info apt reports the the R1000 kext still installed even though it no longer shows up in a search and no changes from the Network Utility.

 

I've even tried installing the kext from my Snow Leopard install using ###### and OSX86tools.

Share this post


Link to post
Share on other sites

Yes, that's where it was hiding. Didn't know that OSX system had kexts hiding within kexts. Deleted it and now the correct kext installs and the internet and home network accessible.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×