Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Displaying Sys info display 16gb ram, but only using 8gb? MiniITX

9 posts in this topic

Recommended Posts

So i just upgraded my Mighty Hack Mini from 2x4gb(8gb) sticks to 2x8gb(16gb).


The 16bg is showing up in my about mac and in my system info, but when i look at my activity monitor it's only using 8gb.


I've tried to reseat the ram and made sure its plugged in properly, and it works in my windows partition, but not sure whats up.


It is a Mini ITX board so I only have two slots?


Running 10.7.3 flawlessly other than this.


I have the Mac Mini system definition installed using the newest ###### (4.3 and chameleon). I have tried removing a stick and everything goes back to 8gb, then when I reinstall, it shows the 16gb in my Sys profile but just doesn't seem to be using it in activity monitor.


Any suggestions?


Ca anyone with 16gb in a Mini ITX chime in ? Thanks!




Gigabyte H55N-USB3

Intel i7 860

Radeon HD 6870


Here is a link of a picture of my Activity Monitor, About Mac, and Sys INFO

Share this post

Link to post
Share on other sites

Post the contents of your org.chameleon.boot.plist, you may be limiting the amount of RAM, this is common when installing with more than 2Gb ram installed (though I never bothered and was always fine).


Just an idea but worth a shot.

Share this post

Link to post
Share on other sites

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Kernel Flags</key>
<string>npci=0x3000 darkwake=0</string>
<key>Legacy Logo</key>


I don't believe anything here is limiting it?

Share this post

Link to post
Share on other sites

Yeah that motherboard only has two memory slots, Chameleon's memory detection is having a fit.


Are you using a patched DSDT? You must re-extract and patch it again after installing more memory.


Use a Linux live CD (Mint is good) or Lavalys Everest (or whatever it's called now) on Windows.

Don't extract on OS X, any tool or script you use will extract your already patched DSDT.

Share this post

Link to post
Share on other sites

Hi sgrinalds,


Did you solve your problem?


I'm having a similar one, with the motherboard P55-USB3 rev 1.0, using DSDT from tonymacx86 also


Installed 8GB RAM but Activity Monitor shows 4GB only



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By deejaystage
      Hola chicos!
      Mi sistema sólo muestra 7 mb de vram y no tengo aceleración en mi gráfica. He probado infinidad de remedios pero no he encontrado la solución.
      ¿Alguien podría ayudarme?
      Gracias por adelantado
    • By Dan ZG
      Anyone have any idea why I can see my my full 16GB RAM (4x4) in BIOS but OSX only shows 12?
      And 16 TB "wired" .. ha ..
      Mobo = Gigabyte X58A-UD3R (FH)

    • By animani
      Hi guys,

      I've tried adding the ram slots in Clover and I get 48GB but using 40% of the ram without doing anything in my computer. It reports as "wired" mostly. 

      If I remove them from config.plist and add trust it detects 32GB and no ram usage after restarting.

      Any help would be appreciated.
      Bios update to the latest version solved my problem.
    • By DaniiSwan
      I'm having an issue with booting into the installer part of my Install USB. I've used the following tutorial (https://www.reddit.com/r/hackintosh/comments/6llf3g/how_to_install_sierra_on_pc_without_a_mac_vanilla/) to create my bootable USB and it does in fact boot into the clover menu. However , when I attempt to boot into the Sierra installer , I get an error message saying:

      OsxAptioFixDrv : Starting overrides for .IABootFiles\boot.efi using reloc block: yes. hibernate wake: no +++++++++++++++++++++++++++++++++++++++
      Changing to OsxAptioFix2Drv or OsxAptioFix2Drv-Free2000 doesn't help as it only changes the "using reloc block" to no.
      I'm just wondering if any has any advice on how to get around this error.
      I'm attempting the install on a Lenovo Thinkpad Edge E530 with an Intel Core i5-3360m and Intel HD 4000 graphics. If any further information is required , feel free to ask
    • By SAMEH209
      I'm trying to install Yosemite on my HP XW6600 Workstation.
      CPU: Dual Intel Xeon E5410 @ 2.3GHz
      RAM: 16GB
      GPU: GTX 950 1GB
      When trying to get to the installer I got a kernel panic saying "Unable to find driver for this platform: \"ACPI"\"

      but I managed to bypass that by booting with "-f -v -x acpi=off" and now I get another KP saying "pmap_steal_memory" and I have no idea what's the cause of this.