Jump to content

[Help] iatkos l2 on Intel HD 3000 Graphics [Acer 5750 with Customization Section ]


77 posts in this topic

Recommended Posts

Hello World!

 

I really need more guidance to be able to succesfully install iatkos l2 on my laptop. I managed to create a bootable USB that has iatkos L2 in it. It took me some time to be able to get to the installation screen, after some research, by booting in safe mode -x I was able to get there. I am now in the Customization section, but I do not know which options are best for my graphics.

 

 

8982c15e80.jpg

 

 

 

My laptop Specifications: Acer 5750-9292

  • Intel core i7-2630QM 2GHz
  • Intel HD Graphics 3000
  • 4 GB DDR3 Memory

I kept it in the default setting just to test if it will work, now I am stuck at the boot screen. My questions that I wish to be answered.

 

1: What are the best custom options for Intel HD 3000 Graphics ?

2: How do I boot for the first time, what should I type as a command, should I delete/add any kext?

 

By solving these problems, I am positively sure more people will find this thread very useful in the future.

 

 

Thanks in advance!

 

 

Update:

 

If you follow the posts below, you will be able install iatkos l2 if you have a similar laptop like mine. All the thanks and apperications should go to

rlf , without him this would not be possible.

 

 

Installations of Xcode 4.2 discussion starts at

page 3.

I don't believe iAtkos L2 has anything special in it for HD3000. You usually have to work on that after it is installed.

 

I would UN-check the GraphicsEnabler because I don't think Chameleon 2.1 has anything for HD3000.

 

You say you are stuck at the "boot screen". What boot screen? The one with the Chameleon at the top? The one with the Apple with the little spinner?

 

Boot with -v always when you are trying to figure out problems. What does it say when it hangs?

  • Like 1

 

You say you are stuck at the "boot screen". What boot screen? The one with the Chameleon at the top? The one with the Apple with the little spinner?

 

Boot with -v always when you are trying to figure out problems. What does it say when it hangs?

 

It's stuck at the Apple little spinner.

 

I will install it again with the default settings, but this time I will uncheck GraphicsEnabler. Then I will run it in -v mode and take a picture. I will be right back!

I did some more research...

 

Under bootloaders, UN-check Chameleon 2.1, but CHECK Chimera 1.6 and under Booloader Options, leave GraphicsEnabler checked.

  • Like 2

I did some more research...

 

Under bootloaders, UN-check Chameleon 2.1, but CHECK Chimera 1.6 and under Booloader Options, leave GraphicsEnabler checked.

 

I turned off my laptop before I saw this post, but this is what I got based on the settings I chose. I will re-install it again with the new settings.

 

These pictures are from different angles

 

http://imageshack.us/photo/my-images/135/36871768.jpg/

OK, I hated to go this far. Booting with -x was intended to turn off the regular video drivers and force it to use a VESA driver where you only get one resolution and no acceleration. But at least you get to the Desktop so you can do some work. But booting -x has caused some other problem. So, the other way is to physically remove the video drivers to force the use of the VESA driver. Actually, we are only going to move them to a new folder so they will still be available. We are going to do this in single user mode which has text for a GUI and you will be typing commands at a command line.

 

 

Boot -s

 

At the prompt "root:"

 

Type:  mount -uw /
Type:  cd /System/Library/Extensions
Type:  mkdir IntelBack
Type:  mv AppleIntelHD* IntelBack/
Type:  mv AppleIntelSNB* IntelBack/

 

Reboot -v -f

  • Like 2

OK, I hated to go this far. Booting with -x was intended to turn off the regular video drivers and force it to use a VESA driver where you only get one resolution and no acceleration. But at least you get to the Desktop so you can do some work. But booting -x has caused some other problem. So, the other way is to physically remove the video drivers to force the use of the VESA driver. Actually, we are only going to move them to a new folder so they will still be available. We are going to do this in single user mode which has text for a GUI and you will be typing commands at a command line.

 

 

Boot -s

 

At the prompt "root:"

 

Type:  mount -uw /
Type:  cd /System/Library/Extensions
Type:  mkdir IntelBack
Type:  mv AppleIntelHD* IntelBack/
Type:  mv AppleIntelSNB* IntelBack/

 

Reboot -v -f

 

 

I tried to boot once in single user mode, but I was not able to type anything. Probably I need a USB Keyboard, I don't have one right now. I would at least need a day to borrow one from a friend. Is there another way to be able to type those codes?

 

Like maybe the terminal that's in the installation screen, below the Disk Utitlity. Would it work if I type that code there?

 

 

Or maybe by moving the folder physically using VMWARE Workstation 8 , I can access my USB and see the hidden folders.

 

If I can't do either one, then I will try to get a USB keyboard as soon as I can, and I will update this thread.

Yes, you can use the Terminal program in the install DVD. It will change a couple of commands and you must know the name of your Mac partition. If you don't remember the exact name of the Mac partition, go into Disk Utility and look it up.

 

 

 

Open Terminal

 

At the prompt,

 

Type:  cd "/Volumes/(name of your Mac partition)"   <== use the quote marks but not the parentheses
Type:  ls	<== this lists the files and directories

If you DON'T see a file named "mach_kernel", you need to try again
If you DO see a file named "mach_atom", you need to try again

Type:  cd System/Library/Extensions
Type:  mkdir IntelBack
Type:  mv AppleIntelHD* IntelBack/
Type:  mv AppleIntelSNB* IntelBack/

 

Reboot -v -f

  • Like 4

Yes, you can use the Terminal program in the install DVD. It will change a couple of commands and you must know the name of your Mac partition. If you don't remember the exact name of the Mac partition, go into Disk Utility and look it up.

 

 

 

Open Terminal

 

At the prompt,

 

Type:  cd "/Volumes/(name of your Mac partition)"   <== use the quote marks but not the parentheses
Type:  ls	<== this lists the files and directories

If you DON'T see a file named "mach_kernel", you need to try again
If you DO see a file named "mach_atom", you need to try again

Type:  cd System/Library/Extensions
Type:  mkdir IntelBack
Type:  mv AppleIntelHD* IntelBack/
Type:  mv AppleIntelSNB* IntelBack/

 

Reboot -v -f

 

 

Here are the new pictures, I booted with -v -f

 

http://imageshack.us.../img0185py.jpg/

The commands you typed were perfect.

 

You rebooted with -v -f and not -v -x, right?

 

The only thing that caused "waiting for root device" was booting with -x. We have done nothing else to cause this. Did you make any BIOS settings changes? Did you move a drive from one port to another?

 

Waiting for root device means that OSX has been asked to take over the booting but it can't find the drive it is supposed to boot.

 

Oh, and if we had known about the PS/2 keyboard, we could have added that to the initial customization. If we do get to the Desktop, you might not be able to do the initial setup because it requires typing in information and the keyboard may not work.

  • Like 1

The commands you typed were perfect.

 

You rebooted with -v -f and not -v -x, right?

 

The only thing that caused "waiting for root device" was booting with -x. We have done nothing else to cause this. Did you make any BIOS settings changes? Did you move a drive from one port to another?

 

Waiting for root device means that OSX has been asked to take over the booting but it can't find the drive it is supposed to boot.

 

Oh, and if we had known about the PS/2 keyboard, we could have added that to the initial customization. If we do get to the Desktop, you might not be able to do the initial setup because it requires typing in information and the keyboard may not work.

 

 

Important Update:

 

I am in .... it worked. I booted in normal mode [ without any commands] and now I am in the second part of the installation. My keyboard and Mouse are not working though. Do I need a USB keyboard to make it work or is there a way to activate my keyboard?

 

r2kilw.jpg

 

 

When I have my Hackintosh running, I will be more than happy to donate to you for helping me.

You need PS/2 drivers for your keyboard.

 

The only thing I can think of is to do this all again: install just like you did with Chimera and GraphicsEnabler, but this time also check PS2. Then reboot with the install DVD and perform the Terminal commands. Then reboot without the DVD, but at least boot with -f because that makes the system aware of the moved kexts.

  • Like 2

You need PS/2 drivers for your keyboard.

 

The only thing I can think of is to do this all again: install just like you did with Chimera and GraphicsEnabler, but this time also check PS2. Then reboot with the install DVD and perform the Terminal commands. Then reboot without the DVD, but at least boot with -f because that makes the system aware of the moved kexts.

 

 

DUDE, I FREAKING LOVE YOU.

 

I am in now, already in the desktop.

 

I don't seem to have Internet or sound.

I hope you have a usb flash drive or something.

 

For sound, download VoodooHDA.kext.zip. Put it on your Desktop. Double-click it to unzip it. Double-click it to install it. Reboot.

 

http://code.google.com/p/voodoohda/downloads/detail?name=VoodooHDA-2.7.3.pkg.zip

 

For internet, if it is an Intel wireless system, you will need to replace it with a Broadcom system. But lets find out what you have. Download the program System Info, run it and provide a picture of the Devices tab output.

 

http://www.insanelymac.com/forum/index.php?showtopic=219584

  • Like 1
I hope you have a usb flash drive or something. For sound, download VoodooHDA.kext.zip. Put it on your Desktop. Double-click it to unzip it. Double-click it to install it. Reboot. http://code.google.com/p/voodoohda/downloads/detail?name=VoodooHDA-2.7.3.pkg.zip For internet, if it is an Intel wireless system, you will need to replace it with a Broadcom system. But lets find out what you have. Download the program System Info, run it and provide a picture of the Devices tab output. http://www.insanelymac.com/forum/index.php?showtopic=219584

 

 

Here are the pictures for the System Info

http://imageshack.us/f/846/img0194lx.jpg/

http://imageshack.us/f/189/img0193rq.jpg/

 

 

There is one weird problem.

 

After I installed VoodooHDA and rebooted, this time I heard a very loud beeping sound and the screen showed error. The sound is similar to this video I found on Youtube. Skip to 58 seconds

 

OK, the VoodooHDA package comes with an uninstaller. I don't know how well it works. There is also a Control Panel with settings to play with that might help.

 

Control Panel: Go to the Apple Menu and select System Preferences. Find the VoodooHDA control panel near the bottom and play with some settings.

 

If you want to remove it, you need Terminal. Select the Go menu and then select Utilitities. You will find Terminal

 

Open Terminal

 

Type:  sudo /usr/local/bin/voodoohda-uninstall
(it will ask for your password - just type the password - the cursor won't move and there will be no feedback - just type the password and press <Enter>

 

As for the pictures you posted. I only needed the first one,, but I'm having a little trouble reading it. I need the vendor id, the device id and the full device title to the following:

 

Broadcom 802.11 b/g/n

Broadcom Gigabit Ethernet

High Definition Audio

 

For internet, do you prefer the wireless or the ethernet?

  • Like 1

OK, the VoodooHDA package comes with an uninstaller. I don't know how well it works. There is also a Control Panel with settings to play with that might help.

 

Control Panel: Go to the Apple Menu and select System Preferences. Find the VoodooHDA control panel near the bottom and play with some settings.

 

If you want to remove it, you need Terminal. Select the Go menu and then select Utilitities. You will find Terminal

 

Open Terminal

 

Type:  sudo /usr/local/bin/voodoohda-uninstall
(it will ask for your password - just type the password - the cursor won't move and there will be no feedback - just type the password and press <Enter>

 

As for the pictures you posted. I only needed the first one,, but I'm having a little trouble reading it. I need the vendor id, the device id and the full device title to the following:

 

Broadcom 802.11 b/g/n

Broadcom Gigabit Ethernet

High Definition Audio

 

For internet, do you prefer the wireless or the ethernet?

 

I do not have access to the Desktop anymore, after that loud sound, the screen crashes. Here is a picture from Google similar to what I see after that sound. It's not the exact same thing, but very similar.

 

 

2libx53.jpg

 

 

 

Can I Uninstall

VoodooHDA from the Terminal in the installation screen?

 

 

If not, I think I have to re-install iAtkos L2 again.

 

Once I am in the desktop, I will give you the rest of the details, and yes I prefer wireless.

No, I don't think you can do it from Terminal on the install DVD. You can run the program, but I'm betting it will try to delete it from the DVD, not the hard drive.

 

You have PS/2 now. Try booting into single user mode (-s) and if that doesn't work, try (-s -x).

 

At the command prompt:

 

Type:  mount -uw /
Type:  cd /usr/local/bin
Type:  ./voodoohda-uninstall

 

Reboot -f

 

Update:

 

Yes, there is something you can do from the Terminal on the install DVD.

 

Open Terminal

 

Type:  cd "/Volumes/Lion"
Type:  cd System/Library/Extensions
Type:  rm -rf VoodooHDA.kext

 

Reboot -f

  • Like 2

No, I don't think you can do it from Terminal on the install DVD. You can run the program, but I'm betting it will try to delete it from the DVD, not the hard drive.

 

You have PS/2 now. Try booting into single user mode (-s) and if that doesn't work, try (-s -x).

 

At the command prompt:

 

Type:  mount -uw /
Type:  cd /usr/local/bin
Type:  ./voodoohda-uninstall

 

Reboot -f

 

 

The single user mode (-s) gave me the loud sound again and the

-s -x gave me the "Still waiting on root device".

 

I do not mind doing the installation again, it should be fairly quick. I will give you the pictures when I am done, sorry for not doing it right the first time. I will be right back.

 

×
×
  • Create New...