Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

9 posts in this topic

Recommended Posts

Hi Guys,


I have a little problem.

I have a dell inspiron n4050 laptop with following specs


CPU: Intel Pentium Dual Core 2.1 GHz B950


Graphics: Intel HD Graphics Family with Max VRam = 783 and id=0x0106


I have tried many different solutions to work graphics card properly on my laptop but in vain.

I am only able to get the desktop view if I delete all AppleIntelHDGraphics* kexts but there is no acceleration at all. Every thing runs very slowly in snow leopard as well as in lion.


Does anybody how to make it work and enable qe/ci?

Any help would be appreciated.


Thanks in advance.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By oliveiro
      I know veterans from the hackintosh community claimed that Intel HD 2500 is not supported and doesn't work, but mine (mobile version) works with High Sierra, as it did back with every versions since Mountain Lion.
      I formerly started a topic here for ElCapitan : http://www.insanelymac.com/forum/topic/316981-intel-hd-graphics-ivy-b-hd-2500-qeci-for-osx-1011/
      This should apply to any laptop with following CPU (mobile Ivy Bridge)
      Intel Pentium 2030M, Intel Pentium 2020M, Intel Celeron 1020E, Intel Celeron 1020M, Intel Pentium 2127U, Intel Celeron 1005M, Intel Pentium 2117U, Intel Celeron 1000M, Intel Celeron 1037U, Intel Celeron 1017U, Intel Celeron 1007U, Intel Celeron 1047UE, Intel Pentium 2129Y, Intel Celeron 1019Y, Intel Celeron 927UE
      I guess following Desktop CPUs owners should be able to make it work (It probably requires DSDT edits to enable the proper output, on my laptop I only use and tested LVDS)
      Intel Core i5-3550, Intel Core i5-3470, Intel Core i3-3220
      My Laptop is an Asus (F301A-RX229H) with an Intel Pentium Mobile 2020M, which includes an Intel HD Graphics, not labelled 2500, but it has 6 execution Units like the 2500, and approximately same clock settings (650-1100) instead of 650-1150 for HD2500. You can check specs here and here. Most importantly, it is identified by bootloader and MacOsX/macOS as "Intel HD Graphics 2500" and uses HD4000 kexts.

      Few Graphic Glitches (windows title bar, dock...) solved by reducing transparency in Accessibility Preferences Panel.

    • By CoreyMoreTech
      Hello. I am trying to get my Intel HD Graphics 3000 to work with full acceleration support and full resolution. Currently I am stuck with 1024x768 when the display is capable of 1600x900. I am running Sierra 10.12.3 and I am unable to change the SMBios from iMac14,2  
      Specifications are as follows:
      Make: Lenovo
      Model: ThinkPad T520
      CPU: Intel Core i5 2540M 2.4GHz
      GPU: nVidia NVS 4200M + Intel HD Graphics 3000 (nVidia disabled)
      RAM: 8GB DDR3
      HDD: 320GB Seagate HDD
      I am fairly new to Hackintosh/Hackbooks and have never successfully hackintoshed a device. Any help would be greatly appreciated. If any extra information is required I can provide.
    • By pabloegpf1
      Hello everyone,
      Some days ago I started a new Hackingtosh project with my Lenovo yoga 3 14. It's the first time I have tried to do this so I'm a bit confused.
      Quick recap:
      First I downloaded a OSx Sierra image and created a bootable USB drive with transmac on Windows Installed Clover in the USB After many attempts and changing my clover options a hundred times I finally got to install OSx Sierra on my main SSD Drive Then I installed clover on the SSD so I can boot without the USB  Now, here is the problem:
      I have been trying to fix my graphics and audio/wifi. I've used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], KextUtility but neither of them worked... (I know I can't ask for support on these tools)
      I'm not sure what kexts to install because I'm not able to gather my system's components, also don't know how to install them
      could anyone help me please?
    • By jack-69

      DISM is your friend!
      Part 1: (For all the computers that don't have UEFI)
      Prepare two USB keys, one with El Capitan & one with Windows 10.
      First put the Windows USB, during the installation (when it asked the Windows code) press shift + f10 and will open the command prompt:
      diskpart list disk (list of your hdd) select disk 0 (0 is number of your hdd) clean (ATTENTION clean all your hard disk selected) convert gpt create partition efi size=200 (creates EFI partition) format fs=fat32 label=EFI We made a EFI partition.
      In my Hdd I have 3 partitions ( 1 for Mac, 1 for Windows=Ntfs & 1 in exFat for sharing files between the two systems).
      create partition primary size=100000 (1 partition for Mac OS X 100GB) format fs=fat32 quick label=Mac (after we will format in HFS+ with disk utility) create partition msr size=128 (creates Microsoft Reserved) create partition primary size=100000 (1 partition for Windows 10 100GB) format fs=ntfs quick label=Windows (format in Ntfs) create partition primary (creates a partition with the remaining space) format fs=exfat quick label=Hdd (format in exFat) Now the fun part.
      We should insert the letters for the partitions. Check
      select disk 0 list volume (check the assigned letters, REMINDS the letter assigned to the USB "example d") list partition (check the number of partition EFI "example partition 1") select partition 1 assign letter=h list partition (check the number of partition Windows "example partition 3") select partition 3 assign letter=g exit Then we have the letter "D:\" for the USB, "H:\" for the EFI partition & "G:\" for the Windows partition.
      Now we need to copy the installation files from the USB to the Windows partition.
      cd\windows\system32\ dism /apply-image /imagefile:d:\sources\install.wim /index:1 /applydir:g:\ Break....
      Now we need the Windows EFI boot files.
      cd\ g: bcdboot (check the command line) bcdboot g:\windows /1 en-us /s h: /f UEFI (in my case "/1 It-it") Restart the computer with the Mac USB "Clover bootloader", then select Microsoft EFI and start the installation of Windows 10 in FULL GPT. 
      If you don't see the exFat partition in Windows don't worry.
      (Take a program like Partition Wizard, format the partition in NTFS  and assigns the letter D:\. Now open the command prompt administrator and write:
      diskpart select disk 0 list partition (check the partition before-exFat = after-NTFS "example partition 4") select partition 4 format fs=exfat quick label=Hdd Now you must have the partition exfat visible and writable)
      Part 2:
      Don't format or delete the EFI partition.   
      From the Mac USB we need delete AppleIntelHDGraphicsFB.kext. 
      Now we go in to the installation of El Capitan, with disk utility format the partition "Mac" in HFS+ mac journaled, then install Mac OS X.
      While starting El Capitan from your hard drive, we must block AppleIntelHDGraphicsFB.kext and AppleIntelHDGraphics.kext. (& add cpus=1 or patch with clover)
      When El Capitan is started:
      Patch AICPM with Clover Configurator Install Clover like this  (of course without installation El Capitan) "Legacy mode" Replace the config.plist in EFI partition and add SMBIOS with clover configurator - macbook pro 6.1 Put the DSDT Put HFSPlus.efi, NTFS.efi in drivers64 folder Insert and replace all kext PS:During the first system start we must go in the system preferences, keyboard, shortcuts and change the key combination of brightness (f2- f3+).
      Intel Core i5 460M
      Intel HD Graphics                                      (Clean graphics without artifacts)
      Wifi & Ethernet                                          (Atheros AR9285 & Realtek 8111)
      Stereo speakers & Microphone                    (IDT92HD81B1X5)
      Keyboard & multi-touch touchpad
      Memory Card Reader
      All USB
      Sleep & Wake
      Brightness Values
      App Store
      Don't work: 
      ATI Mobility Radeon HD 5470                      (Blocked by BIOS)
      FaceTime                                                   (With Rom,SN,MLB valid work)
      iMessage                                                   (With Rom,SN,MLB valid work)
      Thanks : GhostRider - pokenguyen - Mirone & Micky1979 - RehabMan
      HP El Cpitan.zip
    • By oliveiro
      I have an almost fully working Intel HD Graphics in ElCapitan.
      At least QE & CI are working. I had graphic glitches in Dock background and windows titles, apparently due to my MBP9.2 SmBios (which I want to keep for Power Management reasons)

      It's on an Asus Laptop (F301A-RX229H) with an Intel Pentium Mobile 2020M, which includes an Intel HD Graphics, not labelled 2500, but it has 6 execution Units like the 2500 series, and approximately same clock settings (650-1100) instead of 650-1150 for HD2500. You can check specs here and here. It seems like it's a lower end HD2500.

      Vendor ID 8086 of course, Device ID 0156, rev 0009.
      I use chameleon with GraphicsEnabler=Yes, GraphicsMode=1366x768x32, IntelCapriFB=3
      (with Moutain Lion, previous setup on the same laptop, with QE/CI too, required IGPlatformID=01660003)
      I have vanilla AGPM and IntelGraphics kexts, SmBios MacBookPro 9.2, as mentionned before, and a custom DSDT, device is named GFX0.

      Graphic Glitches were solved (accordingly to real macbookpro users forums) by reducing transparency in Accessibility Preferences Panel.

      Hope it helps.