Jump to content

[MiniGuide] LION 10.7.3/4 on HP NC6400 (VGA Intel) & NC4400



13 members have voted

  1. 1. Have you successfully installed your OSX following this guide?

    • Yes
    • No

41 posts in this topic

Recommended Posts

Hi to all!!! I have now completed my first installation of LION 10.7.3 (Vanilla) on this OLD NC6400 (intel VGA) starting from my previous guide about Snow Leopard 10.6.7 http://www.insanelym...dpost&p=1737233

After few attemps and research, I found a way to have a 95% working hackintosch on this really old notebooks.

Anyway first of all sorry for my really bad English!!!!


I HAVEN'T YET TRIED TO INSTALL LION ON NC4400 but I believe that it's the same as NC6400!!! I will update the information as soon as possible. Because of our GMA950 the Lion works only in 32bit. If you want 64bit you will use VESA basic driver!!!!



HP NC6400

- C2D T7200 @2.0Ghz 667FSB 4MB L2 (used T5500, T2300 and T2500 too)

- 4GB RAM DDR2 667 (SL uses only 3.38GB!!)

- HDD 80GB Sata 5400rpm

- Intel Graphics GMA950 with 224MB dedicated (SL can see only 64MB!!)

- Wireless Broadcom Corporation BCM4312 802.11 a/b/g



- DUAL CORE working at 100% (thanks to Slice's clover bootloader!!!!)

- WIFI Broadcom (ootb)

- LAN Ethernet Gigabit (using specific kext)

- Bluetooth (fixing the DSDT)

- VGA with QE/CI enabled (fixing the DSDT and using GraphicsEnabler=Yes)

- Brightness controls with keys 'scorr' and 'pause' (ootb)

- Volume controls (using Audio Kext)

- Audio (using Audio Kext)

- PCMCIA (using specific kext)

- Card Reader only by PCMCIA or USB adapter

- Internal Keyboard (using a specific Kext)

- Touchpad Synaptics (using a specific Kext)

- DVD burner (ootb)

- Internal MIC (using Audio Kext)

- Battery (ootb) * UPDATE 11/04/2012:


- Lid sleep

- VGA-OUT only in Extended mode


UPDATE 11/04/2012:

(*) Still some KP using VoodooBattery on: AppleACPIPlatform (1.3.5), IOACPIFamily (1.4), IOPCIFamily (2.6.7) and naturally VoodooBattery (1.3.3)

Thanks to 0xcafebabe (Markus) to have found an alternative kext for battery management that seems to have resolved the KP generated from VoodooBattery. I have tested it since 2 hours (with and without power adapeter). Till now no KP!!!! Great Markus!!!





- Internal Card Reader from TIxx12. The problem is here: "SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]". I have not found any driver for this!!!!

- Fingerprint recognition HELP

- Infrared port (???)

- Internal 56K Modem: it's only a WIN-MODEM (WIN=WIndows!) Absolute no support in OSX

- VGA-OUT in mirror mode!! (if you try, u will see vertical lines. To restore the situation use the command line tool: 'mirror -off'. You can found it easy on google or in my previous guide about 10.6.7 on nc6400.



- Notebook as above

- USB Keyboard and mouse (for installation)

- USB Pen of minimum 8GB

- Another Real Apple/Hackintosch PC would be better to prepare all the necessary steps

- Internet



- Be sure to enable "SATA Native mode" (AHCI) for better performance

- Enable "Dual Core". If you have some errors please DISABLE dual core on BIOS end NOT use CPUS=1 as boot arg. If you use the arg you will have the CPU always more than 80° C !!!!


P.S. if you prefer, you can use a BIOS patched to remove Whitelist for Wireless Card.



- Download a RETAIL dmg of OSX LION 10.7.3 buildversion 11D50. I have used a .torrent. Be sure to find a RETAIL DVD and not a modified one (Hazard, iATKOS, etc etc...). The image is circa 3.7GB

- Download MyHack 2.2 and follow the guide http://myhack.sojugarden.com/guide/ to create a USB Pen for LION 10.7 and at the end install Chameleon + Extra

- To avoid KP with ApplePolicy kext, be sure to copy a valid SMBIOS.plist under /Extra of the USB pen. To create a good SMBIOS file you can quite use Chameleon Wizard and generate one as MBP3,1

- Copy in Extra the dsdt.aml and modify the org.chameleon.Boot.plist adding these value manually or with Chameleon Wizard:

arch=i386 -v GraphicsEnabler=Yes npci=0x2000 Graphics Mode=1280x800x32




- Insert the new USB Pen, USB Keyboard and USB Mouse on your notebook, power it on and boot from USB (press F9). A Chameleon should appear and wait 5 seconds.

- Now begin the classic OSX wizard (languages etc). Using "Disk Utility" prepare your HDD as you prefer. I used MBR partition table. Ad hoc installation doesn't work: it appears empty. It depends from changes made by MyHack2.2 process don't worry!

- After 15/18 minutes the installation will finish and reboot the notebook

- Please let the USB pen inserted and when chameleon appears, press a key and choose your new HDD OSX partition and press enter. Now the wizard will continue to the end.



- When you are on SL 10.7.3 you have to make bootable your NEW OSX Partition. For that reason you have to launch another time MyHack 2.2 (that you can found on your USB Pen used for the installation). Please choose only the Chameleon + Extra.

- Copy dsdt.aml, smbios.plist and org.chameleon.Boot.plist from USB Key to /Extra folder of your Lion partition.

- Install/Copy at least on new LION partition: Chameleon Wizard, Kext Utility (last version) and Kext b7

- Install VoodooHDA-2.6.2.pkg to enable the audio

- Then, using Kext b7 utility, install ALL kext from my zip (they will be placed under S/L/E!!!)

- REMOVE ANY KEXTS UNDER /Extra/Extensions (ver. 351 of clover it's still not able to inject some Extra kexts to the system during boot process). So I prefered to install ALL under S/L/E.

- Run Kext Utility and wait

- Now you are ready to power off the notebook, remove USB Key, mouse and Keyboard

- Power on the notebook and be sure that all works fine!!!! (don't enable Dual Core from bios!!! it doesn't work!!!)


5) INSTALL LION UPDATES (Itunes, Airport Utility and Safari at this time):

- Install the updates if you prefer!!!



6) NOW THE MOST DIFFICULT PART: Enable the dual core

- All you need to do, it's to install the great NEW Bootloader created by SLICE: http://www.projectos...?showtopic=2304

- I have tested dozen of chameleon 2.1 from svn 15xx to 1902 (at this moment), Chimera 1.9.1 and others but none permitted me to boot the notebook in DUAL CORE mode!!!! So the last chance is the great SLICE. He has just made the miracle with his modified chameleon 2.0 rc5m ver. 1291 but it doesn't support LION OS.

- On my ZIP I have just prepared a Clover2 ver. 351 354 that works for NC6400 (basically I have removed the efi files of 64bit and ntfs, put the dsdt.aml on the right folder and modified the confg.plist file).

- Install clover2 it's not so different from manual installation of a chameleon. Instead of /Extra folder, you have to copy the /efi folder.

- DON'T FORGET TO INSERT YOUR CORRECT UUID and CHANGE your DefaultBootVolume as shown below, if not your clover will not boot!!!







- Change the RED code with your specific one!!!!



Any help would be greatly appreciated






DOWNLOADS from osx86.com (updated at 05/04/2012 09/04/2012)


HP NC6400 (Intel version) http://www.osx86.net...do=file&id=2603


On my installation, I have installed without any problem:

- Temperature Monitor 4.95

- CoolBook 2.22: it shows me 4 frequency values.


UPDATE 09/04/2012:

Update EFI folder using clover2 ver.354. Remove old EFI folder and copy new one provided by the above ZIP file on Lion Partition


UPDATE 11/04/2012:

I attach AppleACPIBatteryManager.kext for LION


UPDATE 11/05/2012:

I have installed Lion 10.7.4 update and it wasn't so fine for this installation: this update, install AppleHDA.kext which MUST be remove because it's incompatible with our VoodooHDA.kext. After the restart. I lost Wireless, FakeSMC, Battery. These kexts are still under S/L/E but they are "ignored" or boot with errors. I have repeated Kext Utility 2 times but without so great success. So I have reinstalled VoodooHDA, FakeSMC,AppleACPIBattery, IO80211Family.kext, then re-run Kext Utility and restart the notebook. Now I'm in 10.7.4... but noshing of special or more fast. Pay attention


I will provide here as soon as possible, a SMBIOS file for MBP2,1. The clover bootloader identify correctly the CPU and marked the notebook as MacBooPro 2,1 but after that, using my SMBIOS.plist file, it becomes MacBookPro 3,1. I want to try to use a file of 2,1. I will let you inform about it.



sh-3.2# lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)

00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 01)

00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 01)

00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 01)

00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 [8086:27d6] (rev 01)

00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 01)

00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 01)

00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 01)

00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 01)

00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 01)

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e1)

00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 01)

00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 01)

00:1f.2 SATA controller [0106]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller [8086:27c5] (rev 01)

00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 01)

01:06.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]

01:06.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]

01:06.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]

01:06.4 Communication controller [0780]: Texas Instruments PCIxx12 GemCore based SmartCard controller [104c:803d]

08:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5753M Gigabit Ethernet PCI Express [14e4:16fd] (rev 21)

10:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11a/b/g [14e4:4312] (rev 01)






  • Like 3
Link to comment
Share on other sites

I used your guide to install Lion on my tc4400. I worked pretty well, except


- my WLAN card is an Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] which does not seem to be supported

- I had to manually set the MAC of Broadcom Corporation NetXtreme BCM5753M Gigabit Ethernet PCI Express [14e4:16fd] to get an connection

- the Lion update broke the install, I now get an KP at PCCard

Link to comment
Share on other sites

hi 0xcafebabe, thank you for your feedback!!!

About WLAN ..... nothing to do!!! Buy a cheap broadcom 4312 b/g or a/b/g [14e4:4312] on ebay and u will have a full working Airport. I had the same problem and I have resolved so. Pay attention at your bios that implementes whitelist wireless card detection!!!!

About MAC address, I know this issue. create a rc.local and add the command inside, so you will have the right mac address every boot:



/sbin/ifconfig enx lladdr xx:xx:xx:xx:xx:xx


I have resolved using this way.


About Lion update.... did you started from 10.7.2 or from 10.7.3??? These kext are related: IOPCMCIAFamily.kext + ApplePCCard16ATA.kext + ApplePCCardATA.kext

I have noticed that inside IOPCMCIAFamily.kext (from Tiger OSX), under Plugins there is an old IOPCIFamily.kext I don't remember the version, but I noticed that OSX use this one instead the right under /S/L/E (ver. 2.6.7). Try to remove the old one under Plugins folder.

Maybe the KP depends by IOPCIFamily.kext.

My suggestion:

- be sure to use this kernel arguments: ncpi=0x2000

- Overwrite the IOPCIFamily.kext with one provided in my zip and run Kext Utility


Let me know



Link to comment
Share on other sites

Success! I updated to 10.7.3 before installing Chameleon.

Dual core works!


I wont change the wifi card, as the bios has a blacklist. Can someone recommend a PC Card or USB stick for Wifi?


Great! Thanks!

Link to comment
Share on other sites

hi 0xcafebabe, happy to hear about your success!!!


For a working dual core, are u using Chameleon or Clover by slice? If Chameleon, which version and svn have you installed?


Thank you





- Feel free to cast the poll of my thread

Link to comment
Share on other sites

Hi Pat,


I am using Clover for the working dual core, following your guide. Just like you, I failed with this machine and any Chameleon I tried.


Today, I purchased an Edimax EW-7811Un WLAN USB stick and i works just fine using their drivers (Realtek 7392:7811).


But I had to remove VoodooBattery.kext since it caused KPs. Do you have any idea on this?



Link to comment
Share on other sites

Hi Markus, I have noticed this behavior too but now I'm fighting with an audio kext of HP dv6366ea...... uhrggg. I will investigate on it in the next hours. If you wil find some fix, please post the solution





Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

I was able to successfully install OSX Lion 10.7.3 using this method.


When I first booted it after the install, it would also boot with the normal chameleon that comes with myhack with dual core enabled about half of the time. The sleep and power management worked perfectly. Keyboard, and trackpad worked OOTB. Graphis also work fine in QE/CI hardware mode.


When I installed all of the kexts, I experienced a VERY long boot time, like 5minutes. I also lost the trackpad. I removed the VoodooPS2 kext, and I got my trackpad back, and now it's booting in less than 30 seconds. The sleep was working normally as before. Audio and Ethernet work, though ethernet has the MAC-address problem. I created a program using applescript that runs and assigns the mac address using ifconfig everytime I sign into the computer. I have the Intel Pro 3945 wireless that doesn't seem to have any support for MacOSX at all. I'm trying to find a compatible wireless-n card that will work in the mini-PCIe slot. I installed the whitelist BIOS.


When I tried to install Clover, it would not boot at all, so I am apparently doing something wrong in the install. I was able to load the Enoch/Chameleon loader ver.1970 and it will boot with dual core enabled 9/10 times, and when it doesn't I reboot it right away and it works fine. However now sleep is not working at all, so I'm still working on that. Otherwise everything else seems to be working pretty well. Once I figure out the sleep issue and get a different wireless card I think I'll be set.

Link to comment
Share on other sites

Hi randallphoto and thank you very much for your feedback about this method. About Keyboard/touchpad maybe you have installed twice the kext (one in S/L/E and E/E) or you are triing to use ApplePS2 pacthed together with VoodooPS2. I have not idea about your issue.


Concerning chameleon, I haven't try your one and last version of Clover don't work well with our notebook (KP or error on Cloveria32 etc..) The last good was the version of my guide.


Please don't forget to update this thread with your suggestion and solutions


Thank you



Link to comment
Share on other sites



I search a DSDT.Aml for NC64000 (VGA Intel) for Lion and on your Miniguide i don't see a DSDT (sorry for my bad english i'm french)


Hi mystique88, the DSDT.aml is included in my ZIP under EFI/ACPI/patched


Anyway if u prefer a direct link, please have a look on my other Miniguide for Snow Leopard




For Lion I have used the same



Link to comment
Share on other sites

Thanks for the rapid answer :) I want install Mac OS Lion, Myhack 3.1 works on this guide ?


Hi, on this laptop Lion is not so good. I noticed some freezing specially after login. Then it will return normal, but I have not so many time to investigate about. However, reading the changelog myHack 3.1 should work well. I have just upgrade fakesmc to 4.2 with some plugins withou problems. Please report your results so I will update my miniguide. Have a nice day



Link to comment
Share on other sites



I have a probleme, I following the guide step per step, and after this action : 4 - First use [...]

Power on the notebook and be sure that all works fine!!!!


I have a grey screen or CPU is Halted (CPU is configure on single core)



Snow leopard works better than Lion ?


My CPU is a Intel T5600, i Edited a smbios.plist, i configure so a frequency

Link to comment
Share on other sites



I have a probleme, I following the guide step per step, and after this action : 4 - First use [...]

Power on the notebook and be sure that all works fine!!!!


I have a grey screen or CPU is Halted (CPU is configure on single core)



Snow leopard works better than Lion ?


My CPU is a Intel T5600, i Edited a smbios.plist, i configure so a frequency


Hi, please force the -v arguments on startup so you can quite understand what it's wrong. If u are not able to explain the point where it blocks, please post a picture of the error.



Link to comment
Share on other sites

How add arch=i386 in first boot without key usb ?


By the picture I notice that you are using a DELL. Is it an external monitor attached to an HP NC6400 or a DELL notebook????


about arguments, stop chameleon boot process (pressing F8 or a key different from ENTER) on volume selection screen. Point the selector to your USB device and write using keyboard your arguments like below:


arch=i386 -v


Pay attention that the keyboard layout is American!!!!!



Link to comment
Share on other sites


i did your guide exactly everything is working except my standby.


when turning on dual=core on BIOS my system cannot boot up with my Logitech Unified Reciver in place. so i need to take tat out.

and after the Lion is on when entering standby my system stuck.


i found a solution and is that if i turn off dual-core the system is fully working which means something is not fully support dual-core.


i hope you could find the problem for this because the system is pretty slow when using only 1 core with Parallels :-.



thanks again for your time and effort on this great project.

Link to comment
Share on other sites


  • Create New...