Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Enabling Intel HD 3000 in Lion — Gateway ID47H06u

7 posts in this topic

Recommended Posts

OK, so I installed Lion with iATKOS L1, following the instructions here.


With AppleIntelHDGraphics.kext (and related files, see below*) installed, which I believe iATKOS did at my request, the computer could only boot in Safe Mode (and then, obviously, it was not getting graphics support).


If I remove these kext files and use the repair utility in Kext Wizard, the computer boots up fine, except again there is no graphics support. So now I want to fix this issue, and get these kexts working correctly.


Is it worthwhile to download AppleIntelHDGraphics.kext from the Internet and try to install that copy? I tend to assume that all copies of it are going to be the same thing, but I could be wrong. Or does something more involved have to be done?



For reference, the last few lines I get from the verbose printout when AppleIntelHDGraphics.kext is installed are as follows.

BSD root: disk0s2, major 14, minor 1
Kernel is LP64
com.apple.launchd 1	 com.apple.launchd 1	 *** launchd[1] has started up. ***
com.apple.launchd 1	 com.apple.launchd 1	 *** Verbose boot, will log to /dev/console. ***
Running fsck on the boot volume...
** /dev/rdisk0s2 (NO WRITE)
** Root file system
  Executing fsck_hfs (version diskdev_cmds-540.1~34)
BootCacheControl: Unable to open /var/db/BootCaches/PreheatedUser/Merged.playlist: 2 No such file or directory
BootCacheControl: Unable to open /var/db/BootCaches/PreheatedUser/Login.playlist: 2 No such file or directory
macx_swapon SUCCESS
Waiting for DSMOS...
nstat_lookup_entry failed: 2
nstat_lookup_entry failed: 2
Previous Shutdown Cause: 3
DSMOS has arrived
ACPI_SMC_PlatformPlugin::startForReal - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
Transcript Offline - Buffer Pool Allocate [181000] failed

At which point it hangs



Computer details:

  • Intel Core i3-2330M
  • Intel HD 3000 integrated graphics

(these are the things I know are useful information; if more is necessary I can provide, just let me know what's actually relevant)



* I also removed files from S/L/E that seemed related to the HD Graphics. A full list:

  • AppleIntelHDGraphicsGLDriver.bundle
  • AppleIntelHDGraphicsVADriver.bundle
  • AppleIntelHDGraphics.kext
  • AppleIntelHDGraphicsFB.kext
  • AppleIntelIntegratedFrameBuffer.kext
  • AppleIntelSNBGraphicsFB.kext
  • AppleIntelHDGraphicsGA.plugin

Also, I removed AppleIntelCPUPowerManagement.kext and AppleIntelCPUPowerManagementClient.kext, since those were giving that timed out message at the end of the verbose print-out. Fixing those would also be good, but that's another issue (and there are other similar things I want working, like the ethernet card. But first things first).

Share this post

Link to post
Share on other sites

i am not familiar with iATKOS but try this, edit your boot.apple.plist file (cant remember where it is maybe in library/... or system/...) and add something (off the top of my head) like





(if yours says 'yes' then try 'no')

Thats the main one,




<key>Graphics Mode</key>

<string>1280x1024x32 (your screen res here)</string>


If that dont work then im stumped!

Let me know if it works

Share this post

Link to post
Share on other sites

keep the files that was originally on the OS when u installed it. Intel's HD 3000 graphics is natively supported on Lion due to the Mac Minis using it. So if u deleted it then yes put it back on...

Share this post

Link to post
Share on other sites

OK, I tried using the GraphicsEnabler=Yes "Graphics Mode=1440x900x32" boot arguments (rather than modifying plist), and that didn't work.


I haven't tried modifying plist because there were some issues with the install, so I figured I'd start fresh and reinstall. Unfortunately, that failed for some reason and I don't have time to start from scratch right now (there was no boot loader on the USB stick because I'd had one on the HDD, but now I don't). Continuing this project will have to wait until the weekend.

Share this post

Link to post
Share on other sites



intel hd 3000 only have full support in 10.7.2 or 10.7.3


see if the that 2, appleintelhd3000.kext and AppleIntelSNBGraphicsFB.kext have u device id


and should work


good hack

Share this post

Link to post
Share on other sites

Ah, that's very good to know; I'll double-check which version of Lion that iATKOS has. How do I determine the precise device ID for my computer? I've actually had a lot of trouble tracking down precisely which makes/models/versions of various components - I recently learned about lspci for the PCI components, which has helped, but the processor is not a PCI component...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By johnverz
      Hardware Info: HP ENVY Sleekbook 4-1009tu 1.4GHz i3-2367M (check here)
      MacOS version: Sierra (10.12.3)
      Please help me make Intel HD 3000 work with this machine. I tried to patch DSDT using MaciASL but to no avail. I am having screen glitch, poor graphics performance, no glass interface and only 4MB graphics memory. I cannot change screen brightness too. I attached my config.plist and my DSDT.aml file. Please help. Thank you
    • By shivadellvostro3550
      I want to hackinstosh dell vostro 3550 for ios development.
      My laptop specs.
      Processor - i3- 2310 M 2.1 GHz
      Graphics - Intel HD 3000 with Switchable AMD Radeon HD 6630M
      RAM - 8GB
      Hard Disk - 500GB 5400rpm 
      i have been studying different forums and watched some tutorials. I am now familiar with terminology and procedure. I came across some posts on Stackoverflow  that intel HD 3000 has problems with Xcode and Android Studio emulators on Mac OS. I also found some threads mentioning Audio has some problems on intel sandybridge hd 3000 graphics laptops.  
      Can anyone tell me if i can use hackintoshed laptop for both ios and Android development?
    • By edgaarcervantes
      Les dejo un antecedente de mi problema:
      Hace unos meses instalé Hackintosh en mi pc, a travez de un .dmg de Yosemite-Zone que encontré por ahí en un video de Youtube. Deje el sistema como venía, solo instalé el driver de red wifi a travez de un .kext y así lo estuve utilizando por mucho tiempo.
      Se descompuso mi pc y tarde mucho en mandarla a reparar, después de un tiempo ya la tengo disponible y decidí retomar el proyecto que tenía.
      Fui por ahí instalado los drivers que me faltaban, Ethernet, USB 3.0, Hot Key, Bateria, etc., todos estos a travez de .kext, tuve suerte pues no batalle en lograr instalarlos, había un monto de archivos en la red, si no funcionaba uno intentaba con otro (todos de acuerdo a mi hardware); Pensé que no me faltaba nada hasta que conecté la pc al televisor, me di cuenta que no funcionaba el audio de la TV si no el de los altavoces internos de la computadora.
      Me quise dar a la tarea de solucionarlo, cosa que no pensé fuese tan difícil, puesto que todos los post que he encontrado son en ingles y hablan de un idioma que totalmente desconozco, que si tengo que parchar los dsdt, ssdt o config.plist, un montón de cosas que no logro entender.
      Estuve intentando hacer alguno de los tutoriales que ofrecen pero, siempre me estanco en ciertos puntos. No pude encontrar ningún tutorial en español acerca de mi hardware.
      Quisiera saber si alguien puede orientarme para poder solucionar mi problema
      Les dejo algunas características de mi pc:
      - Tarjeta madre: Asus k43e
      - Procesador: i3 2350m 2da generación
      - Gráficos: Intel HD 3000
      - Audio: Realtek ALC 269
      - Sistema: Yosemite 10.10.5
      No sé si sea necesario alguna otra información o que anexe mis .dsdt o ssdt.
      Anticipadamente, gracias.
    • By Newbie Mac
      Ciao a tutti,
      sono felicemente riuscito a installare Lion sul mio Optiplex 330.
      Funziona tutto tranne la scheda audio interna ma non importa perché vorrei installare una USB esterna: una Yamaha AG03.
      Dalle istruzioni questa dovrebbe essere installata su Lion senza driver e riconosciuta subito (http://www.yamahaproaudio.com/global/en/products/mixers/ag/manual/mac/index_en.jsp).
      Su un altro hackintosh sempre con Lion viene riconoscita perfettamente.
      Il sistema la vede, nel System Report, correttamente collegata all'USB ma da Audio Midi Setup mi dice "NO DEVICES FOUND".
      Temo che mi manchi qualche parte software per far riconoscere la scheda esterna.
      Ho installato i VoodooHDA ma mi hanno mandato in crash il sistema quindi li ho rimossi.
      Avete consigli?
      Grazie mille
      Retroman Newbie
    • By alainkalender
      Hello everyone,
      I'm new to this forum, I'm really searching for some help with my "project" and hope some of you can help me out with this one!
      It's all coming down to a not starting "Finder"
      The full story,
      I bought a Mac Pro 1.1 (2006) a few day's ago. All stock, dual Intel Xeon 3Ghz, 5GB Ram and the stock video card (256MB). (Lion freshley installed)
      I wanted to upgrade to OSX El Capitain, and after a lot of research and a lot... yes a lot of trouble in making it all work I finally got it. I've thrown in a Geforce GTX 760 2GB Jetstream... couldn't wait to get cables for powering it, so I frankensteind it all with a second PSU. Installed Lion on a Samsung 850 EVO, and then followd a tutorial on how to install el capitain using Piker's boot. 
      After 12 hours non stop messin around it worked, only after some time the mac froze and rebooted. I noticed that maby Google Chrome caused this to happen, and when using Safari it would work without any problem. I even can play 4K flawless.
      But still after some time it would crash, I monitored the CPU and Ram Usage, but there wasn't anything crazy happening at those things.
      .. didn't really got the time to instal other apps. Then I found out Finder wasn't responding. It kept on crashing. I tried a lot of things... deleting the plist files, resetting PRAM, VRAM, Savebooting, deleting cache, Disk repair (Disk Aid)... nothing worked.
      Is this maby a problem with the bootloader (Pike)?
      I hope someone can help me out!
      Thanks in advance,
      Greetings from Holland