Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


iAtkos L2 install problem on MSI P6N SLI-FI

5 posts in this topic

Recommended Posts




Hi guys. I downloaded the iAtkos L2 DVD and restored it on a usb flash drive through osx 10.6 i have already installed on my PC. If I tried booting from the usb just like that, I got the still waiting for root device error after loading kexts, so I just copied the AppleNforceAta.imk64bit.kext from Verdant's files (a big thanks to Verdant for his helpful post), and I managed to surpass this. However now after a while, the loading hans at a point with this message:


BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 no such file or directory

Bug:launchctl.c:2408 (24687):30: cdefd =open (g_overrides_db_patch....


and can't start the installation. Somewhere I read that a fakeSmc will fix this, so I also tried different fakesmc's from verdant's files again but now it doesn't even hang, it immidiately restarts the pc without having time to see the error.


Any ideas on what to do in order to be able to finally start the installation? THanks


UPDATE: For usb flash to boot normally, just copy AppleNForceATA.imk.64bit.kext and NforceLAN.kext in S/L/E from Verdant's files and install Chameleon Bootloader on USB from Verdant's files also. After install, you must boot in the installer again and install through the terminal, the chimera 1.9.1 bootloader on your OSX Volume. This requires that you have downloaded the chimera package and saved it somewhere. You can install it this way:

Let's say you have downloaded chimera to the root of your usb installation flash. Boot in the installer like you firstly did, and when it opens, select utilities and open Terminal. It will start a Terminal directly with administartor permissions (bash-3.2#)


cd / (to move to top directory)

cd Volumes/USBFLASHNAME (Because we said that we downloaded the chimera package there)

installer -pkg chimera-packagename.pkg -target /Volumes/OSX-VolumeName (replace the names with the corresponding ones from your configuration)


This should have done it. Just select restart and boot from your hard disk. It should continue normally the boot into the system.

Hope I helped

Share this post

Link to post
Share on other sites

CORRECTION: Forget the restart, there was an error with chameleon. I tried with the other boot files (boot0 and boot1h) from EFI 10.6 and the boot file from netkas 10.7 as verdant suggested in his post, But now loading hangs at:

USBMSC identifier (non-unique) and some numbers.

Now what?

Share this post

Link to post
Share on other sites

After using the latest chameleon on the USB flash and kexts for nforcelan and sata I managed to get through with the install. After install I put these kexts again in the S/L/E folder in hard drive ( otherwise still waiting for Root device appears) but now the install hangs at waiting for DSMOS. I have read different solutions like using the latest FakeSMC or deleting the Don't steal Mac os.kext but none of three work. What now?

Share this post

Link to post
Share on other sites

UPDATE: Finally I found out that it was a matter of the bootloader beeing used. All this time I was using the versions os Chameleon Bootloader (including the one from the iAtkos setup and the one from Verdant's files from his guide about Lion on NForce). When I switch to the latest version of Chimera (1.9.1) it booted in the os normally and finished the configuration. Unfortunately I didn't have some drivers like audio but I think this will be easier to fix.... So waiting for DSMOS problem was bootloader related for me. Thank you, please mark this as Solved.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dcd_
      he logrado instalar en mi PC iAtkos L2 con éxito y después actualizado a 10.7.5. 
      El sistema es:

      Placa base Gigabyte EX-38 DS5
      La gráfica es una ASUS 210 Silent de 1GB de RAM
      8 GB de Memoria RAM

      Para la instalación en la personalización usé configuración en BIOS AHCI aunque también marqué IDE porque tengo un disco IDE aunque actualmente no lo tengo conectado.

      Para el audio utilicé el chip 889A que es el que corresponde al Realtek que tiene la placa. El inconveniente que tiene es que no consigo que funcione el micrófono.

      En cuanto a la tarjeta de red, también la detecta perfectamente, es la Realtek Gigabit. 

      Para actualizar de 10.7.2 a 10.7.3, de 10.7.3 a 10.7.4 y de 10.7.4. a 10.7.5., siempre me daba error descargando las actualizaciones de 'actualización de software', por lo que opté por bajarlas manualmente e instalarlas. Antes de reiniciar, lo que hice, fue restauras los premisos utilizando Kext Utility.

      Se puede resumir que los únicos problemas que tengo por el momento son que no funciona el micrófono con Skype (con otros programas sí me funciona bien) y no consigo que funcione Teamviewer.

      También estoy a ver si puedo hacer funcionar una tarjeta de tv/sat/radio Hauppauge HVR4000. Ya contaré si lo consigo. 
    • By vhj1995
      Installing Apple Mac OS X 10.7.2 Lion (iATKOS L2)
      ON Lenovo G570
      For Installing Apple Mac OS X OS 10.7.2 Lion ported by iATKOS Team. Codename for This Distro : iATKOS L2. Now I experiment that on my Lenovo G570 and it works 99% expect Wifi and AMD Readon 6370M GFX.
      -Almost Everyting.
      Not Working:
      -AMD Readon 6370M [Although you don’t need to be work it cuz you ain’t gonna gaming on OSX]
      1. Get iATKOS L2 from iatkos.me
      2.Make Bootable USB for Installing OSX Lion [iATKOS L2]
      Here your VM’s Mac work is done. Now you don’t need it.
      3. Boot Up from USB.
      4. Select iATKOS L2
      5. Go through process. [DON’T CUSTOMISE SETUP] for partitioning use Disk Utility to format [Erase] to HFS+
      6. After Installation. Again bootup from USB and Start Setup. Then go to Utility > Terminal.
      Now ,  Perform Following Operations.
      7. Now boot from USB and Select iATKOS L2 from HDD [NOT THE SETUP]
      8. Plugin USB Keyboard and USB Mouse.
      9. Go through process you will get to desktop.
      10. Get kexts and install particular drivers for Network, PS/2 Support, Voodoo HD Sound and bootloader. System Specification MacBook Pro 8,1.
      11. Install Intel 3000’s Kexts via Kext beast. [zip attached]
      12. Now it’s done, boot using command “-v GraphicsEnabler=No”
      Guide By vhj1995.
      my intel hd3000.zip
    • By suarez.531
      Os cuento un poco. Encontré un manual de hackintosh basado en unas herramientas que según me he dado cuenta por aquí no están muy bien vistas.
      Conseguí instalar os x mavericks pero intentando instalar un kext de sonido creo que salí del sistema sin reparar los permisos.
      Comenzó a darme problemas en el arranque que no conseguía solucionar y formateé el HDD donde estaba instalado os x para empezar de 0.
      Desde entonces no he conseguido que arranque el instalador usb de ninguna forma. Me encontré con las herramientas que usáis en este foro y probé a crear el instalador con myHack. Se creó sin ningún problema, pero a la hora de intentar iniciar el instalador me salta exactamente el mismo error.
      He probado desenchufando los dos HDDs y dejar solo el usb y sigue saltando el mismo error. ¿Qué puede ser? No encuentro a gente con el mismo problema..
      Espero que podáis echarme una mano porque estoy ya desesperado.
      Os dejo una foto del error y los componentes de mi pc:
      Intel i5 4690
      Gigabyte ga-b85-d3h
      Kingston hyper x fury 8gb
      Crucial mx100 256gb
      HDD sata 500gb

    • By AbsoZed
      I've been trying to boot to Lion for a couple hours now, and get through the installation with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and all that mess, however, after the installation, I get stuck at "DSMOS" has arrived. I've tried pretty much every bootflag I can think of, and it all ends at the same thing. My specs are as follows, as far as I see them being relevant:
      Asus U43F Laptop
      Intel Core i5 Sandy Bridge
      Intel HD 3000 Graphics
      Any ideas? I've tried -x -f -v PCIRootUID=0 cpus=1 
    • By Mac-Ingegno
      Gentile comunità
      ho installato iAtkos L2 su questo Notebook:
      ASUS F502CA
      -CPU Intel Pentium ULV 987 1.50Ghz DualCore
      -4GB ram DDR3
      -HD sata 500GB (AHCI)
      -Scheda video Intel HD integrata (credo sia la 4000 o 3000)
      -Audio Intel HDA
      -Reti Atheros AR8161(Ethernet) e AR9485(wireless)
      tuttavia dopo aver finito l'istallazione, al primo Boot compare sempre il seguente messaggio:
      "DRMStatus: iTunes/Apple Store Content Access Problem. Content playback may be disabled on this computer. You can continue to use the machine, but you should contact an Apple support representative. ErrorCode: 8877652"
      Ho fatto varie ricerche in merito, ma ognuno suggerisce la propria "cura" ma tutte con esito negativo.
      Sono stati provati tutti i vari comandi suggeriti al Boot: 
      -v -x
      -v -x -f GraphicsEnabler=Yes
      -v -x -f GraphicsEnabler=Yes PCIRootUID=1
      -v -x -f GraphicsEnabler=Yes PCIRootUID=0
      -v -x -f GraphicsEnabler=No PCIRootUID=1
      -v -x -f GraphicsEnabler=No PCIRootUID=0
      -v -x GraphicsEnabler=No PCIRootUID=1  IGPEnabler=Yes
      in Single User (-s)
      seguendo il post di xcrash a questo link:
      dove lui ammette di aver risolto, io ho replicato a lui nel suo post, ma non è giunta risposta.
      sono stati provati questi comandi:
      cd System/Library/Extensions
      mkdir IntelBack
      mv AppleIntelHD* IntelBack/
      mv AppleIntelSNB* IntelBack/
      e anche questi trovati in rete:
      mkdir /GeriOSX/
      mv /System/Library/Extensions/AppleIntelSNBGraphicsFB.kext/ /GeriOSX/
      Ma nessun risultato, il messaggio di errore è sempre li che blocca il First Boot di iAtkos L2.
      Potrebbe dirvi qualcosa questo errore di accesso causato da iTunes che ne impedisce l'avvio corretto della distro da me utilizzata?
      oppure conviene intraprendere un altro tipo di installazione per questo Hardware?
      Qualcuno di voi ha un notebook con caratteristiche simili?
      Grazie per il vostro tempo che vogliate dedicarmi alla risoluzione di questa insormontabile barriera.