Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
beta992

ASUS P8H67-M PRO (B3), i5-2400, speedstep, GTS 450, DSDT

18 posts in this topic

Recommended Posts

Thanks. :)

 

Will try to improve this guide. I'm now using the latest chameleon trunk (Chameleon Wizard) seems to fix some things.

Also I removed the monitoring tools. No changes on kexts/dsdt for the moment, because that seems to work fine. :)

 

I hope to here more reports from users if there sleep is working correctly.

Share this post


Link to post
Share on other sites

works fine for me, even with p67 chipset.

 

my config:

 

ASUS P8P67-M PRO B3 (everything seems to work, including audio and ethernet // P67(!) )

8 GB DDR3 CORSAIR XMS3

Sapphire AMD RADEON HD6870 VAPOR-X (works OOB)

Intel Core i5 2310

OCZ Vertex 2 60 GB - Mac OS X Lion 10.7.3

WD Caviar Blue 1TB - Windows 7 Ultimate 64-bit

LG BH10LS30 Bluray-Drive

 

all of the above do work.

 

last thing i have to fix is the pci-e wlan card (ASUS,PCE-N13).

Share this post


Link to post
Share on other sites

just pasted it into extra.

 

this is my first hackintosh, so i have a really big problem, i really hope you can help.

 

when i move the cursor to finder for e.g., it lags horrible and is not switching to click- mode or dock doesnt zooms when moving over icons, even if i activated it in settings .i dont know whats wrong? maybe got any solutions?

Share this post


Link to post
Share on other sites

You should try to create a new DSDT file, see the link to the guide in the first post.

After patching, change the _PTS values again.

 

What GPU do you have? (You could also send me a PM instead)

Share this post


Link to post
Share on other sites

sorry for my absence, but i couldn´t response because i broke my arm, and spent 7 days in hospital. but now i´m back:D

 

for gpu see post #4

Share this post


Link to post
Share on other sites

Updated the guide, let me know if it is working for you. :)

 

@centurka: hope that you are okey? Anyway.. are you using the latest Chameleon?

Share this post


Link to post
Share on other sites

hey beta992,

yea, i'm ok :D

 

#1 - my network card driver is 32 bit only and there were no 64 bit kext´s available, so i just bought a D-Link DWA-556 which is recognized as an airport card. works great!

#2 - i bought a magic trackpad in combination with a speed link vias nano bt stick, works OOB!

#3 - i use chimera 1.8 (latest), do you recommend chameleon?

#4 - bought 8 GB RAM Corsair XMS3 -1333MHz, special offer ,32,99 euro (germany:D) so now i use 16 GB RAM Corsair XMS3-1333 MHz

#5 - solved UI probs. i use a cyborg rat 7 which is really great. i reinstalled the (latest) driver 5 times for sure, but all this didn´t help. then i downloaded an alternative (USBOverdrive) driver, installed it, reboot, works.

 

so now i am done with building my hackintosh :D big thanks, screenshot´s will follow..

Share this post


Link to post
Share on other sites

Nice.. hope we see some screens soon. :)

Magic trackpad better than a Apple mouse?

 

I use Chameleon trunk and it is working well here. :)

 

Do you tried the new BIOS?

Share this post


Link to post
Share on other sites

hey beta992,

 

the magic trackpad is, umm... magic:D

 

well, my board uses a p67 chipset ---> latest driver 1004. works just fine.

i changed the design of my bootmanager from tonymac´s theme to a boot camp theme... looks more "clear" .

screens will follow.

 

centurka

Share this post


Link to post
Share on other sites

Hey Beta,

complete noob here! i keep getting KP after installing SL, im running:

asus p8h67-m pro 3604

sapphire radeon hd 6850

 

could you please explain what post-install steps you followed?

Share this post


Link to post
Share on other sites

hi beta922

 

stumbled across this forum because looking for P8H67-M-PRO (B3) DSDT file, tried yours above and the result is my lion 10.7.3 is losing the support for PS2 Keyboard and unable to shutdown because of asmedia USB3.0 is active (through PXHCD.kext).

 

before applied your DSDT, PS2 keyboard was working and shutdown work just with a problem that the PC will power on again after 2-3 secs off, so I thought by using your DSDT, will solve the problem.

 

any thought about this ?, do you have your onboard USB3.0 activated ?

 

my system is :

 

P8H67-M Pro (B3)

 

I7-2600K

8Gb Memory

On board Graphics

chameleon boot

 

 

Thank you

Share this post


Link to post
Share on other sites

Updated the guide to support Mountain Lion 10.8.

 

Please let me know if it works for you or what setup your are running on an ASUS P8 board. :)

Share this post


Link to post
Share on other sites

  • Similar Content

    • By plexiputer
      I'm happy to do some Gigabyte 100 / 200 / 300 DSDT edits , just as long as that's cool with MaLd0n.
    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      El Capitan 10.11.6 -> Big Sur 11 - Windows 10
       
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound (all ports) USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) ASUS HyperKit and M.2 with a KINGSTON NVMe SSD - 250 GB Hardware decoding/encoding on both HD 530 and RX 5700 (HD 530 up to HEVC, RX 5700 at the time of writing VP9) iGPU only (with QuickSync) is used in the default config.plist To use dGPU for hw decode/encode and also use Intel QuickSync you need to start with "config_headless.plist" This will use iMac17,2 SMBIOS and shikigva=80 To use dGPU only boot with "config_amd.plist" also disable iGPU completely in BIOS. This will use iMacPro1,1 SMBIOS without iGPU System Integrity Protection is Enabled by default. If you need to boot with SIP disabled you may use "config_debug.plist" or disable it manually in Clover settings. If you want Enabled SIP but with allowing unsigned kexts you may boot with "CsrActiveConfig = 0x01"  
      What is not working:
      -  
       
      Not tested:
      Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: (This is for HD 530 in headless) Primary Display: Auto (to use dGPU only this must be PEG) iGPU Multi-monitor: Enabled (to use dGPU only this must be Disabled) RC6(Render Standby): Enabled (to use dGPU only this must be Disabled) DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5126): Click here -> Z170-DELUXE_Clover_v5126.zip (Tested: El Capitan 10.11.6 -> macOS Big Sur 11.0.1)  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia, gibMacOS - Windows: Transmac, Vmware, Win32diskimager, gibMacOS) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:

       
       



       
      El Capitan 10.11.6
       
      Sierra 10.12.6
       
      High Sierra 10.13.6
       
      Mojave 10.14.6
       
      Catalina 10.15.7
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Useful Applications for Mac:
      EFI Mountain Show -> To easily mount your EFI Clover Configurator -> To easily manage your config.plist https://mackie100projects.altervista.org/download-clover-configurator/ PlistEditPro -> Advanced plist editor https://www.fatcatsoftware.com/plisteditpro/ iStat Menus -> To monitoring your devices https://bjango.com/mac/istatmenus/ Boom 3D -> To significantly increase your audio quality https://www.globaldelight.com/boom/ TextMate -> a basic code editor just like Notepad++ on Windows https://macromates.com Modified Wineskin to run basic Windows 32-bit or 64-bit (or DX9 games) applications on Catalina -> https://www.reddit.com/r/MacOS/comments/fobx5t/i_didnt_want_to_boot_windows_every_time_when_i/ MaciASL -> View/Edit your .aml, .dsl files https://bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/ Hackintool -> All useful info, tools in one place https://github.com/headkaze/Hackintool IORegistryExplorer V2.1 -> To view your IO tables https://github.com/vulgo/IORegistryExplorer/releases/tag/v2.1 App Cleaner -> To delete your apps with caches https://freemacsoft.net/appcleaner/ Intel Power Gadget -> To see your frequencies https://software.intel.com/en-us/articles/intel-power-gadget Carbon Copy Cloner -> Advanced macOS drive backup utility https://bombich.com Commander One ->A Total Commander alternative for macOS https://mac.eltima.com/file-manager.html  
      Useful Applications for Windows:
      Total Commander -> To easily manage EFI https://www.ghisler.com gibMacOS -> A python script for downloading/creating macOS Internet Recovery USB from Windows (working internet is needed when installing) https://github.com/corpnewt/gibMacOS mountvol b: /s -> To mount your system drive EFI
      EasyUEFI -> To manage boot orders and any bootloaders with ease https://www.easyuefi.com/index.html
      MiniTool Partition Wizard -> To mount your USB EFI, and manage other drives https://www.minitool.com/partition-manager/
      Notepad++ -> Basic code editor for all type of files https://notepad-plus-plus.org
       
      Notes:
      According to @albertoacj's comment Sidecar is only working in headless iGPU mode when using an AMD GPU, keep that in mind No need to change anything inside Clover from El Capitan to Big Sur For macOS Mojave and older you might need the full AirPortBrcmFixup.kext for full WiFi support   
      Changelog:
      2020.11.12: Noticed that the CPU is always at 4200 Mhz, created an SSDT for proper CPU stepping. Updated to Big Sur release version, updated bootpack
      2020.11.03: Tested El Capitan, Sierra, High Sierra, Mojave, Catalina, Big Sur
      2020.11.01: Updated bootpack to Clover v5126, ready for macOS 11 Big Sur final release
      2020.04.23: Corrected layout-id to use all audio ports, updated bootpack
      2020.04.22: Deleted unnecessary boot-args, can boot without any custom boot-args (except agdpmod=pikera for RX 5700), updated bootpack
      2020.04.20: Deleted unnecessary lines from config.plist, updated bootpack
      2020.04.17: Replaced FakeSMC with VirtualSMC because FakeSMC is outdated (to see your frequencies use Intel Power Gadget) -> Removed unnecessary kexts, Updated all necessary kexts, updated Clover to v5112, updated bootpack, enabled SIP, deleted bootcamp theme
      2020.03.26: Updated to 10.15.4 -> Updated WhateverGreen, Lilu -> Updated Clover to v5107
      2020.03.23: Removed "EmuVariableUefi.efi" -> deleted, caused false nvram map, now it's native, updated Clover to v5106
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By VortexisTV
      So I've been trying to update to Big Sur from Catalina but I get stuck at the +++ message at the beginning. I made sure I have all my kexts and drivers updated. Updating to Clover revision 5126 would only get me kernel panics. Am I doing something wrong? Any response would be greatly appreciated. EFI
       
      ASUS Zenbook UX331FN
      Intel Core i5-8265U
      Intel UHD 620
      Clover 5120
       

    • By Franklin_NGO
      Hello,
      I tried to patch the DSDT (battery) for my thinkpad L380, but to no avail. Could anyone help me on this?
       
      Here are my hardware and software:
      Bootloader: opencore 0.5.9 (DSDT and EFI in the attached file, SMBIOS removed) Hardware:thinkpad L380 (detail info: https://psref.lenovo.com/syspool/Sys/PDF/ThinkPad/ThinkPad_L380/ThinkPad_L380_Spec.PDF) CPU: I5-8250U GPU: UHD 620 SSD: 970 Evo plus Wifi card: native broadcom card (wifi worked without kext, bluetooth doesn't work due to not properly patch USB) OS: MacOS Catalina 10.15.7  
      Thank you and good day.
       
      DSDT.dsl
      EFI.rar
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/y6avuxsv
       
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/y6avuxsv
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
      USB INTEL SERIE 400.zip
       
      Use these kexts, enable XHCI port limit patch and follow this tutorial for remap USB ports
       
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
×