Jump to content
InsanelyMac Forum
rockinron_1

[How To] Lenovo z370 (i3-2330m HD3000(8086 0116))

Recommended Posts

*****************************************************************************************************************************************************

Mountain Lion Guide here:

http://www.insanelymac.com/forum/index.php?showtopic=280656

*****************************************************************************************************************************************************

For anyone coming here for the HD3000 80860116 use the smbios from a mac book pro 8.3 (included in attachment)

*****************************************************************************************************************************************************

Generic update information lower down

*****************************************************************************************************************************************************

 

*****Last updated: 16/5/2012*****

 

I've had a few people contact me for help. I'm more than happy to help where possible but please read through the entire guide & u n i b e a s t page before contacting me. It may look complicated at first but it's really quite simple. Also I'd prefer comments on this page rather than PM's since other people that may be struggling can read it.

 

There will be a Mountain Lion guide coming sometime after release for those interested.

 

Hardware spec:

core i3-2330m (4 thread dual core)

hd3000 graphics (8086 0116) (note this is the 0116 revision not the 0112 you might read about for different HD3000's)

Atheros AR9285 wi-fi (168C 002B)

Realtek ALC269 sound (10EC 0269)

Realtek ethernet (10EC 8136)

4GB RAM (upgraded mine to 8GB)

 

What works:

Graphics with full QI / CE.

Wi-fi

Touchpad & keyboard

Webcam

Bluetooth

Audio output (speakers & headphones)

App store

Battery sensor (stability issuse - see note 3 below)

HDMI

Ethernet

 

I haven't tried to get these working since I don't need them (may be a simple fix, I wouldn't know):

Card reader

Mic (unkown - i'll update if someone tests)

HDMI audio

And I don't know about sleep. It tries to sleep, goes into s3, comes out of it, sits there stupidly with a blank screen then when you press the power button goes back into s3 and comes back on to normal with the screen on. No idea. Working on sleep but may take a while. For anyone interested in helping see bottom of guide.

 

A couple of things to note before you start:

1. If you don't have a mac / hack then you need to install the iatkos way first then do the following on that install.

2. If you want to install windows on the same partition you need to patch the u n i be a s t installer so you can install OS X on an MBR partition. See step 3 in the following guide:

http://www.macbreake...-partition.html

3. After extended use I have found stability issues around the battery sensor (KP's). When you install kexts using kext utility below I suggest you ignore the files "AppleACPIBatteryManager" & "AppleSmartBatteryManager". I will fix this when I get round to it but probably not for a while.

4. Open the attachment in OS X not windows / linux (otherwise folder structure will probably look screwed).

5.If you have the i5 / nvidia graphics card combination:

a. you need to boot with the PCIRootID=0 kernel flag.

b If it boots and you see a blue flash then a black screen plug a HDMI monitor in to get through setup.

c. copy the 8.3 smbios to your /extra folder (overwrite the one that's there)

 

 

The guide:

1. Go to the tonymacx86 website follow instructions for & install u n i b e a s t (note if your going to put windows on the same partiton when creating partitions in disk utility use "master boot record" instead of "guid partition table")

2. Follow all steps of the u n i b e a s t installer up to and including step 3. (don't do step 4). This should leave you at the OS X desktop on your z370, then:

3. Install latest chameleon (included in attachment)

4. Install all attatched kexts using kext utility (just drag & drop them onto it) (included in attachment) (Red & orange ones are required to boot, the rest are drivers)

5. Copy extra folder to your root directory (now using smbios from 8.2 edited with smboardproduct key from 8.1 to get full hdmi support)

6. Repair permissions & reboot. On reboot go into BIOS and disable legacy USB support (and enable virtualisation if you want it) .

N.B if you get boot0 error its a simple fix, see here:

http://www.macbreake...oot0-error.html

and ignore anything to do with obtaining the boot1h file - its included (you'll have to re-enable legacy usb support to get back into the installer)

7. Update system

8. Reinstall the blue labeled kexts using kext utility & repair permissions (this will have to be done after any system updates)

9. Delete nullcpupowermanagement.kext (in /system/library/extensions) (this MUST be reinstalled before any system updates)

10. Reboot and enjoy!

 

Generic update information, as new ones are released I'll test them and report if they work (up-to 10.7.4 is fine):

1. Install nullcpupowermanagement.kext using kext utility (you WILL get kernel panic on reboot if you don't do this).

2. Reboot.

3. Update system as normal.

4. Use kext utility to reinstall the blue kexts.

5. Repair disk permissions in disk utility.

6. Reboot.

6. Delete nullcpupowermanagement.kext from /system/library/extensions

7. Reboot & enjoy!

 

Here she is up and running, perfectly stable just missing this final touches:

530559_10150648797246295_750336294_9460544_378833811_n.jpg

RockinRon_000048.jpg

 

If anyone manages to get HDMI audio I'd be very interested to know how you managed it.

 

Information about sleep development (incase anyone is clued up enough to help):

I have sleep but it seems a little temperamental depending on how long its been running. How I did it:

Opened console (in utilities) sent the laptop to the pseudo-sleep it goes into then checked console. The devices calling wake were "EHC1 EHC2 GLAN".

So now I extracted my DSDT when into it and removed all the ACPI code for these devices. This has left me with working sleep and apparently no affected devices (still checking everything over). The problem now is that once the laptops been running for a while sleep no longer works and when you try for it, it appears to switch off the monitor then panic instead.

I know also know I cannot simply remove said elements from the DSDT if I want the devices to work when coming out of sleep. I'll work on this more when I get round to it.

 

 

 

*************************Old way using iatkos - for making u n i b e a s t only - not recomended*************************

1. Get a copy of iAtkos L2 (runs quicker restored onto a USB but from DVD will do)

2. Check SATA set to AHCI in BIOS

3. Plug USB keyboard & mouse in

4. Boot iAtkos and install with the following options:

a. chameleon bootloader 2.1

b. fakeSMC

c. disabler

d. RTC

e evoreboot

f. AHCI SATA

g. PS/2

h. atheros AR9285 (unless changing wi-fi card)

5. When the installer restarts shut down the computer before it gets chance to boot again (at BIOS screen)

For the following 2 steps I removed the hard drive and put it into another mac but it should be possible in the terminal (boot with -s):

6. Install smbios.plist for macbook pro 8.3 (NOT 8.1 - it won't work) (use chameleon wizard to obtain)

7. (may be optional but I did it) Install latest chameleon bootloader (2.1 r1814) to mac partition (check graphics_enabler=yes)

8. Repair permissions (use disk utility on iAtkos boot DVD)

9. Boot the laptop and you should have full graphics support and see the initial mac screen.

01 Lenovo Mac.zip

Share this post


Link to post
Share on other sites
Advertisement

Hey...

 

I have a Lenovo z370 myself and first of all, thanks for this guide. This was my first Osx86 install and I would've sacrificed more goats over copper bowls than absolutely necessary if I hadn't come across this.

I started from an iAtkos L1 install and barring a few minor changes, this worked as advertised. I also did a little more searching and I can suggest the following:

 

1. Wifi

Got it to connect to a WPA2 AES network just fine using this kext here.

2. smbios.plist

Like you said, entirely possible to edit from the terminal. Boot into single user mode and edit using nano.

3. Misc. Kexts

Someone with a Lenovo B570 (with a very similar config to the z370) got a successful install and was kind enough to upload his kext config here. Plugged in some of the holes and is worth taking a look at.

 

Now for the fine print.

1. Sleep

The laptop becomes non responsive after closing the lid. Apparently Lion doesn't allow you to change lid close sleep behaviour either. The solutions available are for proprietary Macs only, so I don't know if I should try those.

2. Kernel Panics

I've been getting lots. Usually within 15 minutes of turning the laptop on. The problem disappears by booting into safe mode, and on the subsequent normal boot. I guess this might make it a problem with one of the kexts, but I can't pinpoint which one. (Let me know if you're going through something similar?)

 

I'm going to try the Combo update to 10.7.3 in sometime. Lets see if I manage to get through it without anything exploding.

Share this post


Link to post
Share on other sites

Hey,

 

I got the wifi working provided it wasn't connecting to a 54n router (only 54g) but i'll give that kext a bash.

 

For future reference if you make a copy of your smbios.plist onto a usb and use the terminal cp (copy) command it makes life a bit quicker (especially as you'll probably end up doing a few re-installs).

 

Unfortunately I haven't got sleep and I've no idea how to make it work (it doesn't on my desktop either so I'm sure its something I'm missing as opposed to it not being possible).

 

**See new guide above**

Now for the KP issue I'm fairly sure I've diagnosed it but don't know how to fix it.

If you add the kernel flag -v (verbose mode) to your org.boot.chameleon.plist then you can view the output of the KP.

I've always found that voodoo kexts are in the backtrace and if I remove anything associated with them (audio & battery) it's perfectly stable.

Interestingly a clean vanilla install is also perfectly stable but obviously missing drivers. I only found this recently but it worked:

http://tonymacx86.bl...lion-using.html

Also as a side note I originally had the voodoohda kext on my desktop and it caused KP's on that as well.

 

The main problem is getting the ALC269 audio working without voodoohda (loads of people seem to be having problems with it), it should be possible to get it working with applehda but i don't have the knowlege to do it.

 

All updates will run fine since its a supported architecture so give it bash. **not without nullcpupowermanagement in /s/l/e**

 

BUT I haven't given up yet and if I figure it out the guide will be straight on here.

Share this post


Link to post
Share on other sites

First off - thanks for this guide. Have gotten further this time than any previous attempt. I'm well versed in Linux but am trying to expand my horizons. :-)

 

Having some major issues getting this to work. I have the same configuration as listed above with the exception of having an Corei5-2430 processor. I have a WD 500GB hard drive and I've found it necessary to use the boot1h fix.

 

I keep getting Kernel Panics after the entire install when I try to reboot. I'm doing a reinstall right now and will leave off the AppleACPIBatteryManager and AppleSmartBatteryManager kexts to see if that fixes it.

 

I'm doing a couple of things that aren't spelled out in the HowTo above to get it to this point and I wanted to make sure they were correct.

 

1) I have to use PCIRootUID=0 on initial boot with u n i b e a s t to get it to boot. Every other configuration, including -s, -v, -x, GraphicsEnabler=No all result in it hanging on boot unless I use the PCIRootUID=0.

 

2)I have to have an external monitor connected. Without it, I get a screen flash and then it goes blank right when the installer starts. Once through with the entire install, it is no longer necessary.

 

3) the zip file you attached had a _MacOSX and Lenovo Final directory. Under the _MACOSX directory, there is another Lenovo Final subdirectory. Both of those contain kexts. Which kexts do I use? It appears that the ones in the _MACOSX/LenovoFinal directory are color coded so I'm assuming those are the ones. Unfortunately, the rest of the files including the Extra folder appears to be in the /Lenovo Final directory. Do I have that correct?

 

4) I install the chameleon app from the /Lenovo Final folder.

 

5) I copy the Kext Utility to the Applications folder on my Lenovo. I then copy all the Kext files to /System/Library/Extensions. I then drag /S/L/E onto the Kext Utility app.

 

6) I use the disk utility to repair permissions and then reboot.

 

7) I then have to do the boot1h fix to get it to boot without u n i b e a s t.

 

8) When it reboots, I get the following KP. "unable to find driver for this platform: \"ACPI\".\n"@/sourceCache/xnu/xnu-1699.24.23/lokit/kernel/IOPlatformExpert.cpp: 1504

 

Thoughts?

Share this post


Link to post
Share on other sites

Still happening. I just tried to reboot using -s and the last thing that processed prior to the KP was TSC Deadline Timer supported and enabled.

Share this post


Link to post
Share on other sites

1. I didn't have to do this. Would I be right in guessing your z370 has an proper nvidia gaphics card in it rather than the hd3000? If i recall correctly this is a known fix to get the nvidia cards to work...

2. Again I didn't have to do this but we got through the install so let's not worry about it.

3. Open the attachment in OS X and it should be a flat directory with the labelled kexts & extra folder in it. Opening it on linux (and possibly windows) would give rise to the situation your describing. If I'm wrong, let me know and I'll re-do the package and see if I can sort it.

4. Yup.

5. I've assumed prior knowlege of kext utility here; you shouldn't be copying any kexts at all. All that is required is that you drag & drop them onto kext utility then it will automatically copy them to s/l/e and sort permissions etc.

6-7. You haven't mentioned copying the extra folder to your root directory here, from what you say i'm fairly sure you have but just to check.

8. A punt - are you trying to boot from raid? (if unsure see if you've any BIOS settings relating to it). I've not actually seen this KP before...

 

A lot of guess work going on on my behalf here so let me know the answers and ill get back to you when i can.

 

We might need to do a bit of work on your smbios.plist in the extra folder as it currently for an i3 with a hd3000 (8086:0116) on board graphics chip but you should at least be able to get for the desktop for the time being.

Share this post


Link to post
Share on other sites

Got the same video card Intel HD3000. The processor is a core i5 2410. I'll redo the Lenovo Final from inside OSX. I did put in a blu-ray instead of the stock DVD but that shouldn't be causing a KP. Going to check my bios for an update and try this all again.

 

Share this post


Link to post
Share on other sites

Hmm interesting. Well the pci fix is working at least so lets not worry about that.

 

Out of curiosity have you checked your device ID's match mine? (CPU's pretty irrelevant so long as it's got "core" in the name, its graphics etc were worried about) Ultimately it doesn't matter what label is on the laptop its the parts were worried about.

 

I have no idea about the blu-ray, mines only dvd. For point 8 that was the only thing I could find relating to it. Google the panic and it will give you a few leads.

Share this post


Link to post
Share on other sites

Yep. The graphics card id via lspci -nn matches yours. Not using raid but I'll recheck in the bios. No new bios available via Lenovo (the bios options suck).

 

Everything is exactly the same as yours except the CPU and my blu-ray. Even have the Atheros wifi.

 

I'll try this again with making a thumbdrive copy of your Lenovo Final inside OSX and try once again.

 

You are using GUID on the Hard Drive aren't you? I am but still have to do the boot1h thing because its a WD 500G

Share this post


Link to post
Share on other sites

Got it to reboot and everything fine but still require the eternal monitor the entire time. Tough to use a laptop that way. Guess I'll roll back to linux for the time being. Thanks for the help and I'll check this thread from time to tune to see if a resolution is found.

Share this post


Link to post
Share on other sites

Yes I'm using GUID, originally I tried it on an old hard drive though so I didn't run into the boot1h issue until I swapped the WDC-500 back in.

 

The external monitor issue may be solved by using the smbios.plist from a macbook pro 8.3, my smbios has been played about with so may not be suitable for the i5/hd3000.

You can install it using chameleon wizard.

 

Did you get to the desktop or not?

 

The issue your experiencing is not specific to this range of laptops so I doubt it will be solved through this thread - I know of others who've got there z370 going by following my instructions.

 

If you google "

IOPlatformExpert.cpp: 1504" you'l find plenty of info regarding the error and considering it's complaining it's a missing driver it may only be a case of finding the correct kext to make it work

Share this post


Link to post
Share on other sites

Yes I got to the desktop. I'll take another look at this today and I'll try the smbios.plist you suggested. I'll give this game one more day and then I have to get this laptop running.

Share this post


Link to post
Share on other sites

Got it working now. The smbios.plist did the trick. Still fighting with the wifi (WPA2) on my router but I'm sure I'll get it sorted out. Is there a way to force "54g" on the laptop or do I have to force it from the router?

Share this post


Link to post
Share on other sites

I wasn't aware the wi-fi connection issue mentioned in the replies above was still present.

 

Does the wi-fi symbol appear in the title bar?

Does it see your network?

If so what happens when you try to connect?

Does it connect but not give you an IP address? (Thats the known issue with the old kext I was using - its since been updated).

Or does it not connect?

 

Mine hooked up to our on campus WPA2 network the other day although I couldn't confirm if its b/g/n.

 

If you can see the wi-fi symbol & your network but it won't connect then you can try forcing 54g mode. You have to force it on the router preferences page (AFAIK).

If you don't know how to do that type 192.168.0.1 in your address bar at the top of your browser and look for the mode setting under wi-fi / wireless settings.

Share this post


Link to post
Share on other sites

I can connect easily to an open network. When I try to connect to my home network, it won't connect. I is protected by WPA2 and it is a 54N router. Also, Airport doesn't appear to be working. Does it work on your system?

 

Thanks for all your help.

 

>>Ok. Setting the router to B/G only solved the issue for now. Guess I'll just do without N or switch to WPA.

Share this post


Link to post
Share on other sites

Thanks for everything. I banged my head on the wall for 72 hours or so back 6 months ago trying to get this to work. With your HowTo and personal assistance, I now have a functioning Z370 Core i5-2410. I got the blu-ray player working with Mac Bluray Player. Very nice set-up now. Thanks.

Share this post


Link to post
Share on other sites

Another question. My wired connection isn't working. I've got RealtekRTL81xx.kext installed. what else do I need to do to get it working?

 

Thanks.

Share this post


Link to post
Share on other sites

I'm not sure about that. When I tested it when I first set it up it worked. I have no use for it though so haven't used it since...

 

Couple of generic suggestions I'd try are:

 

Go system settings -> network -> click the add button & see if ethernet is listed.

 

Failing that try the llowing:

Check the flag:

EthernetBuiltIn

Yes

Is present in your /extra/org.chameleon.boot.plist

Then delete all network interfaces in preferences.

Then delete networkinterfaces.plist from /library/preferences/systemconfiguration

Then restart and go to network preferences and start to add you interfaces again, hopefully ethernet will show up (important - you MUST add either ethernet or your airport card FIRST if you want app store to work).

Share this post


Link to post
Share on other sites

I think I borked something when I tried to tether my android phone via usb. It was working before that and nothing I do fixes it now.(Including your helpful suggestions above)

 

I'll just reinstall and start clean. Thanks.

Share this post


Link to post
Share on other sites

Although I've no experience of tethering an android phone I noticed you mentioned doing a clean install.... Have you discovered time machine yet? Its a fantastic backup utility that comes with OS X and if your using a hackbook then keeping a time machine backup is pretty essential.

If everything goes {censored} up its a one click restore from the installer to exactly the system you had before - priceless while you're making sure you hackintosh is up & stable.

(I never trusted backup solutions like this before but I've tested it and it works perfect)

Share this post


Link to post
Share on other sites

Thanks. I'll use time machine from here on out.

 

This is all about learning something new for me. Thanks for the help.

Share this post


Link to post
Share on other sites

No problem, I can't stress enough how good time machine is.

 

If you set it up (system settings) and let it do its initial run from then on whenever you have your backup disk connected it will do hourly backups / daily / & weekly (only of files that have changed - it doesn't take forever each time). Even if you don't have your backup drive connected it will keep a local backup of any file changes.

Once you've run it for the first time if you click the time machine symbol in the title bar & "enter time machine" you'll quickly see how useful it is for recovering individual files.

Then if your system goes {censored} up you can just go into the installer (probably best to keep a ready to install copy of u n i b e a s t on a usb somewhere just incase) and one of the menus has a "restore from time machine backup option" which reverts the system to whichever backup you choose.

 

I never trusted windows to do this but mac does it flawlessly.

Share this post


Link to post
Share on other sites

Getting it set up on my NAS as we speak.

 

The ethernet issue was solved after the clean install by using m u l t i b e a s t and the Realtek Gigabit kext install.

Share this post


Link to post
Share on other sites

I just did the 10.7.4 update. Took the update but got a KP on reboot. Booted with u n i b e a s t and re-installed the blue kexts, fixed permissions and reboot. Everything works.

 

Nice work man. I really appreciate it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By quattrofx
      Hi to all,
       
      I just wont to give inough informations on one place for all the people with same Hardware with
      costimization steps witch i have done. I have fast perfect working High Sierra 10.13.3 on my PC but
      still needs to be actualized thru the DSDT, because it ist the only way to get all the hardware 
      properly working.
       
      Gigabyte Z370 Aorus Ultra Gaming - BIOS F7h
      Intel i7-8700K (4.8GHz)
      Gigabyte GTX 1080 G1 Gaming  8G
      DDR4 64GB PC 3000 CL15 G.Skill KIT (4x16GB) 64GVR Ripjaws V
      Dual-Band PCI-e Adapter TP-Link TL-WDN4800
      Firewire PCI-e Digitus (Texas Instruments Chipset)
      Bluetooth 4.0 USB Dongle ASUS BT400 (Broadcom)
      PSU: LC-Power Metatron Prophecy 2 LC8750II V2.2, 750 Watt
      2 x NVMe SSD 960 Evo 500GB (Win10Pro & High Sierra 10.13.3)
      1 x SSD Crucial 500GB (Sierra 10.12.6)
      1 x 4TB Segate Barracuda SATA 3 (Multimedia)
      Tripple-boot Win10Pro, Sierra 10.12.6 & High Sierra 10.13.3
       
      Bios Settings:
      1.       M.I.T. → Advanced Memory Settings  Extreme Memory Profile(X.M.P.) : Profile1
      2.       BIOS → Fast Boot : Disabled
      3.       BIOS → LAN PXE Boot Option ROM : Disabled
      4.       BIOS → Storage Boot Option Control : UEFI
      5.       Peripherals → Trusted Computing → Security Device Support : Disable
      6.       Peripherals → Network Stack Configuration → Network Stack : Disabled
      7.       Peripherals → USB Configuration → Legacy USB Support : Auto
      8.       Peripherals → USB Configuration → XHCI Hand-off : Enabled
      9.       Chipset → Vt-d : Enabled
      10.   Chipset → Wake on LAN Enable : Disabled
      11.   Chipset → IOAPIC 24-119 Entries : Enabled
       
      Dedicated graphics card:
      1.      Peripherals → Initial Display Output : PCIe 1 Slot
      2.      Chipset → Integrated Graphics : Enabled
      Chipset → DVMT Pre-Allocated :128M   
      Wake for Ethernet Network access - Unchecked
      Enable Power Nap - Unchecked
       
       
       
       
       
      First step:
      I have a perfect Sierra 10.12.6 working on my HP Z800 witch i use to clone to one SSD
       
      Second step:
      Delete old EFI on cloned SSD and put the new one from here:
      https://hackintosher.com/guides/high-sierra-install-full-guide/
       
      Adjusted Kexts and Config.plist for my Rig:
       
      Kext Folder:
      FakeSMC.kext + Sensors Kexts
      Lilu.kext
      CodecCommander.kext
      AppleALC.kext
      IntelGraphicsFixup.kext 
      FakePCIID_Intel_HD_Graphics.kext
      IntelMausiEthernet.kext
      NvidiaGraphicsFixup.kext
      Shiki.kext
      USBInjectAll.kext
      XHCI-200-series-injector.kext
       
      Thread step:
      connected new cloned SSD on the SATA port and Sierra started up and working.
       
      Fourth step:
      regulary updated to HighSierra 10.13.3 running installer from App folder.
       
      Fifth step:
      Cloned Sierra SSD to NVMe SSD 960 Evo 500GB
       
      Made changes to BIOS & Config.plist to become hardware encoding acceleration  in FCPX and HEVC support:
       
      BIOS Gigabyte:
      §  Chipset → Integrated Graphics : Enabled
      §  Chipset → DVMT Pre-Allocated :128
      §  Peripherals → Initial Display Output : PCIe 1 Slot
       
      Config.plist:
       
      1.       Inject Kexts is set to Yes
      2.       In Boot Under Custom flags added:
      Nvidia users: shikigva=60
      3.       Kaby Lake & Coffee Lake Users:
      In Devices Using Nvidia 
      - Set ig-platform-id to: 0x59120003
       
      DSDT Patching:
      1.       HECI -> IMEI Patch
      1.       Comment: change HECI to IMEI
      2.       Find* [Hex]: 48454349
      3.       Replace [Hex]: 494d4549
      2.       GFX0 -> IGPU Patch
      1.       Comment: change GFX0 to IGPU
      2.       Find* [Hex]: 47465830
      3.       Replace* [Hex] : 49475055
      3.        PEGP -> GFX0 Patch
      1.       Comment: change PEGP to GFX0
      2.       Find* [Hex]: 50454750
      3.       Replace [Hex]: 47465830
       
      I think that in my Config.plist (used EFI from here https://hackintosher.com/guides/high-sierra-install-full-guide/  and edited by me)
      are the double entries, but i am not shure and i dont wont to make a mess myself.
      It is beter to leave it to the profis like Maldon!
       
       
       
      Maldon, i have attached my Send me iMac_4FX.zip file generated with RunMe.app
       
      Can you post the list of maded Patches for this RIG please.
       
      THX in advance
       
      QuattroFX
      Send me iMac_4FX.zip
    • By DjBeppe
      Hi all guys I need your help and I hope you can help me
        I took the road to install High Sierra on my new build and now I have some doubt / difficulty I do not know how to solve.   My configuration: 8700K Asrock Z370 Professional Gaming i7 AMD RX580 Nitro+ 8GB   First I created the usb pendrive and I used Clover with the following configurations:     Bootflag:  dart=0 -v Kext:
       
        Bios Setting: VT-d = Disabled Share Memory = 128MB IGPU Multi-Monitor = Enabled XHCI Hand-off = Enabled SMBIOS: iMac18,3 So far no problem, it started successfully, I initialized the hdd in APFS and I ran the installation.  
      Once finished, it started and I made the first configuration successfully. At this point I configured Clover the same way as the installation:     Bootflag:  dart=0 disablegfxfirmware shikigva=4 -rad4200 darkwake=8 Devices:
         
      Graphics:
       
       
      Kernel and Kext Patches:
       
      SMBIOS:
      iMac18,3 Kext:
       
        I reboot and start without problems, but I know there is some problem to solve ... for example, the video card seems to recognize it but if I run a benchmark with "Novabench" I noticed that the GPU is recognized as 1GB:   With "WhateverGreen.kext" and "RadeonDeInit=Disabled":      ||     ||     ||    
        I tried to delete "WhateverGreen.kext" and "RadeonDeInit=Enabled" and I recognize the card differently but the same problem presents itself:  
        ||     ||     ||  
       
       
      Why is it recognized by 1GB instead of 8GB? While on System Profiler is recognized by 8GB .... I'm doing something wrong?
       
       
       
      I tried to enable also "Hardware Encoding & HEVC Support" but I noticed a detail that I do not know if it's right or not (Hardware Info "MacX Video Converter Pro"):
        Without "WhateverGreen.kext" and "RadeonDeInit=Enabled":     With "WhateverGreen.kext" and "RadeonDeInit=Disabled":  
      [COMING SOON SCREENSHOT]  
      Is it normal that this occurs? Which one is correct? I'm going completely in confusion
       
      I'm trying to figure out if I need to make any other changes to the system, if I add some other patches to make it work properly but I do not know where to check.
      I'm trying to configure the DSDT but DSDT Editor and MaciASL do not work, they do not open the DSDT.aml file generated by AIDA64.   Do you know how to give me a hand? I'm banging my head for 2 days I thank you in advance for the help and I apologize for my english   I hope I was clear        
















    • By heisian
      macOS 10.13.2
       
      Specs:
       
      ASRock Z370M-ITX/ac Intel i7-8700K 3.7GHz G.Skill Ripjaws V Series 16GB (2 x 8GB) DDR4-2400 Memory Crucial MX300 275GB M.2-2280 Solid State Drive Gigabyte GeForce GTX 1050Ti Corsair SF 450W 80+ Gold Certified Fully-Modular SFX Power Supply  
      Clover EFI folder
       
      Working:
       
      - Computing things
      - Sound
      - Sleep
      - Graphics
      - Ethernet
      - APFS
      - SMBIOS iMac 19,1
       
      Not working:
       
      - Bluetooth/WiFi (did not buy a chip)
      - High Sierra not recognizing i7-8700K as a CPU (see last photo attachment).
       
       
      I've seen others post screenshots of their 8700K being recognized, but mine didn't end up that way and I dunno why. Regardless, everything seems to work fine so far. Ran Valley, did some coding, etc. See GitHub repo for full config details.
       
      Successfully upgraded to APFS post-install.








    • By serial12345
      Hello i guys i have succuss fully build my havkintosh and from title you know everthing
      Yes i have installd high sierra on my coffee lake 8700k processor and with gigabyte z370 hd3p motherboard
       
      The path was hard but manageg to compelete it
      My build
       
      Processor : Intel I7 8700k
      GPU : Sapphire Toxic r9 270x oc
      Motherboard : Gigabyte z370 hd3p
      Cpu Fan : cooler master 103 with LGA 1151 supported
      Ram : 4 gb ram 2400mhz
      PSU : 750 watt
       
      I know i have to upgrade some parts i will attach the sreen shots soon
    • By giacomo.dessi2303
      Buongiorno a tutti sono un nuovo utente del forum e avrei bisogno di aiuto. Ho installato sierra sul mio laptop che ha le seguenti caratteristiche:
      Scheda video: intel hd graphics 3000 + NVIDIA GeForce GT 720M (so già che la scheda Nvidia non funzionerà)
      Scheda audio: Intel High Definition Audio
      Scheda di rete: 802.11b/g/n
       
      Questo è ciò che funziona e ciò che non funziona:
      Audio (OK)
      WebCam (OK)
      Ethernet (OK)
      Graphics (OK)
      Touchpad (OK)
      Keyboard (OK)
      WiFi (OK)
      USB (OK)
      Bootloader (OK)
      Battery (NO)
      Microphone (NO)
      Brightness (NO)
      Bluetooth (NO)
      SD Card Reader (NO)
       
      ​Non è che qualcuno di voi riuscirebbe a sistemarmi il DSDT in modo che il  portatile funzioni correttamente con sierra? Grazie in anticipo
       
      CLOVER + DSDT.zip
×