Jump to content

Asrock Conroe945 Sleeps and Wakeup !


TopazBar
 Share

44 posts in this topic

Recommended Posts

I've been trying for days and just came thru.

Two important BIOS option:

enable SLeep to RAM and enable Wakeup from PS2 keyboard.

 

That's it. Wow.

 

EDIT: I'll try different sleep method and report (first time I did use sleep from menu).

EDIT2: someone else confirm please.

EDIT3: recovered from automatic sleep.

Link to comment
Share on other sites

I've been trying for days and just came thru.

Two important BIOS option:

enable SLeep to RAM and enable Wakeup from PS2 keyboard.

 

That's it. Wow.

 

EDIT: I'll try different sleep method and report (first time I did use sleep from menu).

EDIT2: someone else confirm please.

EDIT3: recovered from automatic sleep.

 

What did you use as an install method, and what do you have your keyboard plugged into? Do your USB ports work again when you unplug and re-plug them in?

 

-Dan

Link to comment
Share on other sites

What did you use as an install method,
10.4.4 Myzar
and what do you have your keyboard plugged into?
PS2 port
Do your USB ports work again when you unplug and re-plug them in?

 

-Dan

Yes, I have Wireless Lan USB dongle (Ralink GW122) and it recovers. I don't have to re-plug it in.

This may be because I'm running with "RT2500Replug fix". My USB dongle has to be re-plugged in every time I reboot unless this replug fix is running. I got this software way back when.

Link to comment
Share on other sites

Hmm.. 10.4.4 isn't around anymore, I can't find it. Sounds like Sleep was broken in the "10.4.5" and above distributions that are out there. I think I'll live with what I have for now - I can at least wake up and use the 2 USB ports I need (Tablet & Keyboard). I'm sure it'll get fixed some day - with this, or another MB.

 

-Dan

Link to comment
Share on other sites

i'll try this on a 10.4.7 system with an apple keyboard plugged on a usb port and will report it to you guys. just wait until this evening.

 

I should confirm, that Sleep mode perfectly worked on my PC, Asrock ConRoe945G.

 

My config:

Mac OS X 10.4.7 (JaS 10.4.6 + 10.4.7 Update)

Asrock ConRoe945G + Core 2 Duo (E6300)

GMA950 (DVI out)

2 Gb (512Mb x 4)

Mac Keyboard (USB)

Microsoft IntelliMouse (USB)

 

The OS Sleeps immediately, but the system takes nearly 5-7 seconds to sleep after this.

It wakes up by keyboard, mouse or pressing power button.

Link to comment
Share on other sites

I should confirm, that Sleep mode perfectly worked on my PC, Asrock ConRoe945G.

 

My config:

Mac OS X 10.4.7 (JaS 10.4.6 + 10.4.7 Update)

Asrock ConRoe945G + Core 2 Duo (E6300)

GMA950 (DVI out)

2 Gb (512Mb x 4)

Mac Keyboard (USB)

Microsoft IntelliMouse (USB)

 

The OS Sleeps immediately, but the system takes nearly 5-7 seconds to sleep after this.

It wakes up by keyboard, mouse or pressing power button.

 

Geez! you got exactly the same system as me ! the only difference is that i have a logitech mouse! so it should work for me too, i'll try this later on.

Link to comment
Share on other sites

I should confirm, that Sleep mode perfectly worked on my PC, Asrock ConRoe945G.

 

My config:

Mac OS X 10.4.7 (JaS 10.4.6 + 10.4.7 Update)

Asrock ConRoe945G + Core 2 Duo (E6300)

GMA950 (DVI out)

2 Gb (512Mb x 4)

Mac Keyboard (USB)

Microsoft IntelliMouse (USB)

 

The OS Sleeps immediately, but the system takes nearly 5-7 seconds to sleep after this.

It wakes up by keyboard, mouse or pressing power button.

Great!!!!

I'm so glad someone else confirmed. Group Hug :)

EDIT: most of the time it sleeps right away, but just once it took about 5-7 seconds to go into sleep.

Link to comment
Share on other sites

I should confirm, that Sleep mode perfectly worked on my PC, Asrock ConRoe945G.

 

My config:

Mac OS X 10.4.7 (JaS 10.4.6 + 10.4.7 Update)

Asrock ConRoe945G + Core 2 Duo (E6300)

GMA950 (DVI out)

2 Gb (512Mb x 4)

Mac Keyboard (USB)

Microsoft IntelliMouse (USB)

 

The OS Sleeps immediately, but the system takes nearly 5-7 seconds to sleep after this.

It wakes up by keyboard, mouse or pressing power button.

 

Could you post all your BIOS settings? That'd be great!

 

-Dan

Link to comment
Share on other sites

I have BIOS 1.1.

Here is picture (a little blurry) of my ACPI setting:

p8300185sp0.th.jpg

 

Hi all,

 

thanks TopazBar, I have EXACTLY the same config in my BIOS ( i am using 1.1 BIOS as well).

I did not post it here, as I am not at home yet...

 

For some reason, when you set ACPI HPET Table to Enabled, Sleep mode does not work... As far as I remember.

TopazBar, could you confirm this?

Link to comment
Share on other sites

i have the same settings ... maybe i should upgrade to bios 1.1 :)

You must, PLEASE and then report back.

I want at least 3 confirmation.

 

 

What about audio in? Have you got that working too? :lol:

Oh, I forgot about that (I have no need for that yet). Probably not, haven't tested...O.k., make that 98.999 % compatible. Nevertheless, I'm still very happy :)

 

Few things about sleep:

1. If you make display and system sleep at exactly same time, only display sleep takes effect.

2. If you are playing QT video for like 2 1/2 hours, sleep function is disabled during that time (nice feature).

Link to comment
Share on other sites

Hi all,

 

thanks TopazBar, I have EXACTLY the same config in my BIOS ( i am using 1.1 BIOS as well).

I did not post it here, as I am not at home yet...

 

For some reason, when you set ACPI HPET Table to Enabled, Sleep mode does not work... As far as I remember.

TopazBar, could you confirm this?

Fars,

I just tried with HPET enabled, and sleep works fine. So, I will just leave it enabled.

BTW, I'm running 10.4.4 from 10.4.4/5 myzar.

 

EDIT: I spoke too soon. With HPET, sleep works from menu, but automatic sleep fails. So you are right in that with HPET sleep doesn't work properly. I disabled HPET.

Link to comment
Share on other sites

High Precision Event Timer http://www.intel.com/hardwaredesign/hpetspec.htm

In regards to OSX, I remember Maxxuss saying that starting 10.4.5, Intel Mac kernel started to use it exclusively, and not many people had HPET in their system.

Hmmm...you know what I'm thinking? I should enable HPET and try to run one of newer kernel w/o any kernel patches and see how far it goes.

Link to comment
Share on other sites

I have BIOS 1.1.

Here is picture (a little blurry) of my ACPI setting:

p8300185sp0.th.jpg

I have tried these settings and my USB survives a sleep now. Weird. Settings you would think would HELP, don't. Not sure which exactly makes it work, but it appears to work, so I'm not going to mess with it. :-). Thanks for the tips (& sharing!)

 

10.4.6 JaS, updated to JaS 10.4.7, DVI using GMA 950, 10/100 NIC, 4 GB memory.

 

-Dan

Link to comment
Share on other sites

I have tried these settings and my USB survives a sleep now. Weird. Settings you would think would HELP, don't. Not sure which exactly makes it work, but it appears to work, so I'm not going to mess with it. :-). Thanks for the tips (& sharing!)

 

10.4.6 JaS, updated to JaS 10.4.7, DVI using GMA 950, 10/100 NIC, 4 GB memory.

 

-Dan

Your welcome plympton,

It is good to have your confirmation :dance_24:

 

EDIT: btw, if you do large file transfer (i.e., Torrent using Transmission) that takes long time, OSX won't sleep until that transfer is paused or finished. I haven't rebooted for 2 days now.

Link to comment
Share on other sites

  • 3 weeks later...
You must, PLEASE and then report back.

I want at least 3 confirmation.

Oh, I forgot about that (I have no need for that yet). Probably not, haven't tested...O.k., make that 98.999 % compatible. Nevertheless, I'm still very happy :mellow:

 

Few things about sleep:

1. If you make display and system sleep at exactly same time, only display sleep takes effect.

2. If you are playing QT video for like 2 1/2 hours, sleep function is disabled during that time (nice feature).

 

i'm a bit late, but i had no choice, really...

 

Well i tried with bios 1.20 and all the settings like yours but it doesnt work... i have an apple usb keyboard.

 

i'm using Jas 10.4.7 and my system is overclocked to 320mhz fsb.

Link to comment
Share on other sites

 Share

×
×
  • Create New...