Jump to content

[SOLVED]USB-WiFi Sweex LW163/Ralink RT3370 does not work in Snow Leopard 10.6.8!?


4 posts in this topic

Recommended Posts

My built-in Wifi is not enoght good, so I bought external USB adapter Sweex LW163.


Installed drivers from Ralink official site, but it does not work.


Tested in Win7, it is working fine. When I plug it in my Hackintosh Snow Leopard 10.6.8 nothing happens.(USB thumdrives are working fine.)


Anybody has some ideas, same experience?


P.S. Chip-set for my pain is RT3370.

Link to comment
Share on other sites

I have the solution! (Big thanks to kyndder!!!)


Why I had problem?


Ralink, in their kext has not described my model of USB-WiFi.


How I solved the issue.


Simple block of text below fixed issue, and after restart I got connected.




What you need to do, - Steps.


1. Check in "System Profiler"[About This Mac -> More Info...] what is yours ProductId and VendorId.

Mine was:


Product ID: 0x0163

Vendor ID: 0x177f



2. Copy you kext to desktop twice(one will be for backup).


3. Open one of your kext's Info.plist file from desktop, and check it's structure. You need to find out how equipmet is defined in this file.

In my case it was tree structure, where Device and Vendor Id's were in Decimal format, so before pasting I converted the values from HEX to decimal's.


4. Add you equipment to the Info.plist and save it.


5. Use any utility to install updated kext. I personally used Kext Utiliy.


6. Restart you machine with flags -v -f


7. If everything goes OK you will be able to open Ralink Wireless Utility and configure your profile.

Without profile it will no work, Apple AirPort is not supported.


8. And the last, please post your experience, share your knowledge! :)



P.S. If you have the same ProductId and Vendor Id I think you can try kext modified by me.


Link to comment
Share on other sites

  • 4 weeks later...

  • Create New...