Jump to content

Are Some HDD's Incapable Of Storing An OSX86 Bootloader?


1 post in this topic

Recommended Posts

I have installed a few types of Mac OS X on this laptop (10.6.3, 10.6.8 & 10.7) and i can never get a single bootloader to install. I have tried the following:

  • [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]
  • Chimera Installer
  • PC-EFI Installer
  • MyHack Installer
  • Chameleon Installer

I have tried to manually write the boo0 and boot1 files using DD, i have tried install the bootloaders onto the small 200mb formatted EFI partition and nothing happens whenever i try boot from i HDD i get the following type boot errors and messages.




Could there be a feature on this laptop, A Western Digital, shipped with the laptop that would prohibit the installation of a osx86 bootloader. I have successfully installed windows, various linux's and BSD's on the laptop and never had problems, Its just that no bootloader will install.




Found out that it is due to the fact that this drive has a feature called advanced format which autocatically uses 4kb allocation which means that Chameleon cannot install using the usual technique. I managed to install the bootloader but you will need to follow the following steps.

  1. You will need a Ubuntu Live CD.
  2. Boot into the ubuntu session and copy the following two files from the Chameleon package = "boot0" and "boot1h"
  3. issue the following command
    dd if=boot0 of=/dev/sda bs=440 count=1

    and also

  4. dd if=boot1h of=/dev/sdaX bs=4096

    - sdaX is whatever partition you OSX is held (i.e sda2)

  5. Now exit ubuntu and boot your mac using an [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] CD, You need to use the CD and you may not be able to boot from the HDD just yet.
  6. When you are in the mac, run a bootloader insaller package (Chimera, PC-EFI, yada yada yada)
  7. Customize your /Extra folder for you particular hardware.

These are the exact steps i took to install a bootloader with this "Advanced Format" feature, I hope it can be of help to other who have had this problem.



Link to comment
Share on other sites


  • Create New...