Jump to content
InsanelyMac Forum
client00

OS X 10.7 (Lion) install on Dell Optiplex 745

Recommended Posts

For those interested in getting their Dell Optiplex 745 PC powered by the new Mac OS X 10.7 "Lion", here is the corresponding link to the osx86project wiki, I wrote this entry after successfully getting it to work.

 

osx86project wiki link for the Optiplex 745

 

Enjoy.

 

Please discuss any suggestions/solutions you have in mind.

 

Edit 17 Apr 2012

For quick results read post #64

Special thanks to my e-friend BugsB.

Share this post


Link to post
Share on other sites
Advertisement
For those interested in getting their Dell Optiplex 745 PC powered by the new Mac OS X 10.7 "Lion", here is the corresponding link to the osx86project wiki, I wrote this entry after successfully getting it to work.

 

osx86project wiki link for the Optiplex 745

 

Enjoy.

 

Please discuss any suggestions/solutions you have in mind.

 

I just wanted to say, client00, you ROCK! I would probably never have gotten Lion working on my Optiplex without your entry in the HCL. Thank you so much. Everything worked perfectly. I did have a bit of trouble getting the Ethernet adapter recognized, but that was because I was using an older version of the kext. You are awesome!

Share this post


Link to post
Share on other sites

You mention several times about installing kexts in /E/E, but i have used the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] installation method and don't have an /Extra folder on my installation. Is it okay to creat that folder or do I need to install all the mentioned kexts in /S/L/E?

Share this post


Link to post
Share on other sites
You mention several times about installing kexts in /E/E, but i have used the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] installation method and don't have an /Extra folder on my installation. Is it okay to creat that folder or do I need to install all the mentioned kexts in /S/L/E?

 

Either way will work fine.

Reason for placing kexts in /E/E is mainly to keep those extra kexts neat and safe from system updates.

Some kexts require to be installed in /S/L/E, even though it has been reported they work fine when placed in /E/E.

 

In any case use Kext Wizard (or a similar utility) that will easily take care of repairing file permissions and rebuilding kext cache.

Share this post


Link to post
Share on other sites

Hi guys,

 

just curious, as I'm interested in getting a cheap optiplex for a small lion server Id like to set up.

 

I have seen one on ebay for like £50, has the usual c2d 1.86Ghz, 1gig of ram and about an 80gb hard drive.

However, the one I am looking at is the Ultra Small Form Factor (USFF), which only has integrated graphics with no expansion slots available.

 

Does anyone know if there is a working solution for the integrated GMA 3000 that this model has?

 

Id really like to get lion running on this box as it is super small and low powered.

As far as I'm aware, everything else will work correctly.

 

Will this be ok or will I need to go for the small or desktop form factor versions?

 

Thanks guys

Eds

Share this post


Link to post
Share on other sites
Does anyone know if there is a working solution for the integrated GMA 3000 that this model has?

 

Hello Eds.

As of now there is no working solution, you won't be able to even get proper screen resolution (max 1024x768) let alone have hardware acceleration (QE/CI). Needless to say, both are necessary to live the Mac OS X experience.

I've scoured the internet, no kext exists for this graphics controller because it is substantially different from other supported GPUs.

In other words you have to use an add-in PCI-e video card, which forces you to select an upgrade friendly form factor of the Optiplex.

Hope you get one cause they really are reliable machines ;-)

Share this post


Link to post
Share on other sites

QUOTE (Eds89 @ Nov 17 2011, 10:56 PM)

Does anyone know if there is a working solution for the integrated GMA 3000 that this model has?

 

 

Hello Eds.

As of now there is no working solution, you won't be able to even get proper screen resolution (max 1024x768) let alone have hardware acceleration (QE/CI). Needless to say, both are necessary to live the Mac OS X experience.

I've scoured the internet, no kext exists for this graphics controller because it is substantially different from other supported GPUs.

In other words you have to use an add-in PCI-e video card, which forces you to select an upgrade friendly form factor of the Optiplex.

Hope you get one cause they really are reliable machines ;-)

 

Hi Client,

 

Thanks for your response.

I've been trying to find some post somewhere, where somebody has attempted installation on this machine.

 

So far I've got the absolute basics working, it installs fine, and I can boot with the latest 2.1 build of chameleon, and an old IOATAFamily.kext, for the internal drive to be recognised, and have now found a next that works for the Broadcom 5754, although this does not get picked up as built in, therefore the AppStore won't let me sign in.

 

As for the video (GMA 3000), I have had zero success, and the ADI198 audio driver that i'm using (AppleAC97Codec198x.kext does not seem to work either.

 

I'm not fussed about the experience for this machine, as i intend for it to be a small, quiet and low powered file server, and I have a macbook and two other i7 hacks that work great. I'd just like to get audio and appstore sign in working and ill be content.

 

Can anyone point me in the direction of someone that has at least attempted this before?

 

Thanks

Eds

Share this post


Link to post
Share on other sites

So far I've got the absolute basics working, it installs fine, and I can boot with the latest 2.1 build of chameleon, and an old IOATAFamily.kext, for the internal drive to be recognised, and have now found a next that works for the Broadcom 5754, although this does not get picked up as built in, therefore the AppStore won't let me sign in.

 

As for the video (GMA 3000), I have had zero success, and the ADI198 audio driver that i'm using (AppleAC97Codec198x.kext does not seem to work either.

 

I'm not fussed about the experience for this machine, as i intend for it to be a small, quiet and low powered file server, and I have a macbook and two other i7 hacks that work great. I'd just like to get audio and appstore sign in working and ill be content.

 

Can anyone point me in the direction of someone that has at least attempted this before?

 

Thanks

Eds

 

Hello again.

As it's already been mentioned the GMA3100 won't work, so you can forget about it.

As for sound, take a look again at the wiki. You need the patched VoodooHDA kext I have uploaded. It's for ICH8 HD audio which I believe your 745 has (it's not AD1983).

Finally there is a solution for the Mac App Store login problem. Read the relative comment in the wiki. If you do not understand take a look at this post

Share this post


Link to post
Share on other sites

I used iAtkos L2 (Lion 10.7.2) and works great.

 

Used the same as is in the pic:

 

Works: Sound, Network and Video card.

GeForce 8600 GT WIth Dual Monitor (NVEnabler64.kext with kext ultillity) and for the Ethernet I'm using a Dinex DX-PCIGB PCI and the nic board (BCM5754)

 

745n.jpg

Share this post


Link to post
Share on other sites

I was able to get everything working using the instructions on the osx86 website. and upgraded to 10.7.2

 

But I have a few problems.

 

Network doesn't work after waking up from sleep.

can't login to facetime.

 

Does anyone else have these problems? and can you post your boot.plist and E/E kexts used?

Share this post


Link to post
Share on other sites

I was able to get everything working using the instructions on the osx86 website. and upgraded to 10.7.2

 

But I have a few problems.

 

Network doesn't work after waking up from sleep.

can't login to facetime.

 

Does anyone else have these problems? and can you post your boot.plist and E/E kexts used?

 

I used the BCM5722D.kext

Share this post


Link to post
Share on other sites

can't login to facetime.

 

I had the same problem

Can you log into the App Store? If so, then I have no clue, but if not, then you need to insert the EFI string of your ethernet device into your Boot.plist

Best way to do this (and probably the only way to get it) is by using EFI Studio, which you can get here.

 

Hello Eds.

As of now there is no working solution, you won't be able to even get proper screen resolution (max 1024x768) let alone have hardware acceleration (QE/CI). Needless to say, both are necessary to live the Mac OS X experience.

I've scoured the internet, no kext exists for this graphics controller because it is substantially different from other supported GPUs.

In other words you have to use an add-in PCI-e video card, which forces you to select an upgrade friendly form factor of the Optiplex.

Hope you get one cause they really are reliable machines ;-)

 

There is no solution for the hardware acceleration, but to get higher resolutions, you can use the "Graphics Mode" boot flag in the Boot.plist. That way you can use whatever resolution your monitor and OS X natively support, which for me is up to 1600x1200@32. :) Works fine for me, although it would be nice to have QE/CI...

Share this post


Link to post
Share on other sites

hey friends, may I pls remind everybody that there is 4 (!!) different FF's (form factors) of the 745:

  • USFF: Ultra Small (no slot for extra grfx card)
  • SFF: Small (reduced height - requires reduced height grfx card)
  • DFF: Desktop
  • MFF: Mini

Would from now everybody pls first post which of the FFs you are talking about ..

 

Also I recommend that everybody above please take a minute, edit their posting(s) and add this missing information, if missing (or simply add that significant info into your signature). Everything else only leads to model confusion again (and we've had way more than enough of that in these forums .....)

 

Thank you very much,

Bugs

Share this post


Link to post
Share on other sites

hey friends, may I pls remind everybody that there is 4 (!!) different FF's (form factors) of the 745:

  • USFF: Ultra Small (no slot for extra grfx card)
  • SFF: Small (reduced height - requires reduced height grfx card)
  • DFF: Desktop
  • MFF: Mini

Would from now everybody pls first post which of the FFs you are talking about ..

 

Hi.

We mostly refer to DFF, as it happens to be the most upgrade friendly (regarding RAM, expansion cards etc) form factor of the Optiplex 745.

Thx for your comment.

:-)

Share this post


Link to post
Share on other sites
I used iAtkos L2 (Lion 10.7.2) and works great. Used the same as is in the pic: Works: Sound, Network and Video card. GeForce 8600 GT WIth Dual Monitor (NVEnabler64.kext with kext ultillity) and for the Ethernet I'm using a Dinex DX-PCIGB PCI and the nic board (BCM5754) 745n.jpg

 

How did you get it to boot? I burn it to a disk pop it and and NOTHING happens.

Share this post


Link to post
Share on other sites

core 2 duo or quad required, Pentium D don't work ...

 

also hit a key then boot with -v ...

Share this post


Link to post
Share on other sites

How did you get it to boot? I burn it to a disk pop it and and NOTHING happens.

 

I used a mac to burn the iAtkos DVD because is a DMG file, I did the same the first time: burn the DMG file in windows and didn't work, just make sure you select the NON-AHCI SATA in the Drivers section.

Share this post


Link to post
Share on other sites

For those interested in getting their Dell Optiplex 745 PC powered by the new Mac OS X 10.7 "Lion", here is the corresponding link to the osx86project wiki, I wrote this entry after successfully getting it to work.

 

osx86project wiki link for the Optiplex 745

 

Enjoy.

 

Please discuss any suggestions/solutions you have in mind.

 

client00,

I follow your direction but when I get to the install screen I get a white screen with the rainbow mouse just spinning and hang there.

Any thought I did something wrong.

Share this post


Link to post
Share on other sites

client00,

I follow your direction but when I get to the install screen I get a white screen with the rainbow mouse just spinning and hang there.

 

Need more info to help.

Please boot in verbose mode using -v switch (type -v at the command prompt and then press ENTER)

 

...or simply give it some more time, here's something I came across:

"It may pause on the grey apple screen with the spinning wheel for quite some time. Just let it be."

Share this post


Link to post
Share on other sites

I installed lion successfully on 745 SFF by using iAtkos L2. Graphic card ATI 5450 works out of box.

But I have the same trouble as others. Network stops working after waking up (BCM5722D.kext, have to restarty computer to gain access to internet),

and also can not log in icloud and some other i-stuffs.

 

 

I used iAtkos L2 (Lion 10.7.2) and works great.

 

Used the same as is in the pic:

 

Works: Sound, Network and Video card.

GeForce 8600 GT WIth Dual Monitor (NVEnabler64.kext with kext ultillity) and for the Ethernet I'm using a Dinex DX-PCIGB PCI and the nic board (BCM5754)

 

745n.jpg

Share this post


Link to post
Share on other sites

Hi carrick, thanks for your report. Would you please post the online-shop (or model page) link to the exact ATI 5450 you purchased? I have made the exp. several times in the past that a 1234 w. xyzMB from e.g. MSI would fully work in OS X, and the "same" from PNY etc. not ....

 

re. Ethernet: search here in the forum for how to correctly unload kexts BEFORE sleep, then REload them on wake-up. Might work, worth a try. Might also be something that can be tweaked in the DSDT, but I don't know details.

 

re. iCloud etc.: have you tried the iCloud fixes that are floating around? Wasn't there even an iCloud fix offered in iAtkos L2 (even though I don't see it in the screenshot above)?

 

My 745 SFF is a bit pending right now so I don't have it in my sig yet .. After getting the grfx card I need to see if it even needs a new mobo .. worth it I guess 'cause it's running with a Core 2 Quad.

Share this post


Link to post
Share on other sites

Thanks for your suggestion. I have both similar configure SFF and DFF 745........but I use SFF for hackingtosh

 

Here is the link for graphic card. It is not a powerful one, but serves my purpose.

 

http://www.amazon.com/gp/product/B005LU2Z0C/ref=oh_o00_s00_i00_details

 

I will follow the clues you siad to fix the other two problems.

 

 

Hi carrick, thanks for your report. Would you please post the online-shop (or model page) link to the exact ATI 5450 you purchased? I have made the exp. several times in the past that a 1234 w. xyzMB from e.g. MSI would fully work in OS X, and the "same" from PNY etc. not ....

 

re. Ethernet: search here in the forum for how to correctly unload kexts BEFORE sleep, then REload them on wake-up. Might work, worth a try. Might also be something that can be tweaked in the DSDT, but I don't know details.

 

re. iCloud etc.: have you tried the iCloud fixes that are floating around? Wasn't there even an iCloud fix offered in iAtkos L2 (even though I don't see it in the screenshot above)?

 

My 745 SFF is a bit pending right now so I don't have it in my sig yet .. After getting the grfx card I need to see if it even needs a new mobo .. worth it I guess 'cause it's running with a Core 2 Quad.

Share this post


Link to post
Share on other sites

real quick cause I gotta drive to a job: forget SleepWatcher - the NIC gets deactivated on BIOS level, and not (always) correctly reactivated on wake-up. This needs to be tackled in the DSDT. I ran all compilable patches in DSDT patcher, that didn't solve this. Google for something like "DSDT BCM5722D.kext sleep" or "DSDT wake up lan after sleep" or "DSDT wake up nic after sleep". I am totally sure this has been solved yet, just a matter of looking.

 

grfx card: oops, I must not have followed your link (256MB version) directly 'cause I ordered the 1GB version .. just $10 more after mail-in rebate .. works good res. + QE/CI - just tested on VGA so far. The only odd thing is that I need to press a keyboard key TWICE for OS X to wake up, the second key about 5 seconds after hitting the first key - otherwise it goes back to sleep, hmmm. Doesn't matter if the ATI5000injector kext is in E/E or S/L/E. Adding Eulemur as ATIConfig string doesn't help, either. That oddness did not change in 10.7.3 (and neither did the NIC-in-BIOS reactivate as expected).

 

Does your 256MB version wake up right away from sleep with *one* keyboard stroke?

Share this post


Link to post
Share on other sites

Great. As long as it works for you.you have better performence with 1GB.

 

Yes. I have the same syptom as yours.I have to hit keyboard several times, and eventually it wakes up...... I turn it off most of the time..

 

I tried several way to fix the internet problem including yours, so far no success. I just start to do hackingtosh and haven't started to mess with DTST (a lot home work to me).

 

 

 

real quick cause I gotta drive to a job: forget SleepWatcher - the NIC gets deactivated on BIOS level, and not (always) correctly reactivated on wake-up. This needs to be tackled in the DSDT. I ran all compilable patches in DSDT patcher, that didn't solve this. Google for something like "DSDT BCM5722D.kext sleep" or "DSDT wake up lan after sleep" or "DSDT wake up nic after sleep". I am totally sure this has been solved yet, just a matter of looking.

 

grfx card: oops, I must not have followed your link (256MB version) directly 'cause I ordered the 1GB version .. just $10 more after mail-in rebate .. works good res. + QE/CI - just tested on VGA so far. The only odd thing is that I need to press a keyboard key TWICE for OS X to wake up, the second key about 5 seconds after hitting the first key - otherwise it goes back to sleep, hmmm. Doesn't matter if the ATI5000injector kext is in E/E or S/L/E. Adding Eulemur as ATIConfig string doesn't help, either. That oddness did not change in 10.7.3 (and neither did the NIC-in-BIOS reactivate as expected).

 

Does your 256MB version wake up right away from sleep with *one* keyboard stroke?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×