Jump to content

Eds89

Members
  • Content count

    33
  • Joined

  • Last visited

About Eds89

  • Rank
    InsanelyMac Protégé
  • Birthday 04/03/1989

Contact Methods

  • MSN
    eds89@me.com

Profile Information

  • Gender
    Male
  • Location
    Ipswich
  1. Hi guys. I bought a Dell Optiplex 7455 USFF late last year in an attempt to set it up as a small mac mini style server, to host all my media files for streaming to the apple tv downstairs. Everything went really well with the install, other than things like the graphics (not so important as it would probably be headless anyway), and also, the sleep/wake ability. Ideally, i'd like to get a basic intel box that has a low power draw, and has enough compatibility to be able to sleep and then wake on demand when access by the apple tv. I have another couple of hackintosh desktops, but have been unsucessful in getting sleep/wake working properly on any of them. Can anyone offer any suggestions for a decent small unit that can do what I need? Would also be great if it was quite quiet, but not a huge deal. Thanks Eds
  2. Hey guys, I have done a bit of research and as far as i'm aware, no one has documented an install of lion on an optiplex 745 ultra small form factor, probably as a some of the hardware has zero kext support. I'm just starting this thread to see if anyone has attempted or had any success installing lion on this machine, or anything similar, and getting it working to a good degree. Basically the machine is a 2.4Ghz C2D, 2Gigs of ram, an intel GMA 3000, ADI198 audio and broadcom 5754 ethernet controller. So far, I have managed to get lion installed and running on the internal drive, using a modified IOATAfamily.kext i picked up from another dell install, lspcidrv.kext, nullcpupowermanagement, fakesmc, ev0reboot, elliotforcelegacyrtc (to prevent bios reset), and BCM5722D.kext for the ethernet controller. thats kind of the essentials all working, however, the areas I'm having problems, are audio, video and time machine fixed. As far as I can tell, the GMA 3000 is so different to other GMAs, that there is no support for it what soever, therefore I am stuck with 1280x1024 with no CI/QE. Secondly, I can't find a next that works to pick up the audio at all, and not sure exactly what I should be looking for And finally, I assume due to the network controller, whenever I try to log into the app store, or iCloud, I get the hardware can't be authenticated error message. Sleep doesn't work even with sleep enabler, I think due to the GMA not having a next loaded for it. I am not using a modified SMBios.plist, or a DSDT.aml as I have not had any experience using them, and wouldn't know what to edit to make them of any use. I'm hoping that someone out there has had some experience with this machine, or at least can point me in the right direction, or even confirm my suspicions that there will not likely be any support for this hardware further down the line. Thanks in advance Eds
  3. Hi Client, Thanks for your response. I've been trying to find some post somewhere, where somebody has attempted installation on this machine. So far I've got the absolute basics working, it installs fine, and I can boot with the latest 2.1 build of chameleon, and an old IOATAFamily.kext, for the internal drive to be recognised, and have now found a next that works for the Broadcom 5754, although this does not get picked up as built in, therefore the AppStore won't let me sign in. As for the video (GMA 3000), I have had zero success, and the ADI198 audio driver that i'm using (AppleAC97Codec198x.kext does not seem to work either. I'm not fussed about the experience for this machine, as i intend for it to be a small, quiet and low powered file server, and I have a macbook and two other i7 hacks that work great. I'd just like to get audio and appstore sign in working and ill be content. Can anyone point me in the direction of someone that has at least attempted this before? Thanks Eds
  4. Hi guys, just curious, as I'm interested in getting a cheap optiplex for a small lion server Id like to set up. I have seen one on ebay for like £50, has the usual c2d 1.86Ghz, 1gig of ram and about an 80gb hard drive. However, the one I am looking at is the Ultra Small Form Factor (USFF), which only has integrated graphics with no expansion slots available. Does anyone know if there is a working solution for the integrated GMA 3000 that this model has? Id really like to get lion running on this box as it is super small and low powered. As far as I'm aware, everything else will work correctly. Will this be ok or will I need to go for the small or desktop form factor versions? Thanks guys Eds
  5. Hey guys, Still having a couple of issues with Lion. With the gtx 260, I still can not wake from sleep. Everything powers up but the monitor stays off, very annoying. Rear USB ports don't work?! Should I be using a patched DSDT for this system? Final point, the dvd drive sounds like it spins up every five minutes, finds no disc and spins down. Anyone else having these issues? Regards Eds
  6. Hey guys, have had a bit of a search but came up empty. Im looking to virtualise Windows 7 on my Lion hackintosh using VMWare fusion 4. Vmware supposedly support hardware acceleration, aero and dx9.0c etc etc. However when I run windows 7 in the virtual machine, the graphics adapter is simply listed as a standard VGA adapter and does not appear to support any hardware acceleration or DX9.0 or anything, meaning most games, even mine craft can not be run. I can only assume it is to do with the next that is currently loaded for the adapter within Lion. My pc is a core i7 machine, 6GB of ram, and an Nvidia GT260. The card works perfectly in Lion, but I would like to virtualise windows with the same support. Anyone come across this before or have any suggestions? Thanks Eds
  7. It seems many people are having this issue, but none have found a fix yet. I had assumed it was just me. Hopefully someone will come up with something soon
  8. Hey guys, think I am having a similar issue to you all. I have a studio fps 435mt, with some proprietary dell mono in it, core i7 920 and gtx 260. my issue is that sleeping the machine works fine, although it does also stop power to my wireless keyboard and mouse so need wired keyboard to wake. however when it does wake, i think i get the graphics suppression issue, where the monitor does not wake. I can hear the fans and drives spinning up, but no monitor. Ive had a look to try and find my sleep and wake events in the console but not 100% on where to look for them. I have an auto patched DSDT, but the issue was the same even before I started using that. Any suggestions? Thanks Eds
  9. Hi again guys, Been enjoying my mackintosh, but now I need to find a solution to my sleep issue. I can put the machine into S3 sleep i think it is, where everything except the ram is powered down, however, when powering the machine backup, the fans and drives spin back up but the display does not wake from sleep. I think it must be related to my Geforce GTX260. Anyone else having the issue and know of a fix? thanks guys! Eds
  10. Thanks for the info regarding the audio gain. I will have a crack it it! I seem to be able to remote to my machine, using the intel82567 kext, but after a short time it just drops the connection and has to be physically disconnected and reconnected. As for the shutdown issue, it doesnt appear to happen every time, and DSDT, I have not edited one, and did not install one on my initial installation or since!
  11. Hello ladies and gents, Have just finish install of Lion on my XPS 435MT, couldn't be happier, thanks to all the wonderful peeps on this forum. Have now moved onto an inspiron 530, and am having an issue with my 4670. Seems to all work great, except lion believe two monitors are attached, which means I need mirroring to be turned on at all times, and messes with my refresh rate and resolution options a little. Anyone know if there is currently a way to force it to detect only one monitor? Many thanks Eds
  12. Hi, I got this exact working just yesterday. What you need to do, is go to System/Library/Extensions, and find NVDAN50HAL.kext Right click and show package contents. Go into contents and open info.plist make sure the IDs section looks like this 0x00f010de&0xfff0ffff 0x019010de&0xfff0ffff 0x040010de&0xfff0ffff 0x042010de&0xfff0ffff 0x05e010de&0xfff8ffff 0x05ea10de&0xfff8ffff 0x05ea10de&0xfff0ffff 0x05f010de&0xfff0ffff 0x060010de&0xffe0ffff 0x062010de&0xffe0ffff 0x064010de&0xffe0ffff 0x06e010de&0xfff0ffff 0x086010de&0xffe0ffff 0x08a010de&0xffe0ffff 0x0a2010de&0xffa0ffff 0x0ca010de&0xffe0ffff The two lines in BOLD need to be added in manually You may have problems with regards to permissions on this file, so you may need to duplicate it, make the changes and then overwrite the old file. Once you have done this, you need to go into your /extra directory, and open com.boot.chameleon.plist, and add <key>GraphicsEnabler</key> <string>Yes</string> repair permissions, restart and all should be well!!
  13. Ok I got it all working with a couple of little quirks. Firstly I have VooDooHDA for audio (with a lot of noise at higher volumes) I have GraphicsEnabler, Yes, In my com.chameleoon.boot.plist in /extra, and added a couple of device IDs to my NVDAN50HAL.kext in extensions, and have native support for resolution switching and all the bells and whistles, with my GTX 260. I used the IOATAFamily.kext that mojimbe pointed out which adds support for internal drives, where I am running Lion now I have the BootCamp apple theme for chameleon with a timeout of 1 so it looks almost like booting an apple machine I used a version of intel82566.kext for networking which, while a bit slow to get an IP, does work brilliantly I think thats all the tweaks Ive made so far, although im now going to look at swapping voodoohda for something else, maybe a patched appleHDA to try and correct the noise issue with the speakers, and then I will be looking at the card reader on the front of the machine, as I do not know if this works or not as have not tested it. Also I need to try and get wake from sleep working using the sleep enabler that mojimbe linked to. Also have you guys noticed that if you tell the machine to shutdown from Lion, that once it has powered of, it powers back on again after about 5 or 10 seconds? Let me know how you guys got on! Regards Eds
  14. Guys, I'm getting there! I now have voodoohda installed for audio, which seems to be working although there is a LOT of background noise. As for networking, I don't know what adapter you guys have installed, but I have the intel 82567/L-2 and I have tried both appleintelE1000e.kext (which causes the adapter to show up but only receive data and not send i think) and then i tried intel82566MM.kext which should support my adapter but does not at all. Are you guys running the same adapter and did you have to do anything else to get it working? Thanks Eds
  15. Hey guys, thanks for your updates. Just to let you know I finally managed to find time to start trying out Lion on this machine again. Last night I got as far as installing Lion on my USB Hard drive, using a USB Lion Install Drive. When I get home tonight I will try installing the IOATAFamily.kext onto the USB Lion drive and then see if it can see my internal drive. Assuming it can I will then just image the drive onto the internal. What may be easier is if I install the kext on my USB Installer, so that I can simply install straight to the internal rather than USB. Be safer and cleaner in my mind. I'm not too too worried about sleep but it may be something that becomes nessecary, what I need is audio and networking, which you guys have solved!! My only concern is that you guys are using ATI Radeon cards? I swapped mine out for a geforce GT220, so not sure what the compatibility is like with that card and Lion, but that is an issue for later! Again thanks for your help guys and I will let you know how I get on tonight! Eds
×