Jump to content
InsanelyMac Forum
edmoncu

[GUIDE] P5QL-Pro and Fermi: Simple Generic USB Installer

Recommended Posts

i was able to install a fresh copy of Lion using this Method. it's much much simpler than Snow Leopard was...

 

What's working

- HDD is detected

- Graphics card, full QE/CI acceleration

- Sleep, Restart, Shutdown

- Built-in NIC ; Appstore login possible

- Built-in Sound

 

Here are the steps on creating the USB installer:

 

Needed

- An existing OSX Installation: will need Disk Utility

- 8gb USB drive

- Latest Chameleon package

- Before anything else, make sure to allow display of hidden files using this script at the Terminal:

defaults write com.apple.finder AppleShowAllFiles TRUE

killall Finder

 

Extensions used for Chameleon

Search for 'em online and make sure at least these are the latest builds. I used the same drivers I used for my Snow Leopard before.

 

Kexts (kindly refer to attached file)

Required (copied in Extra > Extensions)

- FakeSMC.kext - to allow OSX to run on generic PCs

Optional (copied in Extra > Extensions)

- AttansicL1Ethernet.kext - for built-in NIC.

- IOAHCIBlockStorageInjector.kext - (optional) to display internal disks normally instead of orange icons

- AHCIPortInjector.kext - for better recognition of SATA devices(?)

- ElliottForceLegacyRTC.kext - prevents (in case) resetting of CMOS setup

- EvOreboot.kext - prevents problem during shutdown

- NullCPUPowerManagement.kext - allows more stable operation even without DSDT

 

This page contains better descriptions and uses of these kexts.

 

Steps:

- Acquired the Lion ZIP

- Note the image files: InstallESD.dmg and BaseSystem.dmg

- Double-click on InstallESD.dmg to mount it

- Browse the image contents of mounted InstallESD.dmg

- There should be a hidden file called BaseSystem.dmg, double-click on it to Mount

 

On the 8gb USB do the following

- Using Disk Utility: Restore BaseSystem.dmg to the 8gb USB

- Copy the following from the root of InstallESD.dmg file to the root of 8gb USB

.disk_label

BaseSystem.chunklist

boot.efi

kernelcache

mach_kernel

MacOSX_Media_Background.png

- Delete the Packages alias file on USB > System > Installation

- Copy the Packages folder (from the root of the InstallESD.dmg mounted image) to USB > System > Installation

- Replace the OSInstall.mpkg on the USB > System > Installation with the OSInstall.mpkg attached here.

- Install Chameleon pointing target to the 8gb USB

- Copy the Kext files to USB > Extra > Extensions folder (create the Extensions folder if it is non-existent yet)

- Create a com.apple.Boot.plist file using TextEdit and save it to USB > Extra folder

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>Kernel</key>

<string>mach_kernel</string>

 

<key>Kernel Flags</key>

<string>-f npci=0x2000</string>

 

<key>EthernetBuiltIn</key>

<string>Yes</string>

 

<key>GraphicsEnabler</key>

<string>Yes</string>

</dict>

</plist>

 

Installation proper using the USB we created:

 

- Boot the PC to the USB

- At the Chameleon screen, press Enter to choose the current disk (w/c is the USB)

- OSX Installation dialog will start

- You may run Disk Utility first to Partition (to GUID Partition Table) and Erase the target drive you want to install Lion to.

- Quit Disk Utility

- Going back to the wizard, go through the dialogs to choose the drive where to install Lion to

- Proceed with the installation of Lion

 

Post-installation phase 1

 

- Boot the PC to the USB

- At the Chameleon screen, choose the disk you recently installed Lion to

- OSX Lion will start

- Go through the wizards until you see the login screen, and finally the desktop

 

Post-installation phase 2

 

- Once you're on the Lion desktop, install the latest Chameleon pointing the target to the drive where we just installed Lion

- At the Lion desktop, browse the USB to copy all the contents of the Extra folder to the Extra folder where we installed Lion

- Decompress and run the VoodooHDA_0.2.56.pkg.zip file to install the audio device

 

Reboot and enjoy :)

 

FYI, my machine specs are the following:

- P5QL Pro BIOS 1004

- Q9550 @ stock

- GTX 470 @ stock

- 40gb Intel G2 SSD

 

screenshot20110704at105.png

 

This method requires no DSDT patches and no Enablers. AND IS NOT COMPLICATED. Only used the latest Chameleon and FakeSMC (as well as Attansic LAN driver)

 

BIOS Settings

 

Main > Storage Config: SATA = AHCI

 

AI Tweaker: all settings = automatic

 

Advanced >

CPU Config:

Max CPUID & Intel C-State: Disabled

the rest: Enabled

 

Chipset > NB Config

Mem remap: enabled

Mem hole: disabled

 

Onboard Devices

Marvell IDE: disabled

Serial port: disabled

the rest: Enabled

 

PCI/PNP > PNP OS: disabled

 

Power

Suspend mode: Automatic

ACPI 2.0: Enabled

ACPI APIC: Enabled

 

Tools > Express Gate: Disabled

 

Used the official latest BIOS file from ASUS and it's working well too!

Chameleon_2.RCr1096.pkg.zip

Extensions.zip

OSInstall.mpkg.zip

P5QLPRO.zip

VoodooHDA_0.2.56.pkg.zip

Share this post


Link to post
Share on other sites
Advertisement

updated: ripped my BIOS file (zipped under P5QLPRO.ZIP). use this board's built-in flasher (EZFlash - ALT-F2 during POST) to backup your existing and update with this one.

 

- you must decompress P5QLPRO.ZIP file to reveal P5QLPRO.ROM file

- the P5QLPRO.ROM file is the one you will use to update the BIOS using EZFLASH

Share this post


Link to post
Share on other sites

Thank you for both this guide and your former ones.

I wish I could take part in this godness of OSX:ing. I would love myself some Lion on my PC but I don't have a working OSX installation to prepare the USB. Is there any way?

Share this post


Link to post
Share on other sites

@honokaz: you may use those pre-built images that you can just extract to a temporary HDD or thru VMWare. From there, you can rebuilt everything.

Share this post


Link to post
Share on other sites

... confirmed, the last link i posted above enabled the sound! You can confirm the settings from the Control Panel. But it just shows No Built-in Audio. under System Information. But it works! :)

 

NOTE: Updated instructions including installation of Audio Device

Share this post


Link to post
Share on other sites

A big thanks, I have trouble in installing Lion from all other guides out there but this. Now my hackple is roaring!

 

Doing further house keeping e.g. getting ntfs r/w to work, updating lion version apps, finding best way for backup etc.

 

Are u getting the digital out working with Voodoohda? no luck on mine. Also trying to figure out if I can get my SB Xifi sound card to work, at least the analog output.

Share this post


Link to post
Share on other sites

@kome: thank you that this guide helped you.

 

NOTE: there appears to be a tendency for my hackintosh to be unstable when using my USB speakers with VoodooHDA at the same time on startup as twice I encounter Kernel Panics: first during the desktop, the next one is on startup.

Share this post


Link to post
Share on other sites

Hi edmoncu,

 

thanks for this extremely useful guide!

 

Just the size of the USB drive was driving me crazy (as I discovered after some hours of trials), until I tried to create a partition of 8GB instead of using my whole 16GB pen. Maybe it would be better to write about this partition size limit in BIG and RED :blink:

 

Anyway, now my system is perfectly working apart for the sleep.

 

When it uses S3 state (the same for auto) it switches off the monitor, keyboard, mouse and maybe something else, but not the power supply and motherboard, so I can't wake it up and I need to push the reset button and restart.

 

With S1 state it wakes up but just because only the monitor is switched off.

 

Does your system enter in the real sleep, like in windows (with the flashing power led)?

 

Any idea about how to solve the little problem?

 

Thanks ;)

 

PS. I love using my new mac!! ;)

Share this post


Link to post
Share on other sites

i am trying sleep... so far here's how it goes...

 

- sleep works coz it can resume (even coming from a previous sleep)

- restart works (not coming from sleep)

- shutdown works (not coming from sleep)

 

what does not work (same with my Snow Leopard before even with a valid Sleep Enabler)

- do a sleep

- then do a restart or shutdown

- it will shutdown the OS, but will just stay blank (the computer is still powered on)

Share this post


Link to post
Share on other sites

for a more mac-like experience, you may edit your /Extra/com.apple.Boot.plist file with these contents

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>Kernel</key>

<string>mach_kernel</string>

 

<key>Kernel Flags</key>

<string>-f npci=0x2000</string>

 

<key>EthernetBuiltIn</key>

<string>Yes</string>

 

<key>GraphicsEnabler</key>

<string>Yes</string>

 

<key>Timeout</key>

<string>0</string>

 

<key>GUI</key>

<string>No</string>

 

<key>Legacy Logo</key>

<string>Yes</string>

 

<key>Quiet Boot</key>

<string>Yes</string>

</dict>

</plist>

 

The Timeout, GUI, Legacy Logo and Quiet Boot setup keys are set not to display any Chameleon-related prompts on startup (unless you press F8 of course).

Share this post


Link to post
Share on other sites

Hello,

thanks for your great work! It works perfect, but I have some trouble with my 9500 GT. Normaly it should work with GraphicsEnabler but it don´t.

 

I already updatet chamelion to V 1221

 

Thanks

 

 

 

Motherboard: Asus P5QL Pro (P43 + IHC10)

Ram: 4 x 2GB OCZ (DDR2 – 8500; FSB 1066)

Prozessor: Intel Core2 quad (Q9550)

Grafikkarte: Gainward nVIDEA 9500 GT 1GB passiv

Festplatten: 1 x 1TB SATA (WD), 1 x 500 GB SATA (Seagate)

DVD-ROM: 1 x SATA (LG)

post-197983-1311681007_thumb.jpg

post-197983-1311681013_thumb.jpg

Share this post


Link to post
Share on other sites

... NOTE: updated to add:

 

<key>EthernetBuiltIn</key>

<string>Yes</string>

 

on /Extra/com.apple.Boot.plist file to fix App Store login issue

Share this post


Link to post
Share on other sites
Power

Suspend mode: Automatic

ACPI 2.0: Enabled

ACPI APIC: Enabled

 

Hi,

 

My P5QL Pro only works if I set - Suspend mode: S3 only.

Share this post


Link to post
Share on other sites

Installed using your method on a PQ5 and it installed beautifully. The only problem I encountered was with that version Chameleon. It over wrote the version I used for booting snow leopard...and wouldn't allow me to boot SL into 64 bit. Also when I did manage to boot SL...my HDMI connection wouldn't work.

 

I think my issues have to do soley with this version Chameleon because HDMI wouldn't work in Lion either...only VGA.

Share this post


Link to post
Share on other sites

This is the best install for me so far... Running Snow Leopard on SSD. Made 8 Gb USB Stick as above. made thru to Chameleon, but wouldn't install on the USB drive . Tried Xmove which also had issues installing on USB. Move OS install pkg to USB didn't help. The system boots to Lion install screen, past the language prompts, allowed me to partition the disk and when I try to install, prompt says this copy of lion is damaged. Any ideas?

THx.. :wacko:

Share this post


Link to post
Share on other sites

@bazzmanz: if you can try to use grsync when copying the files to the USB to make sure that the usb will have an accurate copy of the Lion installer.

Share this post


Link to post
Share on other sites
@bazzmanz: if you can try to use grsync when copying the files to the USB to make sure that the usb will have an accurate copy of the Lion installer.

 

Thx Will try this Much appreciated.

Share this post


Link to post
Share on other sites
@UnderOath777: have you tried using the BIOS file posted?

No, I using BIOS 2 years old(by Juzzi if you know), cuz my motherboard P5Q, and when i Install 10.5.4 on it, but AHCI function is enabled. Maybe i need some BIOS?

When I don't install NVEnabler64.kext, Restart working good, Shutdown won't (freeze and BIOS to default) Sleep mode don't work (cuz video don't working) When i install NVEnabler64.kext, Shutdown and Sleep mode working good (I use Sleeper.kext in Extra-Extentions), but restart won't (freeze and BIOS to default).

I see that is problem with NVEnabler64.kext, cuz in Chameleon GraficsEnabler=Yes , don't work... only NVEnabler64 start my video with QE

Share this post


Link to post
Share on other sites

Thank you very much for this detailed guide... worked like a charm. There are some issues I cant get around... would be cool if we can discuss them:

 

1.) After lets say 10 minutes... depending on the amount of use the internet connection dies... The DHCP configuration shows a weird IP in the network settings. And I am not able to connect anylonger. Turning off the connection and restarting does not help... weird -> status says still connected but not to my routers IP... also its not able to find a DNS server. So I have to restart to get it back to work. Could that be a problem with the driver of the lan modul ?

 

I got to say that I had Snow a couple of years on the same machine without this weird issue...

 

2.) Any news regarding sleep ? With me this isnt working either. Turning the computer to sleep... kicks it into a koma... means that its not pos to get it back to life... Also the power unit the harddisks and the fans are still working. Just the screens turn off. Anybody tried the sleep enabler kexts?

 

hmmm...

 

Apart from that .... I am quite happy... guess we will solve the last issues as well...

 

 

Thanks Again Mate...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×