Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
MaLd0n

Novo PC_EFI para Lion e Snow

62 posts in this topic

Recommended Posts

Aqui funcionou num pen drive.

 

Lembrem que este é para HFS+, não para FAT32.

 

 

Ola Old...

 

instalei o .pkg em um pen drive formatado GUID, apos o boot aparecem as opcoes de hd(2,2) slsb--que eh o snow leopard que esta rodando e hd (1,2) mac osx base system,escolho o "base system",dai aparece rapidamente algo de "efi" e o sistema "rebota"...ele nao para com o -v para ser analizado o erro..

 

em todas as formas o sistema da reboot, geralmente apos loading drivers...com o XPC(todas as versoes),com [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] da "BErrr"

 

continuo na teimosia de instalar no Sandy Bridge...

 

c.frio

Share this post


Link to post
Share on other sites
O PC_EFI não tem suporte a Sandy Bridge.

 

Logo o Andy passa os patches pro AnVAL e o seu problema estará resolvido.

 

Ja esperava isto....

Eta processador muquirana...o SL roda legal e o Lion faz exigencias...

 

Obrigado

 

c.frio

Share this post


Link to post
Share on other sites

Caros Maldon e Old,

com o PCEFI pra Lion sobe tudo. Do Wind ao Linux passando pelo Lion e o Snow. O Lion rodando em HDD externo sata e o boot num pendrive.

wink_anim.gif

Grandes idéias, parabéns para a comunidade.

Share this post


Link to post
Share on other sites

 

muito bom para primeira tentativa de boot loader lion

 

cpu não é reconhecido correctamente

 

Modelo: MacBook Pro

Identificador de modelo: MacBookPro8,3

Nome do processador: Dual-Core Intel Xeon / deveria ser i5

Velocidade do processador: 2,27 GHz

Número de processadores: 1

Número total de núcleos: 2

Cache L2 (por núcleo): 256 KB

Cache L3: 3 MB

Memória: 4 GB

Velocidade de interligação do processador: 33.8 GT/s

Versão da ROM de arranque: MBP81.0047.B04

Versão de SMC (sistema): 1.25f4

 

 

mas de certeza que virão novas versões e este problema resolvido

Share this post


Link to post
Share on other sites
muito bom para primeira tentativa de boot loader lion

 

cpu não é reconhecido correctamente

 

Modelo: MacBook Pro

Identificador de modelo: MacBookPro8,3

Nome do processador: Dual-Core Intel Xeon / deveria ser i5

Velocidade do processador: 2,27 GHz

Número de processadores: 1

Número total de núcleos: 2

Cache L2 (por núcleo): 256 KB

Cache L3: 3 MB

Memória: 4 GB

Velocidade de interligação do processador: 33.8 GT/s

Versão da ROM de arranque: MBP81.0047.B04

Versão de SMC (sistema): 1.25f4

 

 

mas de certeza que virão novas versões e este problema resolvido

 

adicione no smbios

SMcputype=1537

Share this post


Link to post
Share on other sites
Passei os patches do Lion pro trunk 752, se alguém quiser testar

http://www.sendspace.com/file/j283mb

 

muito bom trabalho , reconheceu o meu cpu e mais tem gui, demorou foi mais tempo para ler as system kext, fez o psates e e csates , tenho que fazer mais testes nomeadamente com o smbios que para a versão do maldon tinha muitas key e não reconhecia o cpu . e tenho que fazer mais testes com o DSDT estava a ter problemas com o reboot , instalei a openhaltresart, mas vou retirar para ver se os problemas estão ultrapassados .

 

muito bom trabalho de vc os dois maldon e oldnapalm e dos desenvolvedores do boot .. viva o mac os x

 

1 abraço

Share this post


Link to post
Share on other sites

Eu tinha esquecido um patch, nao estava funcionando no Snow, só no Lion. Em breve o Maldon vai postar um instalador com a versão corrigida.

 

Para não demorar no boot do Lion, crie um mkext

sudo kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

Share this post


Link to post
Share on other sites
muito bom trabalho , reconheceu o meu cpu e mais tem gui, demorou foi mais tempo para ler as system kext, fez o psates e e csates , tenho que fazer mais testes nomeadamente com o smbios que para a versão do maldon tinha muitas key e não reconhecia o cpu . e tenho que fazer mais testes com o DSDT estava a ter problemas com o reboot , instalei a openhaltresart, mas vou retirar para ver se os problemas estão ultrapassados .

 

muito bom trabalho de vc os dois maldon e oldnapalm e dos desenvolvedores do boot .. viva o mac os x

 

1 abraço

com alguns testes estou a utilizar smbios boot.plist snow

Captura_de_ecr___2011_04_27_at_21.46.04.png

Captura_de_ecr___2011_04_27_at_21.47.21.png

Share this post


Link to post
Share on other sites
Chameleon 752 com os patches do Andy para Lion e Snow Leopard

Chameleon_RC5_752_Lion_Snow.pkg.zip

 

http://www.insanelymac.com/forum/index.php...t&p=1674711

 

testando há duas horas tudo a funcionar lion e snow com este loader , cpu correcto, pstates e csates, temperatura normal, reboot a funcionar bem , sleep , vou continuar a testar .

 

Parabens para vc os dois muito bom trabalho ... continuem é preciso mais gente como vocês no OS X ..

 

1 abraço

Share this post


Link to post
Share on other sites
Depois da atualização parece que a temperatura e a atividade dos núcleos aumentou um pouco (55°C no máximo na CPU 1).

Roda no terminal

 

ioreg -lw0 | grep PerformanceStateArray

 

ioreg -lw0 | grep CSTInfo

 

kextstat | grep LPC

Share this post


Link to post
Share on other sites
Roda no terminal

 

ioreg -lw0 | grep PerformanceStateArray

| | "PerformanceStateArray" = (<5a090000c05701000a0000000a0000002409000024090000>,<3c060000e0ed00000a0000000a0000001b0600001b060000>)

 

ioreg -lw0 | grep CSTInfo

"nada"

 

kextstat | grep LPC

59 0 0xffffff7f80bf7000 0x3000 0x3000 com.apple.driver.AppleLPC (1.5.1) <9 5 4 3>

Share this post


Link to post
Share on other sites

Aqui também não tem CSTInfo no ioreg do Lion, mas certamente está gerando os C-states, porque a temperatura está normal, e quando não tem C-states ela sobe uns 20 graus aqui.

Share this post


Link to post
Share on other sites
Aqui também não tem CSTInfo no ioreg do Lion, mas certamente está gerando os C-states, porque a temperatura está normal, e quando não tem C-states ela sobe uns 20 graus aqui.

é

no meu tb não retornava nada

Share this post


Link to post
Share on other sites

Tudo certo e sem DSDT, apenas o FakeSMC e alguns drives específicos como o Atheros, Aty_init, VoodooHDA e DWA-125.

Com este bootloader ainda é necessário apagar o arquivo PlatformSupport.plist?

 

PS. temperatura normal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×