Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


ntfs_fixup magic doesn't match = chameleon rc5 only?

8 posts in this topic

Recommended Posts



computer boots fine, able to chose between osx and windows 7 with chameleon and both work but before chameleon gui it has this ntfs_fixup message that appears for around 2-3 seconds


chameleon rc4 i wasn't getting this message, i upgraded to rc5 because i had hibernate sleep issues with Windows 7 and rc4 didn't have boot0hfs to set windows 7 as active partition (fixed now with rc5)


using rc5 Dec 18 2010 Trunk 668 currently (i've tried other versions of rc5 and it persists) and tried rc4 again to make sure it wasn't something else, doesn't show up with rc4






0: FDisk_partition_scheme *500.1 GB disk0

1: Windows_NTFS Windows 32.2 GB disk0s1

2: Apple_HFS OSX 31.8 GB disk0s2

3: Windows_NTFS Games 62.9 GB disk0s5

4: Windows_NTFS Media 367.0 GB disk0s6

5: DOS_FAT_32 BACKUP 6.2 GB disk0s7

Share this post

Link to post
Share on other sites
Yup, i have this one too... Maybe it has something to do with a dual boot on one drive...

ntfs.c :blink:


do you know how to compile source code by chance?


does commenting out those lines in ntfs.c do anything and not even sure where that file is located in source

Share this post

Link to post
Share on other sites
Did you try running chkdsk c: /r on the drive (where c: is the Windows drive letter) ?


tried chkdsk c: /r /f and it asked to scan on next reboot so i restarted and it scanned and rebooted again to see if it was there.....still there :(


but ya RC4 it doesn't show up

Share this post

Link to post
Share on other sites

I also have the same exact issue, which only started happening with RC5.


Any info anyone has that would help fix this would be helpful. It is not fixed with a checkdisk

Share this post

Link to post
Share on other sites

For anyone interested, it has been said that a workaround for this issue is to remove the "Default Partition" and "Hide Partition" commands. After that, the message disappears. If anyone has figured this out, please let us know!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.