Jump to content
InsanelyMac Forum
cfarvin

ASUS EeePC 1001PX (Netbook) Installed! No wireless :(

Recommended Posts

Hey everyone!

 

I have a beautiful installation on an Asus EeePC 1001PX using Netbookbootmaker and a retail OSX 10.6.3 cd. I installed via usb. Only problem now is that the usb is still required to boot to OSX, and there is no wireless. Any suggestions on handling this would be GREATLY appreciated. Thank you in advance!

 

-Cam

Share this post


Link to post
Share on other sites
Advertisement
uhmm, if you read the rules.. it states you need to provide your hardware specs when asking for help...

You must have taken your grumpy pills today. No good getting stressed with new users.

 

@cfarvin for boot without your USB drive try installing Chameleon, can be found here http://www.insanelymac.com/forum/index.php?showtopic=231075

 

And could you list your wireless chipset please.

Share this post


Link to post
Share on other sites

Just run Netbookinstaller targeting your HD to make it bootable. Don't use the DSDT creation function as you will get a KP. Download the Combo for OSX 10.6.5 and use Pacifist to locate IO80211Family.Kext and replace your existing version from 10.6.3. This loads the Atheros driver needed for this machine. I have the same Netbook. By the way, the newer version of Netbookinstaller allows you to update to 10.6.5 without problems.

Share this post


Link to post
Share on other sites
Hey everyone!

 

I have a beautiful installation on an Asus EeePC 1001PX using Netbookbootmaker and a retail OSX 10.6.3 cd. I installed via usb. Only problem now is that the usb is still required to boot to OSX, and there is no wireless. Any suggestions on handling this would be GREATLY appreciated. Thank you in advance!

 

-Cam

 

Hi, i' have this netbook. How had you do this, simply installing 10.6.3 retail without mod?

 

thank you bye :)

Share this post


Link to post
Share on other sites

Hi I am about to buy this netbook for my mother (Christmas) I already have OSX 10.6 retail. I have an usb dvd drive. Does OSX work on this netbook without problems? What doesnt work? I want to use 10.6.5. Is there a howto about updating?

Share this post


Link to post
Share on other sites
Just run Netbookinstaller targeting your HD to make it bootable. Don't use the DSDT creation function as you will get a KP. Download the Combo for OSX 10.6.5 and use Pacifist to locate IO80211Family.Kext and replace your existing version from 10.6.3. This loads the Atheros driver needed for this machine. I have the same Netbook. By the way, the newer version of Netbookinstaller allows you to update to 10.6.5 without problems.

 

Hi,

 

I'm installing OS X 10.6.5 on a Asus Eee 1001px aswell theese days. The machine runs smoothly exept for Wifi and Sound.

 

The 1001PX has the Atheros AR9285 or AR2427 (google tells me both) wireless card.

 

As for the wifi, I have tried so many kexts and editing those in varoius combinations without any luck. Read from here that it might be a issue in the DSDT:

http://www.projectosx.com/forum/index.php?...c=1416&st=0

 

 

What DSDT are you on audioone? I have used Netbookinstaller aswell but no wifi.

Share this post


Link to post
Share on other sites

I'm also installing OS X 10.6.5 on an Asus 1001px. Same problem, no luck. I manage to install SL 10.6 and everything works except the audio and the WIFI Card. But, whenever I update to 10.6.1, 10.6.2, 10.6.3 or 10.6.5 the netbook hangs up when the Apple logo apperas, no spinning icon though.

 

I'll edit this post later to include the hardware specs.

 

Thanks for your time, I'll keep an eye on this post to see if this problem can be solved.

Share this post


Link to post
Share on other sites

Hi guys,

 

first I'm sorry for my english! ;)

 

I installed Snow Leopard on my Asus 1001PX and all warks except Wifi card, but I replaced it with a Dell 1390 (and it work like native airport).

I think you already solved your problems, but if not and for the next users will reading this post may be useful to know that the audio will work installing the voodooHDA_pref.kext kext.

You can found it here http://www.insanelymac.com/forum/...voodoohda_pref .

Nothing to do for Wifi...

 

I hope to be helpful.

Share this post


Link to post
Share on other sites

hi all, i have after a week of hours had issues on my 1001 pxd updated to 10.6.8 legacy kernel 10.8.0 and other kexts to make it work but i have a wifi unstable... do you have a solution for this or i must change the internal card to make working properly? another problem is the bluethoot? don't have bluethoot..otherwise all works perfect with 64 bit kernel

 

thanks in advance

Share this post


Link to post
Share on other sites

Hi,

 

 

i tried several times to install leopard or snow leopard on my 1001px. I have newest bios from asus and when instalation is starting i always see error with ACPI. Unable to alloc class and Failed to sth with ACPI.

 

What i can do?

 

I tried iDeneb 1.6 and SnowLeoDVD.iso (ofc alwais AHCI is enabled). What can i do?

Share this post


Link to post
Share on other sites
Hi,

 

 

i tried several times to install leopard or snow leopard on my 1001px. I have newest bios from asus and when instalation is starting i always see error with ACPI. Unable to alloc class and Failed to sth with ACPI.

 

What i can do?

 

I tried iDeneb 1.6 and SnowLeoDVD.iso (ofc alwais AHCI is enabled). What can i do?

Hi guys,

 

@Renard45, what's your wifi card model? I don't see it in your signsture. Can you be more accurate to describe the problem?

 

@Szymad,

 

You can use Hazard Snow Leopard 10.6.6i, during installation select only these options:

 

1. Chameleon_Bootloader

 

1.1. RC4

 

1.2. All Chameleon_options

 

2. Kernel

 

3. Drivers

 

3.1. Only GMA950_netbook

 

4. All Sata_Pata

 

5. Patches

 

5.1. DSDT Patcher

 

5.2. EvOreboot

 

5.3. FBD

 

5.4. IOATAFamily_fix

 

5.5. IOATAFamily_fix2

 

5.6. Remove_TyMCEDriver

 

5.7. UUID

 

5.8. USB_fix

 

6. Fonts

 

7. X11

 

After installation, during you're on desktop, run netbootinstaller (dowload) app (select all except "create dsdt" and "hide NBI files"). When done, restart.

Use the KextHelper b7 to install kext voodooHDA_pref for audio (download) and for lan (download)

Everything should work now, except the wifi!

 

To update to 10.6.8 download the combo update to apple website, download the legacy_kernel (download) and follow these steps:

 

1) Install combo update, but NOT RESTART!

2) Run Legacy_kernel-10.6.8.pkg and wait until finish installation. Now Restart.

3) Run all other updates from Software Update.

 

I hope I was helpful.

Maybe one day will post a more detailed guide ... ;)

Share this post


Link to post
Share on other sites

Thanks,

 

i used iAtkos s3 v2 and it works but not wifi.

 

I have TL-WN422G (TP-Link) wireless card too.

 

Is there any solution to enable wifi (i can ofc use this TP-LINK)??

Share this post


Link to post
Share on other sites

Hi guys,

 

@Renard45, for this model there's a good discussion here. You can try to ask there. :)

 

@Szymad, if your original wifi card is AR5006 there isn't any way to enable it, although there are many guides that describe how to do it. I try, but my original wifi card still not work. I replace it whit a Dell 1390, it work as native airport, but need to install an additional antenna cable to work fine (asus 1001px original wifi have a single antenna connector). I also use a USB D-Link DW125 wifi adapter and it work perfectly whit 10.6.8.

You can reach all wifi card models compatible whit mac os in the osX86 wiki. You can see here if the TL-WN422G is supported.

 

Good Luck to you both! :D

Share this post


Link to post
Share on other sites
thanks G@tsu85 just one more question do you have Q/E on your netbook 1001PX for the VGA?

 

Unfortunately the gma3150 video card isn't compatible with Q/E.

But the only one problem I have is watch video on youtube (or other website then use the flashplayer plugin) with a resolution greater of 240p.

Isn't a big problem for me, I can run Photoshop and Dreamweaver whitout problems :D .

Share this post


Link to post
Share on other sites
wireless & ethernet work fine and install with Kexts Helper 7

I try the IO kext for wifi but it not work for me on Hazard Snow Leo 10.6.8.

Share this post


Link to post
Share on other sites
wireless & ethernet work fine and install with Kexts Helper 7

 

Inside my Asus eeePC 1001px the wifi card is Atheros AR2427

and the Hardware ID is pci168c,2c.

I have OSX86 10.6.7 installed and I just modded the Info.plist inside

AirPortAtheros9388.kext, replacing pci168c,2b with pci168c,2c ,

to make it work.

 

Hope this can help someone

Share this post


Link to post
Share on other sites
Inside my Asus eeePC 1001px the wifi card is Atheros AR2427

and the Hardware ID is pci168c,2c.

I have OSX86 10.6.7 installed and I just modded the Info.plist inside

AirPortAtheros9388.kext, replacing pci168c,2b with pci168c,2c ,

to make it work.

 

Hope this can help someone

 

I'll try...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×