Jump to content
Sign in to follow this  
Followers 0
Tomica

iATKOS S3 v2 keyboard (+ trackpad) and USB mouse problem

7 posts in this topic

Recommended Posts

Hello everyone.

 

I've been searching everywhere on Google (for about 3-4 hours) to solve this problem, but i just can not find a solution to it. I am using Toshiba Satellite L650

 

Procesor: Intel Core I3-330M 2.13 GHz

RAM: 4GB (2x2GB), DDR3, 1066MHz

HDD: 500GB, 5400rpm, SATA

Screen: 40 cm, 1366x768, TruBrite

G.C.: ATI Radeon HD4500 series 512MB

 

i tried every boot flag that i found: -v, -v -f cpus=1, maxmem=2048, busratio=20 (everything together), no success.

 

Tried plugging out the USB mouse and ethernet cable (and also speakers jack etc.). Nothing helped...

 

It says: "The IOUSBFamily was unable to enumerate a device, retrying" <- something like that. Then it says IOUSBFamily failed to enumerate a device.

 

Any help would be highly appreciated. Tried only with this one (10.6.3), but i have Kalyway and iATKOS v7 on the DVD aswell.

 

EDIT: Intel Chipset: HM55

 

Any suggestions which Mac for PC should i use to make it work, or if i can "configure" this one to work for me :wacko: Thanks

Share this post


Link to post
Share on other sites
Advertisement

OK it's been a while since i last done that, got quite bored of it if i'm honest, cause it didn't work.

 

I know you guys here are awesome n stuff, that's why i'm willing to give it another go:

 

So, here's the deal. I downloaded iATKOS S3 v2, burned it on a DVD with 4x speed, restarted PC to boot from CD/DVD Player. I set Bootflags to -v busratio=20 maxmem=2048 cpus=1. Everything goes fairly well, until i get to setup menu. It all stops here, as i figure out my keyboard, USB mouse or trackpad doesnt work.

 

So, anyone has any idea how to get my USB ports or Trackpad/keyboard working?

 

Intel HM55 Chipset

Intel i3 M330 2.13 Ghz

4gb RAM

500gb HDD

ATi Mobility 5145 512mb

15.6" LED Backlight TruBrite (1366x768) TFT

Windows 7 x64

 

Posting the specs once again.

 

Any kind of help would be greatly apreciated!

Share this post


Link to post
Share on other sites

have you tried tweaking your bios settings? if you have a USB setting in your bios, try setting it to V1.1, instead of 2.0 (or 3.0).

Share this post


Link to post
Share on other sites

Blimey, my bios is very option-less, so i have very few things to be changed there. Tried disabling USB Legacy, but got the same problem, tries also some other minor tweaks, without success.

 

Thanks for your reply tho, dothacker :)

 

Shall i try and flash my bios?

Share this post


Link to post
Share on other sites

Anyway, tried flashing my bios to version 1.80, bios has been flashed successfully, tweaked the bios once again and now my mouse works.

 

Now, i'm having problems getting a partition on the Mac, shall i create an empty partition on Windows and select that as a partition for Mac, or must i do something else?

Share this post


Link to post
Share on other sites

Partition using Disk Utility in the OSX install.

 

You can partition as GUID but you not be able to re-install windows if it ever F's up (which it will).

For this reason I chose to partition as MBR (Make sure your partition is under 2Tb if using MBR).

 

Create 2 or 3 partition depending on whether you are single, dual or triple booting.

 

Format first partition as OSX Extended Journeled CASE SENSITIVE (must be case sensitive or adobe has problems installing), call is 'OS X'. (click customise which is to the left).

 

Then format your windows partition as FAT (MS-DOS) or whatever (1 from the bottom of the list, not exFAT, the one above it), call it 'Windows'.

 

Then if you want an ubuntu/linux partition, create another FAT partition and call it 'Ubuntu'.

 

Install OS X, restart, boot with Swap Disk, load kexts, install Chameleon to MBR.

 

Restart, install Windows to Windows (you'll have to click format on the Windows partition as it needs to be NTFS).

 

Install.

 

Reboot.

 

Windows will now load. Do updates,

 

Restart with Ubuntu disk, delete 'Ubuntu partition.

 

Add partition to this new 'free space' mount point / make it ext4,

add another partition to free space, mount point home, again ext4

add another partition for swap (2gb is enough) mount point swap space

 

Make sure you click to install the bootloader to /, not to the MBR or Chameleon will not pick up Ubuntu.

 

Boot into OS X using swap disk and set OS X to the active partition.

 

Boot into windows (if using GUID you will have to resync your partition table from Ubuntu, another reason to go with MBR).

 

It will throw an error, so restart with the windows disk in the drive, when you get to the first screen press Shift F10, this will launch a cmd prompt. use Diskpart to set windows as the active partition, alt tab back to the installer and click repair, it'll give you a restart prompt DO NOT PRESS THIS, instead, alt tab back to the Diskpart cmd prompt and set OS X to the active drive, then exit diskpart, exit cmd. Then click restart.

 

Your PC will now boot Chameleon and can boot into all 3.

 

I hope this helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×