Jump to content

Hellp! Acer 7730g WIreless Broadcom 4311


Dahito
 Share

13 posts in this topic

Recommended Posts

hey guys i rly need help,

 

I got this Laptop (Acer Aspire 7730g) and i installed Os x 10.6.4 by Hazard everything works fine even cam.

Only my mini Pci Internal wireless adapter and ethernet are not working OOB or with modified kext so i changed my

Intel wifi 5100 to the Broadcom 4311 wich is supported to work nativly by Os X but it is not shown at the preferences or the airport untility, ok so far so good. i tried any kind of kext like bcm enabler.sh io80211 from 10.4 or 1.5 or a special fix but nothing works, :mellow: but now i saw when im booting to windows my broadcom card turns on by LED is lighting up and if im restarting the computer my cards stays on and i boot to os x but then, the boot screen frezzes even by -v , -f or -x so now, when im shutdown my notebook for restart, the LED's are of and i can now boot Os X normaly.

 

So im thinking the card cant be turned on by os x do anybody had same or similar problem pls tell me i really need this card

 

Thanks Best regards

sry for my bad english ^^

Link to comment
Share on other sites

 

Hey Dellmantt, thx for the tip dude,

but its still not shown up as airport but now i got it working that the LED is turned on in OSx and i load any kext that is needed to enable the card with kextload but still no luck, Dude I even tryed the F***ING Tape method but even this didnt work for me i think its the mini pci express i got 2 of pci the second one is actually for bluetooth but when i put the card in it, it goes really HOT so i leave the 2. bank of the pci.

 

Maybe can some one put a download link for me i need the dpci manager to see if the card shown there or anybody has a solution thx

 

OMG PPL HOW THE F*** IS THAT {censored} PASSIBLE ANY KIND OF PPL CAN GET IT TO WORK BUT ONLY ME !!!!!!

 

IM REALLY PISSED OFF GUYS PLEASE HELP ME :D

 

but thx anyway

 

 

My Spec :

Notebook: Acer Aspire 7730g (bios 3636)

OS: IATKOS S3 V2

CPU: Core2Duo t-5800(works fine with voodo p step)

Lan: Broadcom BCM netxtreme gigabit ethernet (NOT WORKING no kext available)

W.lan: Broadcom BCM 94311 rev:0D (NOT WORKING need HELP!)

Graphik: Geforce 9600M GS 512MB (works with NVenabler64)

Audio: Realtek hd audio (works with voodoHDA delete apple HDA)

USB: (works fine)

Cam: Acer crystal eye (works fine with photobooth)

DVD: (Works fine)

AHCI: (no problems)

Link to comment
Share on other sites

Give an untouched kext a shot.

From my system 10.6.4

 

http://www.enterupload.com/dxk8zasuz3c8/IO...y.kext.zip.html

 

Back up your original kext.

 

sudo cp -R /System/Library/Extensions/IO80211Family.kext ~/Documents/

 

Make sure you set the permissions back to root:wheel once you unzip it.

 

sudo chown -R root:wheel IO80211Family.kext

 

Then move it into place

sudo mv IO80211Family.kext /System/Library/Extensions

 

Clear your caches.

 

cd /System/Library/Caches/

sudo rm -rf com.apple.kext.caches/

They will be rebuild on next boot.

Link to comment
Share on other sites

Give an untouched kext a shot.

From my system 10.6.4

 

http://www.enterupload.com/dxk8zasuz3c8/IO...y.kext.zip.html

 

Back up your original kext.

 

sudo cp -R /System/Library/Extensions/IO80211Family.kext ~/Documents/

 

Make sure you set the permissions back to root:wheel once you unzip it.

 

sudo chown -R root:wheel IO80211Family.kext

 

Then move it into place

sudo mv IO80211Family.kext /System/Library/Extensions

 

Clear your caches.

 

cd /System/Library/Caches/

sudo rm -rf com.apple.kext.caches/

They will be rebuild on next boot.

hey thx tryed it but not helped for me.

Oh that kext was empty is that ok ????

 

and yes the card works physicaly and is ok but os x dont see any pci card

Hardware info can see my card ...

Link to comment
Share on other sites

Anyway, before I have a BCM4311, it works OOB, but lately I have upgraded to an Atheros AR9280 based card, it's more compatible and works with a/b/g/n... and identified as an airport extreme on system profiler... :construction:

Nice for U :construction:

can u tell me more cards wich are supported maybe ill buy a new one ^^

 

OH ya i forgot somthing

couse my ethernet is not working too

it always shows somthing like ("applebcm5071: start 0 0 mapping device failed")

it would be awsome if my ethernet will work :construction:

Link to comment
Share on other sites

hey guys i put the applebcm4311.kext into my extras folder after kextutility and restart the kext says at boot

 

-kext com.apple.driver.airportBrcm43xx - Libraray kext com.apple.iokit.io80211Family not found

-Can't Load kext com.apple.driver.AirportBrcm43xx - Failed to resolve library dependencies

-Kext com.apple.drivers.AirportBrcm43xx failed to load (0xdc00800e)

-Failed to load kext com.apple.driver.AirportBrcm43xx (error 0xdc00800e)

-Not loading kext com.apple.driver.airportBrcm43xx- not found and kext not available in early boot.

 

"What does that mean????"

 

And can sombody tell how to use dsdt to make my pci-e seen in the systemprofiler PLs guys help me i think my problem is just chosmetick nithing else ....

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...