Jump to content

[GUIDE] How to install Snow Leo on ASUS Z8NA-D6

185 posts in this topic

Recommended Posts

first of all here is a log of the sleep events




as you can see I´ve set the system at 20:29 to sleep and woke it at 4:07 without any issues

and did it once more after that


here are the almost complete bios settings. most of them don´t affect sleep functionality. because I rebootet my system a thousand times with this work I can´t really say which one made it work - maybe we figure it out together - I don´t have more time to spend for that



CPU Configuration

C1E Support= Enabled
Hardware Prefetcher=Enabled
Adjacent Cache Line Prefetch=Enabled
MPS and ACPI MADT ordering=Modern Ordering
Max CPUID Value Limit=Disabled
Intel ® Virtualization Tech=Enabled
CPU TM Function=Enabled
Execute Disable Bit Capability=Enabled
Intel ® HT Technology= Enabled
Active Processors=All
L1 IP Prefetcher=Enabled
L1 Data Prefetcher=Enabled
Intel ® TurboMode tech=Enabled
Intel ® C-State Tech=Enabled
C3 State=ACPI3
C State package limit setting=C6
C1 Auto Demotion=Disabled
C3 Auto Demotion=Enabled
ACPI T State=Enabled

Chipset Configuration

CPU Bridge Configuration

           CSI Links Speed=Full-Speed
           CSI Frequency=Auto
           CSI Isochronus=Disabled
           CSI L1=Enabled
           Memory Frequency=Auto
           Memory Mode=Independent
           Memory ECC Function=Enabled
           Double Rate Refresh=Auto
           Demand Scrubbing=Enabled
           Patrol Scrubbing=Disabled
           NUMA Aware=Auto
           Page Policy=Open
           Adaptive Page=Disabled
           Channel Interleaving=6:1
           Rank Interleaving=4:1
           Memory Thermal Throttling=Disabled
           DDR3 Voltage Level=Auto
           DRAM DLL OFF=Enabled

North Bridge Configuration

           Crystal Beach / DMA=Enabled
           Crystal Beach / DCA=Enabled

South Bridge Configuration

           USB Functions=5 USB Ports
           USB Port Configure=6+6 Ports
           HDA Controller=Disabled
           SLP_S4# Min. Assertion Width= 2 to 3 seconds

Intel VT-d Configuration

Intel Vt-d=Disabled

Legacy Device Configuration

Onboard Floppy Controller=Disabled
Serial Port1 Address=Disabled
Serial Port2 Address=Disabled

USB Configuration

Legacy USB Support=Enabled
USB 2.0 Controller Mode=HiSpeed
Bios EHCI Hand-Off=Enabled

Advanced PCI/PnP Settings

Plug and Play OS=Yes
PCI Option ROM Scan Order= Bus 0 First
Onboard LAN1 Chip=Enabled
Onboard LAN2 Chip=Enabled
Onboard LAN1 Boot=Disabled
Onboard LAN2 Boot=Disabled

Power On Configuration

Restore on AC POwer Loss= Last State
Resume ON PCIE Wake#=Disabled
Resume On Ring=Disabled
Resume On RTC Alarm=Disabled

I/O Virtualization

SR-IOV Supported=Disabled

PCI Express Configuration

Active State Power Managment=Disabled

ACPI Configuration

ACPI 2.0 Support =Enabled
ACPI APIC support=Enabled
BIOS-->AML ACPI table=Enabled
Headless mode=Disabled

Chipset ACPI Configuration

USB Device Wakeup From S3/S4=Enabled
High Performance Event Timer=Enabled
HPET Memory Address=FED00000h

General WHEA Configuration

WHEA Support=Disabled


in the attached rtf file I highlighted the settings in red that could affect IMO sleep functionality

the green ones could be involved - but unlikely






one more thing


the last weeks I received a lot of PM´s asking for help. you guys here know that I´m willin to help.


but here the last time in clear words


no support for any other install methods! no more "I installed my machine with tonymac or blablablaa method" and it doesn´t work! please got to tonymac or xyz forum and ask for help there.


and guess what........ there are some reasons I prefered this method :blink:


anyone sending me PM´s with questions like this will be blocked immediately in the future

Link to comment
Share on other sites

Thanks Peach-os


Success !! (kind-of)


So I changed all my bios setting to match yours and tried again. I again chose sleep from the menu and got the same results as before. Then next time i tried setting the sleep to time out after a minute and it worked!


The fans stayed on and the computer woke up very quickly after I touched the mouse. It seems to computer moves into a very light sleep. I guess by selecting sleep from the menu it's being told to go into deeper state of sleep which there are still problems with. I wonder in this light sleep if the computer is consuming any less power than just being on. It almost seems as though the screen is going to sleep and not much else.


Anyways thanks once again Peach.


BTW if you select sleep from the menu does it work for you?

Link to comment
Share on other sites

yes - similar result here, except that it sleeps also from the menu. how are your settings in energy saver pref?


I switched back to AnV Bootloader which is creating P-States and C-States as well - but we won´t it need anyway.


right now I´m figuring out the right settings and extensions to have proper speedstep available. one point is already clear at the moment:


without GenerateP-States and GenerateC-States and native SSDT tables this mobo 7 p-states in array instead of 6 and is performing better ! also native speedstep is working with the provided bios and settings.


I will post the whole story later tonite

Link to comment
Share on other sites

as i mentioned before, i switched to AnV bootloader which works IMHO better for this setup.


using the provided bios settings, switched generation of p- and c-states off and set drop ssdt to no, the system has native throttling as you can see in MSR-Tools




here the system works only with one cpu on 1.60 ghz




after I started geekbench the system started working on 2.4 ghz and added the second core.

it looks like turbo mode is working also :)


for measuring the temps, fans and other HW sensors you could use the new fakesmc with new released plugins.

according to the topic here http://www.projectosx.com/forum/index.php?showforum=165

fakesmc and plugins should work in Extra, but unfortunately IntelCpuMonitor seems to work only from S/L/E on the Z8NA - therefore I would suggest to install all extensions in S/L/E.


a big shout and all the credits to the members of HW Sensors project !




here you can see cpu, hd, gpu, northbridge temps reprted properly in iStat. only the heatsink temp looks a little bit weird on my machine. you will find all needed files except iStat in the attached package including an SuperIOFamily.kext which is already adapted for this mobo incl. 6 possible fans. for the gpu diode you should install the correct extension for your setup - ati or nvidia.


please report your results - especially heatsink temps!




msr tools is a little bit outdated, bit I´ve found a version that works in Snow Leo - but only in 32 bit kernel mode !

if you install the attached boot plist file, all needed settings are done.

you´ll need a little bit patience after starting MSR - it takes a while to install and to initialize.


have fun :(

Link to comment
Share on other sites

Cool, looks like you've had some free time.

As for my energy saver prefs, I think I had all 4 options checked on ( I am not at the computer at the moment but I remember my panel had all 4 check boxes, each one checked off)


Everything is actualy working pretty good fir my needs, as I generally turn the machines on, crank'em on a render and then shut em off. So having them speedstep, and throttle down isn't to nessicary. But if it may increase speed.......


What kinda geekbench scores are you getting? And what is your model id 3,1 or 4,1? I remember before having 4,1 gave me much lower geek bench scores. So I set it to 3,1 and it jumped to around 12,800. I was thinking it had something to do with speedsteping at the time, but wast really sure.



Thanks again for keeping this the be all end all z8na-d6 thread, I am sure I am not the only beneficiary

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...

Now after a year my experiences so far:


the built is up to date and still absolutely reliable. it´s working almost as a real mac pro except two things:


1.sleep is working a kind of

2.the geekbenches are a little bit better than comparing real mac´s :rolleyes:



Ashmodai I will check your dsdt the next days and post my results

Link to comment
Share on other sites

  • 2 weeks later...
hmmm.......no problems at all here with 10.6.7. did it even online without any issues.

you have a maintainance install?


In fact I still had my original leo install on a separate disk so I was able to restart the server on leo ...

I am really getting frustrated ... why does it seem to be so difficult ... grrrrrrr .... After upgrade, it is not even crashing during boot, just hang for ever ...


Peach-OS, could I ask you for the dsdt you use currently ...


Thanks ...

Link to comment
Share on other sites

  • 3 months later...

I've been away from this thread for quite some time due to stepping away from the osx86 stuff for a while. I see some issues that are still unresolved so I decided to update this great guide with some new things for those who have been having trouble due to your cpu…


NOTE: This is still a vanilla guide. The only reason we have to use the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] method is because the westmere cpu's aren't supported until 10.6.4. Everything you actually install though is as vanilla as the original guide.


First things first, credit still goes out to peach for the original guide because, well, without it, I'd probably have never been here in the first place.


What you need

-- peaches' attached zip file in the first thread. You don't need the dsdt unless you're using the same cpu as peach.

-- chameleon 2 rc5 r1083 from here: http://www.insanelymac.com/forum/index.php?showtopic=227833

-- tonymacx86s' [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] iso image. Can download it from here: http://www.tonymacx86.com/downloads

-- a blank cd or dvd

-- SL 10.6.3 retail dvd



-- If you've already made the bios changes from peach's guide then undo them. Only changes you need to make are:

---- set sata mode to AHCI

---- set Plug and Play OS to yes


-- If you have more than a combined total of 4GB RAM installed, remove the extra RAM so you only have 4GB. On my system I left 1 2GB stick for each cpu.


-- Burn the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] image to disk



-- Boot the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] DVD. When you get the the boot selection screen, eject the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] disk and insert your SL retail disk. Wait 5-10 seconds then press the Tab key to bring up the text based menu. Then press F5. Your SL retail disk would now show up in the disk selection list. Scroll down and select it. Type -v then hit enter. (note: you may or may not need to use other boot flags, but on my end, -v got me where I needed to go.)


-- If all goes well, the installer should load after a few minutes.


-- Once inside the installer, prepare your SL disk via Disk Utility.


-- Back on the installer, click customize and uncheck printers, languages and fonts leaving only base system and X11 checked. Then install SL.


-- Once the installation completes, go ahead and reboot. Remove the SL disk and reboot to the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] disk. Once you get to the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] boot screen, press the tab key again, then select your newly installed SL system from the list, type -v and hit enter. (note: again, I only needed -v but you may or may not need other boot flags). If all goes well, SL will boot up, you'll get the annoying minute long welcome in many languages video then set up your account etc etc.


Post Installation

-- Once you have booted into your system for the first time, created your account and whatnot… First thing to do is install chameleon. The version listed at the top of this guide is the one I used, and it works great, therefore it's the one I recommend. Do not reboot after installing chameleon.


-- Once chameleon is installed, use a kext utility (like kext helper) to install the IONetworkingFamily.kext. Make any modifications as necessary following the steps laid out in peach's original guide… except that on my system, I modified the next first, then installed it using next helper.


-- If you did this correctly, your networking should become active without needing to reboot. If not then just reboot to the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] disk, press the Tab key, select your SL install, type -v (and any other flags you need) and hit enter. You shouldn't have any problems booting back into SL. We don't use chameleon here yet because we haven't updated from 10.6.3 so all you'd get is a black screen.


-- Ok, so once back in SL if you had to reboot, download SL 10.6.8 combo update and install.


-- You may need to install the IONetworkingFamily.kext again if your ethernet goes down. Also, copy the Extra folder from peach's guide to your SL disk. Make any changes needed to your com.apple.Boot.plist.


-- Once that's done, remove the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd and reboot your system using chameleon. If all went well you should be back in SL 10.6.8 without issue.


I think that's it.. if I missed anything, let me know. Or if you run into any issues along the way, post back here with specifics.


Personally, I didn't do much once I got SL installed updated and booting properly on my system as I only did so in order to install Lion. For that, I followed this great guide - http://www.insanelymac.com/forum/index.php?showtopic=256729


If you do install Lion, make sure to install the IONetworkingFamily.kext again. Everything else is covered in the guide linked previously.

Link to comment
Share on other sites



As far as I can tell, sleep is working properly in Lion. I'm not guaranteeing it works... but when I go to the apple menu > sleep, it appears to go to sleep, and appears to resume properly as well.


I've attached my dsdt for reference, but please note that I did none of the patching myself. MaLd0n patched it for mere here: http://www.insanelymac.com/forum/index.php...d=1720117


Link to comment
Share on other sites

  • 2 weeks later...

just tested Maldon´s edit and it does pretty the same as my dsdt version - but it seems to boot a little bit faster and I have a few more pounts in Geekbench. I created a diff just to understand what he did. did you give him a native dsdt from Lion or one of my edits?


and yes it´s going to sleep S0 as my last edit did - you could find it in the logs


by the way......did you ever receive the stick?

Link to comment
Share on other sites

  • 2 months later...

Yep, received the stick many moons ago.. thanks again for that :unsure:


Sorry for the delayed response.. I've been quite swamped with work for the longest time..


The dsdt I supplied was the native one extracted from my system. I never tried using your dsdt since our cpu's are different. One thing I did notice though is even after my dsdt was patched, my machine still ran hotter than I would've liked.. and graphics weren't all that great on my 560 Ti (after I managed to get full 3d support) so I eventually dropped it for a while.


Anywho.. I'm considering giving this another run since I had to enroll in the developer program and well, it doesn't do me any good if I don't have a mac/hackamac to work with it on hehe. I'm waiting to see how things perform in a virtual machine first.. but so far, not very well.. so it' likely I'll be up all night working on this and setting stuff up again hehe.


I'll keep you posted with anything new I find out, if any.

Link to comment
Share on other sites

cool.....my machine is working pretty good, especially since I added a SSD for the OS. next step will be a Highpoint 620 SATA 3 controller to squeeze the rest out of the SSD.


you don't use dsdt in general or just a basic patched one? If you'd extract your native dsdt, just use diffmerge to compare and compare window in DSDTSE to copy the patches - except the cpu section of course.


or sent me your fresh dsdt - I need some practice :unsure:

Link to comment
Share on other sites

Well, I was using the dsdt that MaLd0n patched for me*.. the original I extracted from my system was linked earlier but it seems the thread has been removed. Once I get all preparations for the move made, I'll extract a new one and post it back here.


*There was a thread a while back, I think for a dsdt auto patcher he made, but my configuration wasn't listed so he patched it manually. Knowing nothing about dsdt myself, I just used the one he patched and left it at that ^^

Link to comment
Share on other sites

are you sure that this dsdt is an unpatched one? it has already some patches - even "Apple" in the headline :rolleyes:

anyway I compared the patched dsdt with mine - only difference I see is that I renamed the devices. therefore you could use mine (cpu section looks the same) or still stick with the patched one you have.

If you have the time to create a new "virgin" dsdt I will patch it for you again. take care that you boot with disabler kext without any dsdt loaded.

Link to comment
Share on other sites

Maybe it's not hehe.. I dunno. I used "DSDT Editor" with option "extract dsdt from bios". I'm assuming then that it read my dsdt from the Lion root instead of actually extracting it ><


I'll boot up SL with no dsdt tomorrow and see what I come up with then. My apologies ^^

Link to comment
Share on other sites


  • Create New...