Jump to content
peach-os

[GUIDE] How to install Snow Leo on ASUS Z8NA-D6

183 posts in this topic

Recommended Posts

here is a pretty is simple guide to install Snow Leo on ASUS Z8NA-D6.

 

I try to keep it as short and simple as possible - therefore please no questions like could I use this or that instead

99% the answer would be I don´t know - I´m no hardware dealer who would be able to test different configs :)

 

please follow the guide as it is - no support for other methods !!!

 

also I would go with an nvidia card - they are much easier to install ( in my case it´s a 9800gt / 512mb)

I can´t give any support for ati cards, you will find a solution yourself in the forum.

 

This is what you need

 

1. a kalyway 10.5.2 distro (exactly this one - please don´t ask for other distros - they won´t work)

2. an official Snow Leo DVD ( I won´t give any support for a distro as main install)

3. two harddrives ( I still prefer the WD AAKS series) .- we name them HD 1 (main install) HD 2 (maintenance)

4. Tinker Tool from here

5. chameleon 2 RC1 431.mpkg and Cameleon RC3 658

 

 

Let´s go

 

 

A. Bios Settings - credits for this to MightyLedZepp

 

1. on the main menu, select IDE configuration. Configure SATA as AHCI.

2. on the advanced menu, select CPU configuration. Disable HT Technology, disable Intel C-State technology,

and set Active Processor Cores to 1.

3. on the advanced menu, select PCIPnP configuration. Set Plug and Play OS to Yes.

4. on the boot menu, select boot device priority and make sure the DVD drive is set to the first boot device.

 

 

B. Install Kalyway

 

1. now boot into kalyway

2. format HD2 with GUID (maybe a small partition with 10GB for the kalyway maintenance install and the rest for data)

3. customize the install > uncheck everything except kernel > choose sleepkernel

4. install the kaly to HD 2

5. reboot without the DVD, hit F8 and set CPUS=1 -v as boot options

6. install Chameleon 431.mpkg

7. now go to root and delete the "boot" file

8. copy the "boot" file from *chameleonRC3>i386 to root.

9. reboot to kaly with options CPUS=1 -v

 

C. Install Snow Leo

 

1.boot into HD 2 with options -v cpus=1

2.finish setup and copy Tinker Tool to desktop (you might need a second smaller USB drive)

3.format the HD1 you will use for SL with GUID

4.start Tinkertool, check show hidden files and apply.

5. now boot the SL DVD

6. in SL DVD go to System>installation>packages

7. start osinstall.mpkg and choose HD 1 to Install SL. uncheck the printer drivers, otherwise installation will fail.

8. install should be done in 30 minutes - don´t reboot

9. install chameleon 431.mpkg to the new SL drive.

10. when done go to SL root and delete the "boot" file

11. copy the "boot" file from *chameleonRC3>i386 to SL root.

12. copy the working dsdt.aml to SL/ Extra

12. replace the kexts in SL/Extra/Extensions with the attached files

13. replace the com.apple.boot.plist in Extra with attached file (edit the serial in case - now its set to 012345...)

14. it won´t be possible to repair disk permission in SL, without the last step:

go to the SL DVD again and reinstall the BSD.pkg (also in System>installation) from the DVD.

15. now reboot

 

 

D. Starting the first time Snow Leo

 

1. enable CPU Settings - credits for this to MightyLedZepp

when the system restarts, enter the BIOS menu. Its now safe to enable the features that were previously disabled: HT, C-State, and all cores.

Change the boot order if needed, and reboot to HD1.

2. when the Chameleon bootloader comes up boot only with option -v (in case it doesn´t boot) .

3. install the attached IONetworkingFamily.kext to S/L/E with kextutility

4. reboot

3. now you should have a workin Snow Leo :)

 

 

E. updates

 

using the attached dsdt.aml and fakesmc (dsmos.kext = kp) there won´t be any problems with any updates.

to make your system safe in any case, install first Snow Leo also to HD2 and replace the kaly 10.5.2 install

using the same procedure, or copy the HD1 install with Carbon Copy (as long it´s small enough)

from within this "maintenace install" you could easily repair any problems and redo any updates in case it didn´t work

the regular way.

important: this works only from an other Snow Leo install !

 

 

 

 

working

 

1. restart

2. graphics with GraphicsEnabler=yes for Nvidia cards (already set in the attached com.apple.boot.plist) QE/CI all working

3. shutdown works if you use disabler.kext instead of dsdt

5. USB

5. firewire (with an extra pcie firewire TI instruments)

4. ethernet - if it doesn´t work with the attached IONetworkingFamily.kext - this is the solution (credits to MightyLedZepp):

 

go to /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/Intel82574L.kext/Contents/Info.plist and edit the following lines:

 

<key>IOClass</key>

<string>Intel82574L</string>

<key>IOPCIPrimaryMatch</key>

 

1. change <key>IOPCIPrimaryMatch</key> to <key>IOPCIMatch</key>.

2. add your Ethernet Controller's uid to the list in the line right after the <key>IOPCIMatch</key> line.

usually the id is 0x10D38086 - the simple way to find out is to use Windows Device Manager.

3. remove the line that says <key>IOPCISecondaryMatch</key>, and also remove the line immediately below that.

 

once complete, open terminal and type

sudo -s > enter

enter passwort > enter

rm -rf /System/Library/Extensions/Caches > enter

rm -rf /System/Library/Extensions.mkext > enter

 

 

not working / in progress

 

1. shutdown with dsdt (works sometimes)

2. sleep

 

 

at the moment I´m still trying to get sleep/shutdown to work editing the dsdt.

the included dsdt has many optimizations following a lot of instructions by Masterchief .

everybody is welcome to help with the dsdt - still to do:

1.p-states for the nehalems (in my case the E5520)

2.sleep

3.shutdown

 

enjoy !

 

AsusZ8NA_D6.zip

 

EDIT: shutdown fixed with DSDT - use the attached DSDT file and Asere´s Bootloader - you need still only fakesmc and IOstorageinjector in Extra

 

p-states working with chameleon RC5 newest versions

 

 

UPDATED Version workin with 10.6.8 / bios 902 - working sleep S0

 

dsdt.aml.zip

Share this post


Link to post
Share on other sites
Advertisement

shutdown fixed and only two kexts remain in Extra ! - read in the first post

 

now only sleep is still to fix :(

Share this post


Link to post
Share on other sites
it work on asus t6600 too?

 

of course .....also on your asus vacuum cleaner, the asus microwave .....almost everything from asus :(

Share this post


Link to post
Share on other sites

Thanx for the guide. Will build my system on weekend.

 

Have couple of questions.

 

1. Do both GLAN ports work after patching Info.plist?

2. Does your dsdt work good with Cham2rc2 too? I have working SL now and doent want to reinstall it.

 

Thx in advance

Share this post


Link to post
Share on other sites

1. both GLan working

 

2. I didn´t test this chameleon version and I can´t see the sense in doing that - the newer versions have so many improvements. I never would handle a hackintosh system where you can´t handle even a not working boot file.

don´t you have an other os x install where you can boot from in case?

Share this post


Link to post
Share on other sites

Nope, ive got bootable flashdrive w SL. But hope will not have problems with migration =)

Did you make proccessor section in your dsdt?

Share this post


Link to post
Share on other sites
Nope, ive got bootable flashdrive w SL. But hope will not have problems with migration =)

Did you make proccessor section in your dsdt?

 

I didn´t try this chameleon version - hence don´t know.

 

if you mean the p-states in dsdt - this and sleep is still the only things to work on

 

I wrote here about it http://www.insanelymac.com/forum/index.php...p;#entry1472426

and didn´t get any responses from the dsdt gurus - maybe I posted it in the wrong section ;)

Share this post


Link to post
Share on other sites

Ok, i have X5570 and will try to migrate with your dsdt then and post here.

Thanx for your answers.

Share this post


Link to post
Share on other sites

Hi Peach-os

 

Sorry if this is a stupid question. You wrote chameleon RC2 431.mpkg, do you mean Chameleon-2.0RC1-r431 ? and then use use the boot file from Chameleon RC3 658 ?

 

So far i've installed kalyway which was easy enough, but when chameleon has finished installing and i change the boot file I cannot get chameleon to boot, i just writes some rows of numbers and stops. Any idea what i could be?

 

Thanx

Share this post


Link to post
Share on other sites

yes, you´re right - chameleon 2 RC1

 

yes - RC3 658

 

post a picture of the screen where the bootloader stops - can´t say anything with that info.

 

otherwise you could skip this point and leave kalyway install as it is and install also SL over it as soon

SL is workin on the main install - or go straight ahead with asere bootloader

Share this post


Link to post
Share on other sites

Hi again

 

I got past the problem, for some reason the chameleon 2 installer didn't work properly, so I installalled chameleon 2 manually and changed the bootfile with the one from chameleon 3.

 

Now I'll try to follow the rest of you guide

 

thanx

Share this post


Link to post
Share on other sites

Ok, this really isn't my day ;)

 

I simply cannot get this machine to boot into snow leopard.

 

So far I've done the Bios setup, installed kaly 10.5.2 to HD2, installed chameleon 2 to HD2, changed the bootfile to the one from chameleon 3. Installed snow leopard to HD1 installed chameleon to HD1 the same way as I did to HD2. Applied your dsdt.aml, com.apple.Boot.plist and smbios.plist to extra folder on HD1, applied fakesmc.kext and IOAHCIBlockStorageInjector.kext to extra/extensions

 

I've then changed the boot order and the other bios tweeks back and tried booting HD1 (snowleopard) with -v, but no luck it always stops the same place and reboots the machine.

 

the last line says: Starting Darwin x86_64

 

the build:

 

kalyway 10.5.2 for intel and amd

snow leopard 10.6.0

 

Asus Z8D6-NA

2xE5620 Xeon cpus (2.4Ghz)

16 GB Ram

 

Thanx

Share this post


Link to post
Share on other sites

could you post a pic of the bootscreen when it stops?

 

check your bios settings again and try it with less RAM.

Share this post


Link to post
Share on other sites

Hi again

 

I tried with 8 GB's of RAM on stick of 4GB per CPU

 

Same thing happened it reboots at: Starting Darwin x86_64

 

It goes very fast so i had to record a video on my iphone to get everything.

 

I have also tried with the same BIOS settings as the kalyway HD + cpus=1 but the same thing happens.

 

Would you mind taking a picture of Advanced/CPU Configuration in BIOS so I can compare it to yours?

 

Thanks again

image.tiff

post-185928-1275814667_thumb.jpg

post-185928-1275814724_thumb.jpg

Share this post


Link to post
Share on other sites

try to boot without the dsdt and disabler.kext in Extra

 

I will compare the bios settings - did you set Plug and Play OS to yes?

Share this post


Link to post
Share on other sites

Thank for your reply

 

I Will try that tomorrow. Any special version of disabler kext?

I'm beginning to think that my cpu's maybe aren't compatible ...

 

Thanx

Share this post


Link to post
Share on other sites

Ok - I compared the settings. It seems you have a different bios version than I do. mine is the latest 0902. In my bios there are no "data reuse optimization" and no "Performance/Watt" settings.

Also I have only the cpu cores settings 1, 2 or all - but not 4 (mine is set to all)

 

are you sure you have the same Mainboard?

Share this post


Link to post
Share on other sites

I too have the latest bios, so that it support my cpu's (e5620). I guess snowleopard doesn't support them yet... Bad luck... And the new westmere didn't come out today as i hoped for, guess i'll either have to wait or get some new ones that are supported by snowleopard. My stupidity is going to cost me this time i guess:-( unless someone know of a way to trick snowleopard into using westmere chips.

 

Thanx for your help anyway

Share this post


Link to post
Share on other sites

ok.....so it looks like that the additional settings are appearing if using a westmere cpu.

I wouldn´t give up yet - someone hast to be the first one doing it :thumbsup_anim:

 

when installing snow leo - did you set cpu cores to one cpu? try to change or to disable the additional settings.

Share this post


Link to post
Share on other sites

yes i had the cpus=1 otherwise it cannot boot into the kalyinstall

 

I'm now trying to install with only one cpu, I don't know why it should work but i'll try anyway;-)

Share this post


Link to post
Share on other sites

STOP ! I didn´t mean with option cpus=1 or one cpu installed!

 

I meant the BIOS Setting for active cores how it´s described in my guide: set it to one core !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×