Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Network HDD - Mac OS X 10.6

5 posts in this topic

Recommended Posts


I'm new to Mac and am having a problem with my Network HDD (NAS):

- at first, it worked, I could mount it and could see the files, however I could not write to it and I could only open a file on it if I opened it through a program (so the double-click doesn't work)

- a friend told me to format it to HSF+ and it would still be visible for my windows computer too, so I did that and now the network functions no longer work


Anybody knows what to do?

if you need more info, please let me know.


I run Mac OS X Snow Leopard, connected to the network through wifi, the NAS is connected to the network by cable, I can access the HDD on my mac if I plug it in via usb cable


I really need my HDD to work through the network again asap...

Thanks so much for any help!

Share this post

Link to post
Share on other sites

I'm a little confused here. You say you formatted the NAS drive as HFS+ ? Which NAS is this? Unless it is from Apple, most of the small consumer NAS enclosures run on one or other variant of Linux/Unix, and drives in them are normally formatted in one of the Unix formats (ext2, ext3, ext4, reiserfs, xfs, ufs, etc). Exactly which format is dependent on the box firmware (my Buffalo used xfs, the D-Link I use currently at home uses ext2 as default, the homemade box running FreeNAS uses ufs as default). Unix does not do well with HFS+, if it can even read it to begin with.


The NAS if it is set up correctly makes that part totally transparent, allowing the information to be read and/or written over the network via one of the protocols that all of the operating systems can handle - often Samba (smb) is easiest on a mixed Windows/Mac/Linux network.


I use my NAS to allow my media files and photographs to be universally available (even to XBMC running on an elderly modded X-Box).


You should let the NAS box format the drive(s) inside it in whichever format it uses. Be very careful if you do otherwise! Some of the boxes have only a bootloader on the hardware and part of their operating system on one of the drives (e.g. Buffalo Linkstation). If you take drives out of these and format them on a different machine, it can wreck the NAS box in such a way that it is extremely hard (virtually impossible) to repair

Share this post

Link to post
Share on other sites

Thank you for your answer.


It's a NAS from Freecom: Freecom Network Drive 1TB: http://www.freecom.nl/ecproduct_detail.asp...ssCatID=1146168 (Dutch).

It has (or had?) Samba running on it.


So I can assume the drive is wrecked now... How can I fix it? Can I re-install Samba and get it back to work that way?

Or can I plug it in an airport with USB and get it to work on the network again that way?

Both Mac and Windows machines must be able to access it. I have MacDrive installed on the Windows machines.


Share this post

Link to post
Share on other sites
nvm this problem...

I took the liberty of using a hammer to solve the problem :dev:

I'm now running two 500gb LaCie network drives and they work like a charm! :)


just a FYI, most of the time you have no control of what filesystem NAS supports, its up to NAS manufacturer. For cheapo-nas devices, its ext2/ext3 most of the time and you see it over SMB layer.

Any issues you might have encountered is probably due to either problem with the NAS hardware or network issues. Thats the price of file abstraction -- problems could arise on many layers

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.