Jump to content
InsanelyMac Forum
rassha

Lenovo G550

Recommended Posts

Hallo to all, Anyone sucessfully installed Mac OSX on this notebook?

Lenovo G550

 

  • Lenovo G550 Model: Lenovo 20023
  • Intel Core2Duo T6500@2.1ghz CentrinoDuo
  • Chipset Legend PM45 ICH9 Nvidia Geforce G105M (NV98M)
  • Network wired: broadcom netlink gigabit ethernet adapter (ven_14E4/dev_1693)
  • Network wireless: Intel WiFi Link 5100 AGN
  • Audio: Legend HD Audio Controller Conexant High Definition (ven_14F1/dev_5051)

detailed specs: http://www.newtechnology.co.in/lenovo-idea...top-pricespecs/

 

I tried several times with iAtkos v7 but without success. Anyone have tips which component to select during installl?

 

 

lenovoideapadg550.jpg

Share this post


Link to post
Share on other sites
Advertisement

I installed 10.5.5 using a msiwindosx.iso file I found online. I used the combined update to patch it to 10.5.8 after installing a few kext files. I am just having trouble with the intel gmax4500 video card as I can't get it to run at the native resolution without losing the cursor.

Share this post


Link to post
Share on other sites

Rassha,

Any luck on getting it to work? I'm considering buying this myself.

Vinod

 

 

Hallo to all, Anyone sucessfully installed Mac OSX on this notebook?

Lenovo G550

 

  • Lenovo G550 Model: Lenovo 20023
  • Intel Core2Duo T6500@2.1ghz CentrinoDuo
  • Chipset Legend PM45 ICH9 Nvidia Geforce G105M (NV98M)
  • Network wired: broadcom netlink gigabit ethernet adapter (ven_14E4/dev_1693)
  • Network wireless: Intel WiFi Link 5100 AGN
  • Audio: Legend HD Audio Controller Conexant High Definition (ven_14F1/dev_5051)

detailed specs: http://www.newtechnology.co.in/lenovo-idea...top-pricespecs/

 

I tried several times with iAtkos v7 but without success. Anyone have tips which component to select during installl?

 

 

lenovoideapadg550.jpg

Share this post


Link to post
Share on other sites

YEs %100 work snow leopard dvd 300$ donate now

I wait

 

Need

5100AGN wifi driver

Broadcom Netlink Driver

Broadcom bluetooth

Sound card

VGA is Greade Work Geforce G 105M (NVIDIA GEFORCE 9800GX2 )+CUDA DRIVERS

No 64bit Work

Share this post


Link to post
Share on other sites

Hi,

 

is there any progress with this model? Has somebody managed to install hackintosh on g550? Especially I'm curious about support for G 105M video card.

 

Thanks!

Share this post


Link to post
Share on other sites

WORKs .......> Great

 

Mac : Snow leopard universal 10.6 ver. 3.5 / with Dual boot with 7 Ultimate

 

I confirmed that my G550 Lenovo ... works good excpt ( Broadcom ethernet ) and ( Intel 5100 WiFi )

 

Sound works great ( Conexant ) By ====> AppleAzaliaAudio.pkg

 

Nvidia works great G 105M By ========> Latest Enabler_for_Nvidia_and_multiple_ATI_cards

 

 

and i gonna give u all I can as it is great forum :wacko:

AzaliaAudio.pkg.zip

Enabler_for_Nvidia_and_multiple_ATI_cards.rar

Share this post


Link to post
Share on other sites

I´m interested in this machine, too.

I got a few questions:

 

1) How do you solved the wifi problem? Something external?

2) Is the video-output working?

Share this post


Link to post
Share on other sites

Just wanted to chime in and share my experience with installing osx on my g550 laptop. I have almost the exact same laptop as stated above. This post is a little long-winded and geared towards n00bs like myself :superman:.

 

Video: Nvidia 105m - this works flawlessly with the package provided by Moh_vista. I also have an external dell flat panel that osx detects automatically when plugging / unplugging it via hdmi.

 

Install method: I used the myhack installer method. Copied Snow Leopard to a usb stick via a vmware osx image. When installing initially choose ApplePS2Controller or your keyboard and trackpad won't work. After installing update the ApplePS2 kext to VoodooPS2 for better scrolling support for ALPS. If you have an external usb mouse and keyboard you don't have to worry about ApplePS2.

 

Upgrading to 10.6.2: Worked fine with no problems.

 

Installing kexts: You can install kexts in 2 different locations. 1) /Library/Extensions 2) /System/Library/Extensions. Make sure to run the pfix utility after installing kexts to make sure they are installed properly!

 

Audio: The audio works fine with VoodooHDA. At first I thought it wasn't working but then I had to go to sound preferences panel. Under the tab output it was defaulting to Digital Out. Change it to speakers. I could not get this to change automatically when plugging earphones in. Maybe another driver works better? Also the internal mic doesn't seem to work. Also the sound was only detected after I ran the pfix utility.

 

Power: With the supplied Voodoo kexts the battery and power management work fine. The battery icon in the bar correctly shows battery charge etc. However when closing the laptop lid osx hangs and only shows a black screen. Other than that osx has no trouble waking up etc.

 

Keyboard & Trackpad: This took me a while to figure out. I finally added an edited trackpad kext to the VoodooPS2Controller kext. Make sure that ApplePS2Controller is not in any of your extensions folders or it will act wonky. With the attached kext two finger scrolling, regular scrolling and tapping work fine. I could not get it to work with any other kexts. IMPORTANT: to get the trackpad to work first install the kext, run pfix then reboot. After that, replace the Trackpad prefPane in /System/Library/PreferencePanes with the supplied Trackpad.prefPane in the zip. After doing this Trackpad should show up in system preferences.

 

Internet: As stated wireless and wired does not work. I picked up this sweet mini adapter from ebay for only $18 + free shipping. It's wireless n capable and about the size of a penny.

 

Overall the g550 is a great hackintosh machine and running snow leopard on it is nearly flawless except the internet issues. I've included all the kexts mentioned in my post so you don't have to hunt them down. If you have any questions feel free to ask. If you have a better solution for the sound driver please tell! Thanks.

 

Download:

g550_osx_kexts.zip

Share this post


Link to post
Share on other sites

Hi ;)

 

I would ask you about a technical matter of this notebook. I want to buy it also, but I'm often reading tests where is written that the Lapopt-Fan is very loud. Can anyone say anything about this ?

Would be nice ;)

Share this post


Link to post
Share on other sites

I haven't had that problem. My only two complaints are

 

1) The alps touchpad. Synaptics is way more responsive.

2) The fn key being in the bottom left corner. As a programmer I use ctrl alot. I'm constantly pushing fn + key and wondering why it has no effect.

 

Other than that solid laptop.

Share this post


Link to post
Share on other sites

can anyone help me...i've installed mac os 10.5.2 kalyway it worked just fine except i can't find Broadcom Netlink Driver,or some way to get the network adapter work.....my laptop is

lenovo g550,3gb ddr3, 320 gb ata hard disk,intel t4300 dual core processor 2.1 ghz.... :) ...i must tell you that i'm kind new in installing mac

Share this post


Link to post
Share on other sites
I haven't had that problem. My only two complaints are

 

1) The alps touchpad. Synaptics is way more responsive.

2) The fn key being in the bottom left corner. As a programmer I use ctrl alot. I'm constantly pushing fn + key and wondering why it has no effect.

 

Other than that solid laptop.

 

Regarding your item #2 as a programmer you would benefit substantially from going to Systems Preferences, keyboard, modifier keys and remapping your caps lock key to be a ctrl key. If you use the terminal a lot this will make you 300% faster I promise. It takes some time to get used to like Sun Style 3 keyboards but I do this and it's much more productive. As a systems engineer/admin by remapping caps lock (useless key) to CTRL and using screen i am MUCH more efficient.

 

Just my .02 :)

Share this post


Link to post
Share on other sites

I want to ask you, if you get the trackpad fully working. I can use it to move my cursor, but not to do the "left-click" with it. also the sound is not working yet.

 

But i must say, i got the wireless working :) after I finished with those 2 problems, I want to write a little guide how to use it as a real good hackbook

Share this post


Link to post
Share on other sites

I think this too But i need to resolve the problems xD

 

I'm working 3 days with my Snow Leopard 10.6.2 Hackbook. There should be other people, who get Audio working. It can be also good if I start with my Blog-Post and then looking for the people :unsure:

Share this post


Link to post
Share on other sites

@ayame just use the voodoo ps2 kext in the zip file in my previous post. Everything will "work". It's still kind of herky jerky but at least it's working. I'm very curious as to how you got the wireless card working. Please let us know! :wacko:

Share this post


Link to post
Share on other sites

I wanted to start a new topic for 10.6.2, but there was written, that i have not the right to do... Ok, so i wrote a guide in my personal block. I hope all want to help me to get this laptop fully working!

 

http://chems-chaos.de/2010/02/06/hackbook-...pard-dual-boot/ (only German)

 

http://chems-chaos.de/2010/02/06/hackbook-...6-0-auf-10-6-2/ (English and German)

 

Please contact me under the adress of my blog if you find bugs in my english language ;-)

Share this post


Link to post
Share on other sites

Nice job ayame! Very thorough! This will definitely help all who have a g550. Kind of makes me wish I didn't waste those hours trying to figure things out and just wait for your blog post. :rolleyes:

Share this post


Link to post
Share on other sites

Please help to get this Hackbook fully working :( I am missing some Feedbacks on my block, and inputs with other kexts ^^

Share this post


Link to post
Share on other sites

is any usb-wifi adapter good for osx? I found a lot $1 wifi adapters at eBay, but not sure whether osx is able to support them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • It seems nice that chris1111 provided a patch, but I can't -- in good conscience -- download a random binary file from github and run it on my system.    What is so proprietary about his patch that he can't include source? I think I'll wait until the updated driver comes out before I update...  Does anyone know where to look for updates to the webdriver from Nvidia? I've ever found a page that lists them, just links to the actual files to download, and that root is not 'browsable'. I'd like to monitor that site to see when a version is updated for the 17E202 build. Once that is released, I can update OSX and should be fine.  
    • hey MaLd0n  It's been a while since I used clover, so a lot of things went rusty. Can you please look at my setup and guide/help what should be done next?  https://fex.net/354949878474?fileId=441517695   Current setup:  GA-Z97X-UD3H Xeon e3 1245v3  Msi GTX 1050ti Gaming X
    • Hi @fabiosun and thank's for your patience with an old and stubborn man.   I am 100 % sure that my MSR 0xE2 register is unlocked thank's to you.   My system is 100% stable and I haven't had one kp with this configuration in the last two weeks.    I'm now running without TSCAdjustReseat.kext and I can't se any issues in performance with or without that kext. What I however can se is that the amount of total energy consumed during the test-cycle are 10 times higher without the kext (three times Cinebench CPU and two times Luxmark open CL) as you can see in the output from my AppleIntelInfo.kext attached in my earlier post.   I have tested running Cinebench five times in a row with or without TSC kext and have exactly the same performance (see attached files). Temperature is not a problem at all.   Everything seems to be fine so I guess I have to wait and see if upcoming 10.13.5 maybe recognise Intel Xeon w series processor as native.     
    • Tried with HPET enabled and disabled so I don't think it's that. I'd tried with bus ratio before to no effect but wouldn't hurt to try again. The clock runs at the correct speed.
    • could be an HPET / TSC Sync issue. does your system clock slow down or run faster then it should. also check cpu and buss ratios.


×