Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

EasyBCD and Snow Leopard

5 posts in this topic

Recommended Posts

After the dreaded invalid node structure fault on my hard disk I had to reinstall and save my data. I decided to go for Snow Leopard easypeasy install with the available russian distro. Patched to number 3.5.2.


One thing is clear though if after installing you do not put the dsdt.aml file in root, the distro install will not boot. Fortunately I could recover that file from my old drive.


When I had QE and CI and sound back the next thing was to have a dual boot with EasyBCD. The official version 1.72 however gave a chain loading error with the Guid partitioned disk. So I downloaded the latest beta 2.00 v64. Since I have two OSX disks in the system it now give time to switch between them. Only 2 seconds but I can live with that. Problem still was however that the bootloader would not proceed.



My guess was that the .efi file from Easybsd beta still is meant for Leopard. So the boot process would not continue. Then I remembered that somebody here or on another forum advised to copy the bootfile from the OSX SL disk and rename that to nst_mac.efi and replace the original in the NST folder on the c: drive. This is the EasyBCD folder which is normally hidden.


And voila SL boots. So now I can boot Windows 7 and Snow Leopard. I like both but it is clear that Snow leopard has a more clear screen display (display postscript aka DPS) and is certainly more snappy.


Hopefully this can be of help to others who are trying to get there EasyBCD configuration to work with Snow Leopard.

Share this post

Link to post
Share on other sites

Thanks for sharing...for clarity the bootfile is "chain0" then renamed it as "nst_mac.efi" or "nst_mac.mbr". In my case, I renamed "nst_mac.mbr"

Edited by Gringo Vermelho
Please don't quote entire posts when replying directly below them.

Share this post

Link to post
Share on other sites

That's an interesting post, as I also dual boot between SL and W7 using EasyBCD.


One problem though - I cannot seem to install Chameleon RC3 as the bootloader on the SL partition, and am working atm with RC1. How do I call this boot file from within EasyBCD's (well Neogrub really) menu? Is it a case of copying RC3's boot0, or boot1h to the NST folder, or am I missing something here?




Share this post

Link to post
Share on other sites

First post to this forum! Hello, world.


And may I say... I don't appreciate having to leap through burning hoops to even get a chance to post on this forum.... much less have to do it twice :\

Granted, the questions aren't terribly difficult, but... seriously? And "pass-fail" questions how to create a hackintosh when the people joining this forum in the first place are probably looking for help?! :\


Anyway, this is just a brief rant about how I got Snow Leopard (10.6.7) onto my dual-booting Windows XP / Windows 7 Lenovo S10 (4187) . I have everything (USB, iphone connectivity, WLAN) working except Sleepenabler and external video at &--#62;1024x600, which aren't terribly important to me.


First off, I wish I had found this URL earlier. Before I had already been there. He writes, "...most frustrating experience of my life... mostly due to the abysmal quality of the guides that are available. Speaking of the OSx86 guides. They are perhaps the most poorly written, ill-explained walkthroughs ever written... only somewhat useful if you have read every last one, and been failing at your OS X installatino for 4 weeks....." It's pretty funny stuff, but sadly rings true IMO. (I took 4 days of intensive trial and error, and it was... needlessly painful. Learning experience and sense of satisfaction notwithstanding.)


Note that any modification of your partitions results in the Lenovo One Touch Recovery button turning into an ordinary on-off button. You won't be able to trigger the recovery partition to restore your XP using this anymore. But given the abysmal performance with windows XP - do you really want to?


This rant is mainly for venting my frustrations, and perhaps entertaining some of the more sadistic amongst you. i hope it is somewhat educational for hackintosh newbies like myself, and if anyone is interested I'll turn it into a more concise guide - but the S10 is pretty much an antique so I'm guessing interest will be limited.


So I started out with a lenovo S10 (2GB RAM + 512MB on board) with its original windows XP install (sluggish +++), dual booted with a Windows 7 "addition". Windows 7 makes the laptop slightly snappier (? because of increased RAM utilization?) but it just feels... so... unpleasant.


A Google Search for "Installing OS X on windows 7" generates an army of results - most of which are irrelevant. In the end I found one that made sense... sadly I can't credit the author since I've lost the URL... but in a nutshell you need to resize one of your partitions to create unallocated space on your hard disk upon which the Mac OS partition will live. (I like to think of partitions as plastic bags.)


Since the Lenovo S10 comes with 3 primary paritions already (1 FAT-32 for windows XP, one NTFS for the lenovo "one touch" recovery, and another Fat-32 for... user files?) and I had already created a fourth primary partition for Windows 7 (NTFS) I found myself unable to create another primary partition for OS X to live on. (there's a limit of 4 primary partitions)


I found another random online guide and followed it using Easeus partition manager home (free!) to merge my two FAT-32 partitions into one (Didn't convert to NTFS because previous experience showed me it just isn't worth the time and effort.) I then shrank the FAT-32 XP partition, and joined the unallocated space up into a contiguous unit at the end of my hard disk, after my NTFS (Windows 7) partition. (the Easeus page comes with instructions. Sadly the program doesn't let you drag and drop. It takes a little getting used to.) Next step was to format the unallocated space into FAT 32 so that OSX install would see it.


I then used this guide from macuniverse and my macbook pro to create a snow leopard 10.6.3 (my retail DVD) USB installer (Steps 1 to 4). Sadly his guide is meant for people without any other OSs installed, so after I followed steps 5 onwards my boot record had been messed up.


(Boot record -- thing that is stored somewhere on your disc, outside the data area you can browse, that tells windows how to boot up. Bootloader - some program that launches before your OS starts up, and points towards the partition you choose)


I now booted up to : Boot0... testing... (5 times) then boot0: fail followed by my laptop halting entirely. I realised SL must have altered the MBR so I tried to restore it with Windows 7 from DVD (using an external drive). This was unsuccessful, but taking a look with diskpart made me realize that SL had changed the active partition to the new OSX partition. So I changed it back (run dispart from the windows 7 "advanced recovery" section via the command line, and use list volumes, list partitions to figure out what's going on. the "list" command lets you do a "dir" (or "ls"), and "select" lets you view more about that volume/partition. ultimate you set the active partition by selecting it, and typing "active". You can do it too from the OS X Installer - look at this website but instead of choosing the OS X partition, choose the primary booting partition -- for me, windows XP)

Upon the next reboot, windows 7 installer successfully restored the MBR and let me boot back into windows 7. Sadly the windows 7 boot loader records Win 7 and XP were messed up (the boot loader is that black screen with the boot options), so I downloaded EasyBCD. Since I booted into Windows 7, the "C" drive was windows 7, and the "D" drive was XP. I used EasyBCD to create a new BCD schema, which created an \NST folder on D. I then pointed EasyBCD's entry towards the D drive for XP, and the C drive for Windows 7. This worked perfectly, and restored my ability to dual boot.


More guides later, I tried using windows 7 to set the active partition to my OS X partition and reinstalling. Frustratingly, I still got the Boot0 error -- even with SL as the active partition. I still haven't figured out why that is. But miraculously when I used EasyBCD to create a schema for OS X, I could now boot into the chameleon bootloader. Progress... (it's yet another bootloader, which EasyBCD uses for starting OS X. It has a nice picture of a chameleon on it)


Sadly that got as far as starting Darwin (OS X) before rebootig the laptop. This, I assume is the "endless loop" problem the guides refer to. Even starting with -v (verbose mode, lets you see all the errors) wasn't very helpful, since the error flashes up for like a microsecond before the reboot occurs.


Much frustration later, I found an online post that suggested substituting the iboot_legacy ISO for the nst_mac ISO. The ###### 3.3 failed, but the legacy, miraculously got me into OSX 10.6.3 - at last. It would seem that the iboot_legacy kernel (the heart of the bootloader) works with 10.6.3, but the 3.3 kernel (meant for core i5/i7 machines) doesn't.


I now had a perfect working 10.6.3, complete with WIFI and ethernet. So I found flynflip's guide and followed it to the T. How much luckier could I get, right? I guide meant specifically for the S10!


I upgraded to 10.6.7 (no more WLAN but otherwise cosmetically functional), then took the leap to 10.6.8 (don't reboot! download the combo update! delete the _sleepenabler.kext! etcetc) and wound up with a heap of kernel panicks. (kernel panick - equivalent to the windows blue screen of death, only less blue and more helpful)


many attempts at repair later (involving learning how to replace kexts manually from terminal running off the SL installer (what's with the installer terminal not having sudo, anyway? -- note if any websites mention sudo, and you're in the "CD installer's" terminal, just omit the sudo and the commands should work), and repairing permissions, and rebuilding caches...) and replacing the kernel with nawcom's kernel, I finally... gave up. It felt like banging my head against a brick wall. stuck at PCI Configuration, waiting for DSMOS, etcetcetc


I think the combination of easybcd + iboot_legacy just doesn't play nice with 10.6.8. Period. If anyone out there thinks differently, please feel free to convert me from my current PTSD-induced phobia of 10.6.8)


So back to the drawing board for me, installed up to 10.6.7, and no WLAN.


Much googling later, I found this advice :



Open Finder and navigate to com.apple.Boot.plist

Add max_valid_dma_addr=1024 to the kernel flags."


So my com.apple.Boot.plist files (inside Extra folder and /Library/Preferences/SystemConfiguration/com.apple.Boot.plist) now includes:


&--#60;key&--#62;Kernel Flags&--#60;/key&--#62;

&--#60;string&--#62;arch=i386 max_valid_dma_addr=1024&--#60;/string&--#62;


This totally failed for me, since my Kernel Flags are apparently being loaded from the (uneditable) iboot_legacy bootable ISO.


Fortunately, I then found the Broadcom kext fixes. (The S10 uses a Broadcom 4231 wireless a/b/g chipset). I started using kexthelper to semi-automatically install the kexts instead of doing it from command line (automates the process of deleting the old kext, copying the new kext to /system/library/extensions, applying the new permissions (chmod, chown) and booting with -f which rebuilds the kext cache... all of which are necessary when installing a new kext) and now had 10.6.7 with wireless LAN.


Since bootup was intolerably slow (&--#62;30s, most of it waiting for DSMOS) I found this site, and ran this from the "CD installer" terminal



cd "/Volumes/Mac OS" (my partition is called Mac OS...)

chown root:admin /.


this worked beautifully, and I now have a 10+ second boot time.


I found that I could not connect to an external HDTV to the VGA port (the TV is detected, but then both screen and TV get corrupted, but revert when the TV is disconnected. When rebooting with the TV connected, ) even with a kext fix for the intel 945 GM chipset -- no dice, just a note on the TV that the resolution is not supported. Ah well. I'll try with a 1024x768 projector and see what happens.


My webcam was also not working, even with the camtwist fix -- it kept saying that the camtwist camera was in use by another application. Oddly enough, somewhere along the line I have unknowingly fixed this - no idea which kext I installed for this. Perhaps the intel GM did the trick.


Lastly, I found that my iphone was not being detected or charged by the S10. I solved this by downloading ###### 3.10.1 and "rolling back" the IOUSBFamily (drivers & bootloaders / miscellaneous / IOUSBFamily Rollback) and then repairing the permissions and rebuilding the cache (from "system")


I have a sneaking suspicion I could have done most of this using ###### 3.10.1 (snow leopard edition) but... I don't want to think about it right now...


right. So rant over. I have 10.6.7, I have WLAN, iphone charging, normal audio (switching to headphones too) despite system profiler reporting ID = 0, and a working webcam. I have two finger scroll, and, I think, zoom.


All that's missing is sleep (sleepenabler lets me go to sleep, but recovering from sleep gives me a lot of alarming audio cracks and pops and sounds like my mobo is eating itself) and video out to HDTV, both of which I can live by. Sleep can be circumvented by downloading the nosleep utility, which unfortunately at present doesn't remember your last preference, and you'll have to reset it everytime you reboot. The laptop is considerably snappier even in the presence of hard-disk activity, and is using its ram more optimally. More importantly, it looks so pretty. :)


Rant over.

Share this post

Link to post
Share on other sites

for some reason "[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.10.1" is getting censored to #####. anyway it's at [link removed]

Edited by Gringo Vermelho
If you had read the forum rules you would know what the reason is.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.