Jump to content

Preview is not working in Snow leoaprd on PC


12 posts in this topic

Recommended Posts

Hi Guys


I can't take a screen shot on snow and everytime i do using preview i get this error


Process: Preview [361]

Path: /Applications/Preview.app/Contents/MacOS/Preview

Identifier: com.apple.Preview

Version: 5.0 (501)

Build Info: Preview-5010000~1

Code Type: X86-64 (Native)

Parent Process: launchd [223]


Date/Time: 2009-09-13 15:17:06.571 +0100

OS Version: Mac OS X 10.6.1 (10B504)

Report Version: 6


Interval Since Last Report: 34830 sec

Crashes Since Last Report: 3

Per-App Interval Since Last Report: 499 sec

Per-App Crashes Since Last Report: 1

Anonymous UUID: 1A4A1C03-AB2D-4E64-9F50-158A83BC9607



Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

Crashed Thread: 0 Dispatch queue: com.apple.main-thread


Thread 0 Crashed: Dispatch queue: com.apple.main-thread

0 com.apple.CoreFoundation 0x00007fff8148f91b CFArrayGetValueAtIndex + 187

1 com.apple.Preview 0x00000001000ae828 PVCGDisplayCreateImageForRect + 121

2 com.apple.Preview 0x0000000100092d79 PVCGContextCopyDisplayCaptureContentsToRect + 56

3 com.apple.Preview 0x0000000100092c06 PVCaptureRegion + 1383

4 com.apple.Preview 0x0000000100092141 -[PVApplication(Grabbing) grab:windowNum:] + 496

5 com.apple.Preview 0x00000001000947b9 -[PVApplication(Grabbing) grabScreen] + 138

6 com.apple.Preview 0x0000000100093e6a -[PVApplication(Grabbing) _takePicture:] + 512

7 com.apple.Foundation 0x00007fff86365500 __NSFireDelayedPerform + 404

8 com.apple.CoreFoundation 0x00007fff814c3a78 __CFRunLoopRun + 5480

9 com.apple.CoreFoundation 0x00007fff814c203f CFRunLoopRunSpecific + 575

10 com.apple.HIToolbox 0x00007fff86d8dc4e RunCurrentEventLoopInMode + 333

11 com.apple.HIToolbox 0x00007fff86d8da53 ReceiveNextEventCommon + 310

12 com.apple.HIToolbox 0x00007fff86d8d90c BlockUntilNextEventMatchingListInMode + 59

13 com.apple.AppKit 0x00007fff80564520 _DPSNextEvent + 718

14 com.apple.AppKit 0x00007fff80563e89 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 155

15 com.apple.AppKit 0x00007fff80529a7d -[NSApplication run] + 395

16 com.apple.AppKit 0x00007fff80522798 NSApplicationMain + 364

17 com.apple.Preview 0x00000001000017c4 start + 52


Thread 1: Dispatch queue: com.apple.libdispatch-manager

0 libSystem.B.dylib 0x00007fff838b0b16 kevent + 10

1 libSystem.B.dylib 0x00007fff838b2a19 _dispatch_mgr_invoke + 154

2 libSystem.B.dylib 0x00007fff838b26d6 _dispatch_queue_invoke + 195

3 libSystem.B.dylib 0x00007fff838b21f6 _dispatch_worker_thread2 + 244

4 libSystem.B.dylib 0x00007fff838b1b28 _pthread_wqthread + 353

5 libSystem.B.dylib 0x00007fff838b19c5 start_wqthread + 13


Thread 0 crashed with X86 Thread State (64-bit):

rax: 0x0000000000000002 rbx: 0x0000000102032600 rcx: 0x00007fff70c86178 rdx: 0x0000000000000000

rdi: 0x0000000102032600 rsi: 0x0000000000000000 rbp: 0x00007fff5fbfe3f0 rsp: 0x00007fff5fbfe3e0

r8: 0x0000000000000000 r9: 0x000000010201dcc0 r10: 0x00007fff88d54fa9 r11: 0x00007fff8148f860

r12: 0x0000000000000000 r13: 0x4094000000000000 r14: 0x000000005b81c5c0 r15: 0x0000000000000000

rip: 0x00007fff8148f91b rfl: 0x0000000000010246 cr2: 0x0000000000000000


Model: Mac Pro 3,1, BootROM TJ428398-42352, 4 processors, 2.43 GHz, 4 GB, SMC

Graphics: Display, PCIe, 256 MB

Memory Module: global_name

Network Service: Ethernet Adaptor (en0), Ethernet, en0

Network Service: Parallels Shared Networking Adapter, Ethernet, en1

Network Service: Parallels Host-Only Networking Adapter, Ethernet, en2

Serial ATA Device: WDC WD5000AACS-00G8B1, 465.76 GB

Serial ATA Device: HL-DT-ST DVDRAM GH20NS15

USB Device: Microsoft Wireless Optical Desktop® 2.10, 0x045e (Microsoft Corporation), 0x009d, 0x1a200000

USB Device: USB Headphone Set, 0x0c76 (Solid State System Co., Ltd.), 0x1607, 0x3a100000



Link to comment
Share on other sites

Me too

I have tried everything from creating new admin account (some confirmed that worked for them)to installing new applications like Capture deleteing preview screen capture in preferences etc.. I think the issue is not preview it is the saving of the capture that does not work. example. i tried grab and it takes a snap and save it but when you open it it is a blank screen.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...
  • 3 months later...
i have this problem too. when open picture file in preview, it not shown. anybody can help me with this.


To view the pic, select it and click space bar it will open it. if u want to view all of them, then select all of your picture and then click space bar. I hope it will solve yr problem.

Link to comment
Share on other sites


  • Create New...