Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
fiffel

Help macbook refuse to install OS X

4 posts in this topic

Recommended Posts

Hi,

 

I have been given a Macbook by a friend who has asked me to get rid of Vista and install OSX on it.

 

The MacBook currently only has Vista installed and does not have an Apple Partition. I installed BootCamp and when I tried the "Restart in MacOSX" command the error "No OSX Volume can be found"

 

You may think I'm crazy but it's as though the MacBook has forgotten it's made by Apple.

 

On startup there is no Apple logo and if you try zapping the PRAM, starting in Target Mode or holding down the C key to start using an Apple DVD, these commands are simply ignored and the MacBook screen goes black and then Vista appears.

 

In order to get OSX on this device am I going to have to get to know about EFI and change it in some way?

 

This is really beyond me but any help on this matter would be greatly appreciated.

 

Regards

Share this post


Link to post
Share on other sites

Sounds like you need to partition your hard drive with the right file system structure. Vista uses NTFS and mac uses HFS+ Journaled. So in order to install Mac OS you need to use the disk utility to change it to HFS+ before you install the OS. The disk utility should be up at the top of the screen, in tools? I think. I can't remember but that sounds like what needs to happen.

Share this post


Link to post
Share on other sites

you ought to erase that drive. get one of those thousand available free boot disks with some partitioning utility like gparted and boot of that and erase the drive.

 

if you can't get it to boot off cd, you could, if you have a desktop / external case, take out the drive out of the macbook and connect it to sata and erase it with another os.

 

in order to install osx it doesn't matter which os currently resides on the drive. even the filesystem is of no importance because you can, if you can boot of the osx dvd, use the hard disk utility to repartition the drive correctly (guid and hfs+)

 

what actually happens if you turn on the macbook while holding down the alt key?

 

okay, now i'm wondering if this problem still persists... just noticed its a bit old lol

Share this post


Link to post
Share on other sites

I was just wondering if I could use my Macbook pro and install Leopard via Target Disk Mode?? I am assuming no because it is Intel. I already tried TDM and was unsuccessful in seeing the drive on my screen. The cube had the firewire icon bouncing around on its screen but no response on the MBP.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×