Jump to content

Gigabyte G31M-ES2C with Snow Leopard installed and running


9 posts in this topic

Recommended Posts

Got Snow up and running on my Gigabyte G31M-ES2C, and thought I'd post some brief notes on how.


The Gigabyte G31M-ES2C is mostly the same as the GA-G31M-ES2L, so I mostly followed the guide here: http://www.insanelymac.com/forum/index.php?showtopic=181699 - I'll just focus on differences in procedure. The process I followed was:


1. Get the initial Snow Leopard install done - there are lot of ways to do this; Boot-132, Memory sticks, separate partitions, etc. Just choose one based on what you have available. I took the easy way, and used an existing Leopard system to do an install to a SATA drive in an USB enclosure from a standard Apple Retail DVD. The USB part for no reason other than that was the path of least resistance.


2. I then modified the installation (prior to booting it!), by:


a. installing fakeSMC.kext, Openhaltrestart.kext(the 64 bit version) and NullCPUPowerManagement.kext into /System/Library/Extensions. All these kexts are from the post above.


b. Installing Chameleon-2.0-r431. Note I installed manually, from the .bin file - I couldn't get the installer to work.


c. Replaced the boot file with the 64 bit one from the post above.


d. Added a com.apple.Boot.plist in /Extra, copied from the previous 10.5.8 install on the same box, with an EFI string for the display.


e. Adding a patched DSDT file. (patched for the CMOS reset bug).


3. Once I had the mods to the install done, I installed the SATA drive as a SATA drive, in connector 0, as some guides suggest that you can get KPs if the drive is not on zero.


4. Booted with -f -v. Note that at least one guide suggest not using -f; my experience was that not using -f results in KPs


5. That booted fine, but no network - the G31M-ES2C uses a Realtek Lan chip not supported out of the box. I then installed the Realtek 32-bit driver from here: http://www.insanelymac.com/forum/index.php...181133&st=0


6. The Realtek driver doesn't work with 64 bit, so I added the -x32 string to the kernel flags in com.apple.Boot.plist in /Extra. (Note, I'm happy running 32 bit - by default, as I read the Apple docs, all Snow Leopard retail installs run 32-bit by default; only Server runs 64)


7. Reboot, and working.


Working: QE/CI, networking, shutdown, Bonjour, etc, etc, no KPs over about 8 hours (so far) of operation


Not yet paid any attention to: Audio


Not working: Sleep (don't care, don't use it)

Link to comment
Share on other sites

  • 3 weeks later...

How exactly did you get bonjour working with this mb's Realtek chipset? I have installed using the same process... I have sound (Voodoo HDA - ALC883 resulted in a Kernel Panic), PS2 mouse and Keyboard works, Lan works using either Realtek 1000.kext or the Realtek official drivers from the Realtek web-site. (The same thing IMO). But bonjour won't work! I have tried the ipconfig command in Terminal to enable promiscuous mode, but no luck.

I can connect to the internet using a PPPoE setup where I use my username and password, but don't trust this as my network usage shown in the Activity Monitor is extreme. Within a minute of connecting using PPPoE, it shows 4mb of downloaded packets - that without even using a browser and continues running infinately.


I would prefer to get bonjour working and hope you know something that I may have overlooked. I did go to the link in your post regarding this chipset, but that thread kind of goes around in circles.


Please help...


Oh, forgot to mention... I am booting using the 32-bit kernel. I am using the -x32 Kernel flag in com.apple.Boot.plist (Using BootThink Darwin Bootlaoder) as I need to be in 32 bit mode for Sound and Lan to work. Does not work at all using 64 bit kernel. (Although that is not a major concern, as 32-bit is supposed to be default anyway (Some argue the facts, but I am comfortable with what apple do by default ... they must have their reasons) When I used the Chameleon 2 RC3 bootloader and used arch=i386 to get away from the forced 64 bit default kernel, booting would hang ... in -v mode ... "ACPI_SMC_PlatformPlugin wait for service ..... applecpupowermanagement. etc... timed out" even when using Nullpowercpu and disabler kexts (without kernel panic IMA ... just sits waiting indefinitely)


Please help a mac-gurl to get Bonjour working properly//////

Link to comment
Share on other sites

Regarding Bonjour -


This may, or may not be relevant, but I recall that on the (very similar) GA-G31-MF running 10.5.x, you can get Bonjour by assigning a static IP (rather than DHCP) for the nic.


With greetings from Athens.

Link to comment
Share on other sites

I'm just using the Psytar 32 bit driver; Bonjour worked oob. No ipconfigs, static IPs or anything.


You are right. It does work using Psystar's kext. I added dns server address manually and bonjour connects now. Weird though, as Leopard would automatically asign the dns from the router settings. Small detail.... but it works.

Link to comment
Share on other sites

  • 2 months later...

Hi to all;

I recently purchased the same mother board GA-G31M-ES2C with Rev 2.0, could you kindly tell me which version of BIOS you are using. I am unable to install OSX 10.6, the installer hangs up at 90%.


Can any one of you provide me the necessary BIOS settings required to run the OSX 10.6


Thanks in advance

Link to comment
Share on other sites


  • Create New...