Jump to content

All OpenCL Benches: RAYTRACING/Galaxies/Grass/qJulia/Displacement...


125 posts in this topic

Recommended Posts

  • 3 weeks later...
  • 1 month later...

Soon there will be an update to V171, which has slg V1.62Dev insie and also some fixes.

I removed High gpu only bench and added UltraHigh Sponza gpu only.

Would be fine if you check new Sponza Benchmark.

I uploaded the V171 to RS for getting some reference benchmark times. No major changes in known Luxball UltraHigh benchmark .

 

http://rapidshare.com/files/407420780/smallluxGPU_V171.zip

Bildschirmfoto_2010_07_17_um_10.59.14.jpg

Hi Andreas

 

V171 :

 

here are the results of the Sigmaringen Jury:

 

midrange: 8,6sec

ultra high: 34,9

sponza:44,8

 

5770 is recognized with 725 MHz and 512 MB RAM here

__

 

and slightly off topics , but I know you are the man: :(

 

got the 5770 to work with netkasdrivers without a hitch on 10.6.4

 

seems all work : resolutions-quartz-dual monitors with second display on hdmi

 

but:

 

extremely low performance in opengl extension viewer :

card is recognized as ATI Radeon HD 5770 OpenGl Engine

all 120 extensions are there

 

but only 200 fr. in benchmark /ffsa 4 mode

2900 fr in normal mode

remember our ati 3850 with 4500 fr. in normal mode ?

 

Any thoughts ?

 

best

armin

Thanks your results will be references in next final 1.7.1. (monday/tuesday)

200 fr with 4*fssa is real low if non fssa is 2900+ frames !

Maybe the driver cant setup fsaa correct and you must wait for later (official ) drivers.

Thanks your results will be references in next final 1.7.1. (monday/tuesday)

200 fr with 4*fssa is real low if non fssa is 2900+ frames !

Maybe the driver cant setup fsaa correct and you must wait for later (official ) drivers.

 

 

Hello,

 

Here a my benchmarks wilth 1.7.1

 

Smallux 1.7.1 SmalluxGPU v1.6beta1 OSX 10.6.4

Luxbal glass scene 640x480

All tests with Optimized Type 1

4 Cores CPU + All GPUs

Intel Core i7 CPU 920@2.67GHz 2800MHz

ATI 4850 GS Gainward 510Mb 750MHz

 

Benchmark Modes OPENCL GPU only

Luxbal Midrange : 2,3s

Sponza Ultrahigh : 50,9s

Luxbal Ultrahigh : 1,9s

 

and CPU+GPU

Luxbal Midrange GPU: 10,7s

Sponza Ultrahigh GPU only : 49,9s

Luxbal Ultrahigh GPU only : 4,0s

 

Benchmark GPU with OpenCL pixel filtering

Filter none: 795,38M

Filter Preview: 200,47,M

Filter Gaussian: 82,10M

;)

Benchmark Modes OPENCL GPU only

Luxbal Midrange : 2,3s

Sponza Ultrahigh : 50,9s

Luxbal Ultrahigh : 1,9s

 

and CPU+GPU

Luxbal Midrange GPU: 10,7s

Sponza Ultrahigh GPU only : 49,9s

Luxbal Ultrahigh GPU only : 4,0s

 

First to say there is no CPU+GPU Benchmark.

The lest side of the slg GUI (where you can select GPU, CPU+GPU) is the interactive mode, which shows the rendering and supports a few scenes. All the settings there are independend from the middle Benchmark gui part.

Only that settings are used with fixed scenes and fixed resolutions.

 

Your Ultrahigh Luxball benchmark (always gpu only) times look a bit fast.

Please check the console tab (within the GUI) and look for some errors.

OpenCL does automatic use the CPU and not GPU if some gpu device fails (mostly driver probs).

Therefor (gpu fails) fast i7 cpu will perform much faster as ATI 4850 GS.

You can also check that - if you can run real gpu only benches - if you start luxball scene (or other)

in the interactive mode (left side of gui).

You would see your GPU speed informations (Rays/Sec) in the interactive render window beside the cpu threads info (shown as native .... ) or alone.

If you only see native .... fnormation lines and no gpu information line the gpu fails and cpu works insted, even setting gpu only.

 

I attached an screenshoot which shows interactive mode running CPU+GPU. Please post your screen also to compare. If gpu works, you will see also an information line (Cypress=GPU) for GPU below that cpu thread lines (native...)

 

If we also GPU information line i can put some extra code to investigate the problem of the to fast Ultrahigh Luxcall results.

But first we have to look after your interactive speed results (native+ gpu XXXk Rays/sec).

Bildschirmfoto_2010_07_26_um_07.43.26.jpg

Hi Andreas

as you changed the terminology slightly in 1.7.1 here the results again :

 

ATI 5770 @750

_____________

 

 

 

bench luxball midrange : 8,6 sec.

bench ultrahigh :33,4 sec

bench sponza :44,8 sec.

 

 

EDIT : CPU@ 3,2 GHz

 

mid: 7,0

sponza: 36,8

 

 

 

 

 

 

________________

 

opencl pixelfiltering :

 

error on ati cpus

 

best

armin

Thanks !

OpenCL Pixelfillter for ATI 57/58xx isnt implemented in the OS X ATI OpenCL driver - so that error is "normal".

I will upload an Final 1.7.1 today here , with some new instances scene (130 Mill triangles! to reytrace) and SPPM raytracing Method switch in the GUI ( beside Type 0, Type 1 - glass looks very nice). Times will not change by this update .

 

Attached 130 milllions triangles object raytraced. ( Most other scenes have less than 50.000 triangles)

Will need >= 3GB RAM to run fast (also when run in gpu only). On 2 GB systems the raytracing may run slower/stall because of memory swappings.

Bildschirmfoto_2010_07_26_um_09.18.28.jpg

Now 1.7.1 preFinal V3:

DL 55 MB: 171V3 with benchmark instances scene (8800GTX = 150 sec)

http://rapidshare.com/files/410151278/smallluxGPU171_V3.zip

 

- removed OpenCL Code Type selector (0/1) from Benchmark. Always use now Type 1.

- added SPPM Method Type - special raytracing method in OpenCL. Glass / lights look mostly better, but more cpu usage

- added intances 130 Mill Scene (fixed res / special OpenCL Code = no res+no Type selector for that scene)

Instances 130 Million (triangles) may NOT work on ATI OS X GPUs.

At least on Windows the ATI OpenCL drivers fail, Nvidia drivers can run that scene on Win/OS X

Also huge RAM usage, therefore 3GB RAM needed to perform fast. I would NOT run that GPU only on lowend GPUs.

- added again CPU cores count selector (2 or 4 cores) for interactive scenes

Hi Andreas

as you changed the terminology slightly in 1.7.1 here the results again :

 

ATI 5770 @750

_____________

 

 

opencl pixelfiltering :

 

error on ati cpus

 

best

armin

 

Perhaps you should install latest update for Imac 10.6.4 wich is taking charge of latest ATI Radeon HD 5670 or ATI Radeon HD 5750 !

 

perhaps you could after this update with latest ATI buffer

http://netkas.org/?cat=7

:(

Yep, maybe the iMac Mid 2010 OpenCL Framework update (ATI OpenCL Framework updated onyl) may help - otherwiese 10.6.5 in the future. In the OS X past, ATI OpenCL drivers were oft a bit problematic (until updated each 10.6.x - Nvidia mostly working.

  • 1 month later...
Yep, maybe the iMac Mid 2010 OpenCL Framework update (ATI OpenCL Framework updated onyl) may help - otherwiese 10.6.5 in the future. In the OS X past, ATI OpenCL drivers were oft a bit problematic (until updated each 10.6.x - Nvidia mostly working.

 

 

Hi Mitch , you may correct HD 5770 results :-)

 

mid : 7,0 sec.

 

Sponza : 36 sec.

 

 

post-253749-1283425954_thumb.png

  • 1 month later...
  • 5 months later...

NEW OpenCL Luxbenchmark

(Same Code base as SmallLuxGPU, but measures an fixed time (120 sec) for an fixed scene to render - better comparable results.

You will get an OpenCL Benchcount between 300 und 12000 (higher=faster, with > 1 highend card up to 40000) , depends on the GPU speed.

My NV 9600GT gets value of 620 in OS X 10.6.7.

 

http://www.luxrender.net/wiki/LuxMark#Download (DL MAx OS X Version)

 

Here some results (Win, Linux, OS X):

http://www.luxrender.net/wiki/LuxMark_Results

 

PS: Nividia Fermi (GTX 4xx) seems to work in LION DP2 now :)

Bildschirmfoto_2011_04_02_um_10.34.00.jpg

  • 2 months later...
  • 2 months later...
×
×
  • Create New...