Jump to content
InsanelyMac Forum
alnova1

Final cut pro 6 crash on Hackintosh

Recommended Posts

Has anyone had this problem? I installed Final cut pro 6 and upon start up after installation, it goes through all the motions and after it tells you there is no camera attached, it crashes. I have tried updating also and this didnt help. I am running 10.5.5 on a 2.40 quad-core with 8 gb of memory and nvidia 7300 gt.

Share this post


Link to post
Share on other sites
Advertisement
Has anyone had this problem? I installed Final cut pro 6 and upon start up after installation, it goes through all the motions and after it tells you there is no camera attached, it crashes. I have tried updating also and this didnt help. I am running 10.5.5 on a 2.40 quad-core with 8 gb of memory and nvidia 7300 gt.

 

I am having the same problem. I even tries final cut 5 and 6 both crash the exact same way. Compressor, dvd studio, everyting else works fine just final cut pro. If you found a fix please let me know.

Share this post


Link to post
Share on other sites

Hi

What I did.

 

Edit the NetworkInterfaces.plist...

 

go to: /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

 

Change these lines:

 

BSD Name from "en1 or whatever you have" to "en0"

 

IOInterfaceUnit to "0"

 

I saved to another location then replace the file, it will ask the admin password.

 

Then delete your internet connection, and add a new, it has to show the en0 network adapter.

 

Hope this helps.

Share this post


Link to post
Share on other sites

Hi ihackpro... your solution worked absolutely perfectly for me. After I edited the plist, rebooted and went into the Network preferences, the system informed me it had detected a new ethernet port and told me to configure it... Did that and now FCP 6.0.6 starts up without a single problem. Wonderful stuff!

 

Thanks for putting this here for us to use.

 

Hi

What I did.

 

Edit the NetworkInterfaces.plist...

 

go to: /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

 

Change these lines:

 

BSD Name from "en1 or whatever you have" to "en0"

 

IOInterfaceUnit to "0"

 

I saved to another location then replace the file, it will ask the admin password.

 

Then delete your internet connection, and add a new, it has to show the en0 network adapter.

 

Hope this helps.

Share this post


Link to post
Share on other sites

I had the same problem; actually neither Final Cut Pro nor QMaster nor Compressor would run and crash on startup (including QMaster preferenc panel). and that´s how it got fixed: It is, like already mentionned, Final Cut Pro not seing a Ethernet Interface "en0". To get this, you go into Preferences Panels/Networking and delete all networking interfaces except your major ethernet - which is very likely up and running. After this you go to /Library/Preferences/SystemConfiguration and delete "NetworkInterfaces.plist" (you can keep a backup copy, if you like).

 

Restart your Hackintosh now and go to Preferences Panels/Networking again and klick on the"Tool" symbol to choose "Rearranging Interfaces". Do this and put your Ethernet to the top.

Share this post


Link to post
Share on other sites

mine is dying in the same way. I have a evga 9800gtx though.

my board (cant remember?) won't even give me an option of en0 and if I try to edit said file, it changes it back to fw0 after restart.

ideas?

Share this post


Link to post
Share on other sites
I had the same problem; actually neither Final Cut Pro nor QMaster nor Compressor would run and crash on startup (including QMaster preferenc panel). and that�s how it got fixed: It is, like already mentionned, Final Cut Pro not seing a Ethernet Interface "en0". To get this, you go into Preferences Panels/Networking and delete all networking interfaces except your major ethernet - which is very likely up and running. After this you go to /Library/Preferences/SystemConfiguration and delete "NetworkInterfaces.plist" (you can keep a backup copy, if you like).

 

Restart your Hackintosh now and go to Preferences Panels/Networking again and klick on the"Tool" symbol to choose "Rearranging Interfaces". Do this and put your Ethernet to the top.

 

Worked like a charm!

 

Got final cut running now.

 

Thanks!!

Share this post


Link to post
Share on other sites
I had the same problem; actually neither Final Cut Pro nor QMaster nor Compressor would run and crash on startup (including QMaster preferenc panel). and that�s how it got fixed: It is, like already mentionned, Final Cut Pro not seing a Ethernet Interface "en0". To get this, you go into Preferences Panels/Networking and delete all networking interfaces except your major ethernet - which is very likely up and running. After this you go to /Library/Preferences/SystemConfiguration and delete "NetworkInterfaces.plist" (you can keep a backup copy, if you like).

 

Restart your Hackintosh now and go to Preferences Panels/Networking again and klick on the"Tool" symbol to choose "Rearranging Interfaces". Do this and put your Ethernet to the top.

 

 

Thanks!! Finally everything works! :)

Share this post


Link to post
Share on other sites
Thanks!! Finally everything works! :help:

I have Final Cut Studio 3. I install everything. Compressor and Final cut Pro both crash when loading up. I found out by uninstalling Qmaster, final cut pro loads fine. Now I don't have compressor, qmaster installed and would like to have them. Also, the "Share" functionality in Final Cut Studio is now disabled because it uses Compressor, which I don't have. I have a hackintosh computer. I connect to the internet using some third party wireless card that's intstalled. I believe it acts as the airport. Here are my network settings:

 

AirPort:

 

Type: AirPort

Hardware: AirPort

BSD Device Name: en1

IPv4 Addresses: 192.168.0.25

IPv4:

Addresses: 192.168.0.25

Configuration Method: DHCP

Interface Name: en1

NetworkSignature: IPv4.Router=192.168.0.1;IPv4.RouterHardwareAddress=00:17:9a:48:24:03

Router: 192.168.0.1

Subnet Masks: 255.255.255.0

IPv6:

Configuration Method: Automatic

AppleTalk:

Configuration Method: Node

Default Zone: *

Interface Name: en1

Network ID: 65513

Node ID: 148

DNS:

Server Addresses: 192.168.0.1

DHCP Server Responses:

Domain Name Servers: 192.168.0.1

Lease Duration (seconds): 0

DHCP Message Type: 0x05

Routers: 192.168.0.1

Server Identifier: 192.168.0.1

Subnet Mask: 255.255.255.0

Proxies:

Exceptions List: *.local, 169.254/16

FTP Passive Mode: Yes

Ethernet:

MAC Address: 00:23:69:09:1f:83

Media Options:

Media Subtype: Auto Select

 

 

Ethernet Adaptor (en0):

 

Type: Ethernet

Hardware: Ethernet

BSD Device Name: en0

IPv4:

Configuration Method: DHCP

IPv6:

Configuration Method: Automatic

Proxies:

Exceptions List: *.local, 169.254/16

FTP Passive Mode: Yes

Share this post


Link to post
Share on other sites
I have Final Cut Studio 3. I install everything. Compressor and Final cut Pro both crash when loading up. I found out by uninstalling Qmaster, final cut pro loads fine. Now I don't have compressor, qmaster installed and would like to have them. Also, the "Share" functionality in Final Cut Studio is now disabled because it uses Compressor, which I don't have. I have a hackintosh computer. I connect to the internet using some third party wireless card that's intstalled. I believe it acts as the airport. Here are my network settings:

 

AirPort:

 

Type: AirPort

Hardware: AirPort

BSD Device Name: en1

IPv4 Addresses: 192.168.0.25

IPv4:

Addresses: 192.168.0.25

Configuration Method: DHCP

Interface Name: en1

NetworkSignature: IPv4.Router=192.168.0.1;IPv4.RouterHardwareAddress=00:17:9a:48:24:03

Router: 192.168.0.1

Subnet Masks: 255.255.255.0

IPv6:

Configuration Method: Automatic

AppleTalk:

Configuration Method: Node

Default Zone: *

Interface Name: en1

Network ID: 65513

Node ID: 148

DNS:

Server Addresses: 192.168.0.1

DHCP Server Responses:

Domain Name Servers: 192.168.0.1

Lease Duration (seconds): 0

DHCP Message Type: 0x05

Routers: 192.168.0.1

Server Identifier: 192.168.0.1

Subnet Mask: 255.255.255.0

Proxies:

Exceptions List: *.local, 169.254/16

FTP Passive Mode: Yes

Ethernet:

MAC Address: 00:23:69:09:1f:83

Media Options:

Media Subtype: Auto Select

 

 

Ethernet Adaptor (en0):

 

Type: Ethernet

Hardware: Ethernet

BSD Device Name: en0

IPv4:

Configuration Method: DHCP

IPv6:

Configuration Method: Automatic

Proxies:

Exceptions List: *.local, 169.254/16

FTP Passive Mode: Yes

 

 

 

I have the same problem....

any one help??

Share this post


Link to post
Share on other sites

People, thanks a ton... At first I had problems with QE-CI, then wanted to extend my partition, formated by mistake, then dealing again for 4 days continuously with QE-CI (even though in profiler appeared as supported) because FC was crashing at startup. And no nothing. Now, I modified to en0 (from en2), restarted and it works perfectly. Geez, all this fuss for the network adapter's name??? Does it even have anything to deal in final cut??? (I'm talking about the network adapter). Thanks a lot, again, it works perfect now.

Share this post


Link to post
Share on other sites

Any other motif for Final Cut not working cause even with en0 can't get it to work, either on ethernet nor on wi-fi ;)

Share this post


Link to post
Share on other sites
I had the same problem; actually neither Final Cut Pro nor QMaster nor Compressor would run and crash on startup (including QMaster preferenc panel). and that�s how it got fixed: It is, like already mentionned, Final Cut Pro not seing a Ethernet Interface "en0". To get this, you go into Preferences Panels/Networking and delete all networking interfaces except your major ethernet - which is very likely up and running. After this you go to /Library/Preferences/SystemConfiguration and delete "NetworkInterfaces.plist" (you can keep a backup copy, if you like).

 

Restart your Hackintosh now and go to Preferences Panels/Networking again and klick on the"Tool" symbol to choose "Rearranging Interfaces". Do this and put your Ethernet to the top.

 

Thank you sooooo much!!! You saved my day!!!!!

 

Pcace

Share this post


Link to post
Share on other sites

help please anyone....

i cant use apple motion 4. there's always kernel panic appear

i tried to uninstall it several times but the results still same, others working fine (FCP 7, DVD Studio Pro, color ,etc)

even when i tried istaling motion 3, the result same crash kernelpanic appear ( sorry for my bad english)

intel core2 quad 9550

gigabyte EP45 UD3R

 

help please...

Share this post


Link to post
Share on other sites
Hi

What I did.

 

Edit the NetworkInterfaces.plist...

 

go to: /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

 

Change these lines:

 

BSD Name from "en1 or whatever you have" to "en0"

 

IOInterfaceUnit to "0"

 

I saved to another location then replace the file, it will ask the admin password.

 

Then delete your internet connection, and add a new, it has to show the en0 network adapter.

 

Hope this helps.

 

This worked like a charm with me.

A caveat is, in my case, I had to input en0 and IOTinerfaceUnit to 0 TWICE. I had to replace the values up top, scroll the .plist down to the bottom and replace the identical values.

I pulled my hair out because I was only replacing the top values.

So finally, I figured it out. Rebooted my system. Checked network under system profiler and it STILL said EN2 under BSD.

Going into system preferences/network, it prompted me to add a new network card EN0. Sweet! Went to the little gear icon at the bottom to "set service order," reordered EN0 to the top, deleted everything else and I was golden.

Log and transfer works and everything is accelerated.

I know this is a lot of repeating earlier posts, but I wanted to share my experience.

Share this post


Link to post
Share on other sites

Mine says it's EN0 but the only way I could get FCP open was to remove QMASTER. Now FCP works but compressor doesn't, it crashes at startup still. Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×