Jump to content

still waiting for root device

18 posts in this topic

Recommended Posts

Has anybody managed to find out what this problem is? no matter what i try (on a REAL system with SSE3 enabled) i cannot get past this message in verbose mode. The normal mode gets me to the apple screen with the "no entry" box. I have tried the rd=drive0s1 (and all combinations of it) and still nothing. This is all that seems to be stopping us from booting at the moment.


Any ideas?

I'm running it on a normal P4 system, and also a new dual core machine (the MAC installer detects 4 logical cpu's! :)) same problem on both.



Link to comment
Share on other sites

Did anyone manage to actually get those files and possibly zip them up for download in the software section? It seems like the only way to get it working is to do some reverse engineering, and recompiling on a MAC system. Not useful if all you have is a PC :)


someone post dem files!

Link to comment
Share on other sites

i tried on boot -v, -s or -f


but when: -v or -s: and still wait for root device

-f = error on gray apple bootscreen


i got folders from /System/Library/Extensions darwin 8.0.1 x86 and do not replace at all on phoenix iso (using transmac)

i also delete /System/Library/Extensions/IOATAFamily.kext for first on phoenix iso


and stay on the same error.

note, i'm running it from vmware.


thats right? :?

before do this fix on iso, i got the screen to reboot my computer.


well just it.

better than KDP_POLL errors :)

Link to comment
Share on other sites

actually, this seems to sporadically work. i started it booting, then went in the shower and came back to a list of 'still waiting for root device' messages.


then i reset the VM, and it got past that point, but now it kernel panics and give a message about kdp_poll no debugger device after it fails to nfs_boot.


The reason i think this happens is because i don't have a CPU that supports SSE3, but i would like some confirmation of this?

Link to comment
Share on other sites

ok how do you people add the library without the iso corrupting


for one ultra iso only sees the extensions folder under hfs mode and you cant copy all the files from it and add them to a new image easily


isobuster sees the hfs too and wont let you extract without registering (i did enter the key and it took it)


EDIT: Removed content violating DMCA


and is ultra iso the only that does it? ive tried lots of other programs and isobuster and ultraiso are the only that seem to work


and whats with this macdrive stuff i have macdrive and i cant mount images it only asks do i want to burn an image

Edited by Metrogirl
Link to comment
Share on other sites

I was the one who added the 2nd part to the Errors wiki.


I am not sure how RAM disk works and what kext is needed for it, but the installer needs to create the RAM disk for /var and that's where I am currently at. It might be that it's System.kext/PlugIns/IOKit.kext that provides the RAM disk but I could be wrong, not much info googling for the specified error and the solution they provide

is one for PPC and OS X after it's installed.


Either way, I didn't have much luck with darwin 8->8.1->mactelbase->gui path so I'm hoping we can get the Dev.DVD patched all the way and ready for install.


We need a PC application that will read Hybrid DVD's and save them back properly. As noted above neithe UltraISO nor ISObuster do it, and we need an alternative. Perhaps mounting the .iso in linux as a read/write fs would help but I haven't tried yet.

Link to comment
Share on other sites

  • 2 weeks later...

I put rd=disk0s1 in the boot prompt and it got past the "Still waiting for root device" but now I am getting the following:


nfs_boot: networking is not initialized 
panic(cpu 1 caller 0xC0256EA6): nfs_boot_init failed with 6

Debugger called <panic>
ethernet MAC address: 00:00:00:00:00:00
ip address:

waiting for remote debugger connection
kdp_poll: no debugger device


Please Help

Link to comment
Share on other sites


  • Create New...