Jump to content

MAC OS X on Dell Studio Hybrid


65 posts in this topic

Recommended Posts

  • 2 weeks later...
Id like to know also i cant find the exact specs on it, it be pretty cool to run mac on it.

Hi! I bought from DELL this wonderful mini pc. I have problems to install Kalyway, it seems that the only option in Darwin is CPUS=1 but I want to try with Deneb (downloading:-))))

My specs are these:



Any help will be accepted;-))))



P.S. Video card is Intel X3100

Link to comment
Share on other sites

  • 3 weeks later...



i've managed to install a Leo4all v3 with "cpus=1", erased all kext related to GMA x3100 to be able to boot in VESA. I've used sonotone dell post installer to add wireless and it works pretty well.


Now i'am looking to start frow a stock install and to add only necessary kext and to get GMA x3100 working but i am getting stuck with :

"using 10485 buffer headers and 4096 cluster IO buffer headers."


i've tried every solutions proposed on this forum and none of them have worked.


Comments or suggestions anyone ?

Link to comment
Share on other sites



here is a quick answer i will do a longer post next week : what i've done so far :


Leo4all v3 works on the hybrid, here is how :


1 - Resize your vista partition to make room for Leo4all,


2 - Boot Leo4all DVD (peharps with cpus=1) and install it on the new partition


3 - you need a boot 123 cd to be able to boot your new partition, boot with cpus=1 and -x to go in terminal mode


4 - delete all AppleIntelGMAX3100 kext in the System Library Extension folder, and delete Extensions.mkext


5 - reboot with the boot 123 cd always with cpus=1, install Chamelon DFE for hard disk


6 - you can modifiy your apple.boot.plist to do cpus=1 and set a VESA graphics mode (mine is 1440x1024x32)


now you can normaly reboot your studio hybrid but only in VESA mode.


With Leo4all installed, i managed to install a stock Leopard 10.5.5 and modifiy it to make it boot in VESA mode. I've also test a special X3100 kext my screen is no longer black but the display is {censored} (lines seems to be scrambled), it is still not working but it is a closer step to the solution to get X3100 working on hybrid.


Anyone got X3100 working on hybrid ?

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 3 weeks later...
if people are interrested in i will post a tutorial


Me three! I've been trying to get this up and running for three weeks and it's still kicking my ass. I'm currently on iDeneb and having installed ok with your hints above, but am hanging on the reboot when it loads the video drivers...

Link to comment
Share on other sites

Here is a quick tutorial, i will post a longer article when sound problems will be resolved.


First I as said before i've managed to install a Leo4all v3 with "cpus=1". Use "-x" option to boot in vesa mode and erased all kext related to Intel GMA (and Intel GMA Framebuffer)

I need it to be able to install a stock 10.5.6 install (if you own a Mac you surely will be able to bypass this step).


Then here is my steps :


From your Leo4all installation :

1 - Install a stock 10.5.6 Leo installation on a partition


2 - Install the latest 10.5.6 combo update


3 - Find DSDTPatcherGUI_1.0 (or later but that'is the version i currently use) and follow the instructions to produce a dsdt.aml (to put in the root folder of your stock 10.5.6 installation)


4 - With DSDTPatcherGUI_1.0 in the Tools folder you have Bootloader.pkg to install Chameleon


5 - Then you need some kext's to put in Extra/Extensions directory (on the root folder). I used the kexts from a file called "generic.iso" that i've found on this forum. You mount generic.iso then initrd.img in generic.iso. And here is the Extra folder. I keep only the following kext : AppleACPIPlatform, AppleAHCIPort, AppleAPIC, AppleSMBIOS, AppleVIAATA, dsmos, IntelCPUMDisabler and SMBIOSEnabler.


Update 1 : it seems that only dsmos and SMBIOSEnabler are required


Update 2 : I made a complete new installation yesterday and it seems that for the first run all kexts are required (the one in the first list). With only dsmos and SMBIOSEnabler I had problem running the installation for the first time.


6 - Erase all Intel GMA kext and Intel Framebuffer from your Extensions installation folder


7 - Install these one : http://xtremevenomuk.co.uk/download.php?list.15

(use KextHelper it is quick and easy) you will have all QE/CI enable but but but only on the VGA output (which is already great).


Update 4 : Ethernet stop working with 10.5.6 driver. I upload driver from Realtek (yeah MacOs driver) and everything is fine now

Update 5 : Bonjour, the sharing protocol do not work pretty well with the Realtek driver. So I use this one :


but i does not come with a proper installation (you have to put the kext in the IONetworkFamily.kext in the plugins Folder

Take it at your own risk, it is a quick tutorial so it assumes you already have some knowledge on installating osx.


The next steps :


- Reduce the list of needed kext and do a precompiled mkext to be put in the extra folder (speed up booting i think)


- Get audio working


- Get a good keyboard mapping (idea anyone ?)

Update 2 : In system preferences, international you can choose a PC keyboard mapping which is ok for me.

Update 3 : In fact I use keyboard mapping from Sonotone Dell Post Installer (only used for the keyboard)


- Make a lengthy and more detailed tutorial


I have Vista and OsX on my internal drive. My advice, keep 2 partitions on your internal drive (one for vista and one for osx) and do your tests on an external usb hard drive (you can do all the steps from a Mac on a usb external drive and the try it on your Hybrid by the way but be carefull). When you have a good installation on your usb drive you can copy it to your internal drive using Disk Utility.


The final step would be to have all video output (dvi-d, vga and hdmi) working... who knows ?

Link to comment
Share on other sites

Thanks for the brief summary. I'd also come across this article:




Which, whilst not for the Hybrid, covers the same Chipset and Graphics adapter. Pretty much the same information provided with a couple of extra bits and pieces.


Does anyone know why the DVI-D port off the splitter cable doesn't work? The VGA port, as said above, works fine - but the DVI port only renders a subtle blue screen. This isn't a must have, but for Dual boot systems would keep things tidier!

Link to comment
Share on other sites

My installation works without sleepdisplay and natit which seems not to be the case of the link you post Postrecho.


as an add on to my tutorial, it tried to minimise the list of extra kexts yesterday and thanks to the dsdt patch it seems that only dsmos and SMBIOSEnabler are required (works on my installation).


so things to be done :


- Audio


- Keyboard mapping


- DVI-D working


i'am adding a new one (which is less important on a desktop that an laptop but)


- get Suspend working (it has a very strange behavior but I only test it today as I usualy always turn on and off my hybrid). If anyone has informations on how it works on Apple desktop pc i would be usefull.


Do not hesitate to post informations or questions.



Link to comment
Share on other sites

For the keyboard mapping, if like me you own a MS keyboard, then MS have a Mac version of Intellitype and Intellipoint - both work perfectly. This maps all non-std keys but still does not fix the annoying @ vs " switch!


I found that once I had installed the above files, I had a new region keyboard layout 'UK - Microsoft' and when selected - all mappings are ok.


Perhaps that's one less!


BTW = Agree completely re the natit. I used the video drivers you posted as the others were a little quirky! Now if only DVI ...!?

Link to comment
Share on other sites


  • Create New...