Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Crashing OSX on VMWare Fusion on OSX Leopard using AMD

5 posts in this topic

Recommended Posts

I've got two machines running Leopard. I've got an Asus Quad Core Intel running one of the first 10.5.1 images that came out. Still runs perfect. I have VMWare Fusion 1.1.1 installed and run a prebuilt Tiger images known as OSX10.4.10_Vmware_Appliance on it. It runs flawlessly I can keep it up for weeks and it never crashes.


I take this same EXACT image and try to run that on my AMD machine, it will run for 2-3 hours but VMWare Fusion will always eventually crash. I've tried a fresh OSX10.4.10_Vmware_Appliance image, no difference. Since the AMD machine is a test machine, I've tried different Leopard images from Kalyway to Leo4All, tried upgrading to 10.5.3, or any other tricks, VMWare Fusion running my Tiger VM will always crash eventually.


This machine is a Bio Star K8M800 Micro AM2 motherboard with an AMD Dual core. 2 gigs of memory and SATA. NVidia 7800 AGP 8X video card. I've tried different Leopard kernels for the heck of it, some of the kernels that come with the Kalyway image cause VMWare fusion to crash the local Leopard OS kernel as soon as I start it. Using the default Kernels with either Leopard image, the local machine never crashes, just VMWare Fusion. I've also tried VMWare Fusion versions 1.1.1 and 1.1.3, all have the same problem.


Any help on this would be appreciated as I can't think of anything else to try to make VMWare Fusion stable on this AMD system.


Any feedback of anyone who has successfully run Tiger on VMWare Fusion on an AMD system using a host OSX Leopard machine would be helpful too!

Share this post

Link to post
Share on other sites

as the vmware does not "emulate" the processor but is making it acessable to the guest system.

so an identical image is not necessary running on identical hardware.


as for the crashes on amd, did you decrypt the app with marvins? might be coded for intel proc id´s.

Share this post

Link to post
Share on other sites

In response to the first reply, yes VMWare does have CPU ID flags in it, however from what I have read, changing the CPU ID's on it turns VMWare into running in 32 bit mode instead of 64 bit mode. People have advised not to do that.. If it was a problem with the CPUID, I'd expect VMWare to not run at all. However it does run, and it runs rather well for 3 hours usually. Then it just crashes. The OSX host machine still runs perfect (to my knowledge), it's just the VMware process that hangs and crashes..


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.