Jump to content

Keyboard/Trackpad troubles after install (STILL UNSOLVED!)

18 posts in this topic

Recommended Posts

I'm running 10.5.2 on my Gateway ML6720 Laptop and the install went fine. I had to use a USB keyboard to complete the installation because the onboard keyboard wasn't working, but the trackpad was working fine. So, after it was done I went to work trying to fix the keyboard, but nothing seemed to work. I tried every solution in the How To - Keyboards, Trackpads, etc. thread, but still I've had no luck. Everything from the boot DVD Terminal had absolutely no effect and all the hacked and enhanced drivers did was break the trackpad, but didn't get the keyboard working? I've tried the Kalyway, iATKOS, Leo4All, and even the beta JaS release with the methods, and still nothing. Could it possibly be because I'm running Leopard on a external USB drive? Because I wanted to make sure I could get it to work there before I moved it onto my laptop.


Is there some other solution I could try to get both the keyboard and trackpad working?


Here's the specs from the Gateway website if it helps...


ML6720 Notebook Specifications

Part Number: 1014691RGateway ML6720 Notebook


Feature Description

Processor Intel® Dual-Core Mobile Processor T2310

1.46 GHz | 1 MB L2 cache | 533 MHz FSB

Chipset Intel® GL960

Display panel 15.4-inch WXGA (1280 × 800)

Memory 1024 MB 667 MHz DDR2 SDRAM (2 × 512)

Operates at 533 MHz

Total slots: 2 DDR2 slots | Available slots: 0 DDR2 slots

Video controller Intel® Graphics Media Accelerator X3100

Up to 384 MB of Dynamic Video Memory

Audio High definition audio - 2 channel

Hard drive 120 GB 5400 RPM SATA hard drive

Optical drive 8x Multi-Format Dual Layer DVDRW with DVD-RAM with Labelflash™


Write maximum: 8X DVD±R, 6X DVD-RW, 8X DVD+RW, 2X DVD-R DL, 2.4X DVD+R DL, 5X DVD-RAM, 24X CD-R and 16X CD-RW discs

Read maximum: 8X DVD-R/RW/ROM, 4X DVD±R DL, 5X DVD-RAM, 24X CD-R/RW/ROM discs

Modem Integrated V.92 56K modem

Network 10/100 Ethernet LAN

802.11a/b/g wireless LAN

Memory card reader 5-in-1


* Memory Stick®

* Memory Stick Pro®

* Multimedia Card™

* Secure Digital™

* XD


MiniSD and RS-MMC (when used with adapter that is supplied with card)



* Four - USB 2.0 ports

* One - VGA port

* Microphone jack

* Headphone jack

* RJ-45 port

* RJ-11 port

* One - Kensington lock slot

* Power input


Pointing device Touchpad with vertical scroll zone

Expansion Slot Expresscard™ Type 54

Battery 6-cell Lithium-ion

Dimensions 1.31 to 1.40-inches (H) × 14.09-inches (W) × 10.39-inches (D)

33 to 36 mm (H) × 330 mm (W) × 264 mm (D)

Link to comment
Share on other sites

try this, AppleACPIPlatform.kext remember to backup the kext before replacing


If there is a ACPIPS2Nub.kext in the extensions directory move it but there is one in the AppleACPIPlatform.kext

It has given me touchpad with scroll



Link to comment
Share on other sites

I really think you are doing it wrong!?


There are TWO ACPIPS2Nub.kext files one resides in the Extensions directory and the other under /Contents/Plugins/ in the AppleACPIPlatform.kext also in the Extensions directory. They CANNOT exist together! You should remove both of them!


After removing the ACPIPS2Nub.kext from the AppleACPIPlatform.kext you need to repair the AppleACPIPlatform.kext (chown, chmod and clear kextcache and repair file permisions)

At this stage you should have and external mouse and keyboard, reboot and use Kext Helper to install just the ACPIPS2Nub.kext from the above link: http://forum.insanelymac.com/index.php?s=&...st&p=763013


You WILL have it working as we all use the same kext! the kext mentioned in the link is EXACTLY the same as the one in my AppleACPIPlatform.kext. It was just extracted and I like to keep the in their original state!




Link to comment
Share on other sites

I really think you are doing it wrong!?


You're probably right.


I just tried doing it the way you described and still nothing.


I think I'm going to start over with a fresh install.


Can you give me a quick step-by-step here with the command line input I would have to put in the terminal?

Link to comment
Share on other sites

And then from the fresh install I followed pretty well. removed the kexts, removed caches, chown, chmod, repaired permissions rebooted and installed the other kext, repaired permissions and everything, rebooted, still nothing, tried moving the PS2Nub to the ACPIPlatform, repaired. rebooted.


Still nothing.




I don't have a clue anymore, I guess I'll try a little bit again tomorrow if I'm in the mood.



Link to comment
Share on other sites

Ok, apparently I don't have an Extensions.kextcache file to remove anytime I try


Is that a problem?


Still can't get the keyboard.


If I break the trackpad I can usually get it back pretty well.






ApplePS2Keyboard: probe failed

ApplePS2Trackpad: Synaptics TouchPad 6.2


I really think you are doing it wrong!?


I don't think I am anymore.

Link to comment
Share on other sites

  • 2 months later...
hey just to let all you guys know not sure if you got it working or not... but i have an ml6720 and my keyboard and trackpad work beautifully from kexts available this is the link (chun-nan you are a genuis) so yeah try it i bet it will work for you!



Alright, after a long absence, I'm back. So, I'm definitely delighted to hear about this. So, just a quick review before I try this. Did you just install the kexts? or was there a deeper process to it?

Link to comment
Share on other sites

You need to use the fixed ps2controller.kext and his nub for proper support. I was the one whom he fixed it for originally. I have a gateway MT-6916. It seems Gateways laptop keyboards don't get detected properly, so he fixed the controller so that it will pass the probe check.

Link to comment
Share on other sites

  • 1 year later...

well since i can't find any support, or start a new topic, i'll post here.


i've tried kalyway, and iatkos, and neither gives me network, or keyboard.


i've tried every fix i can find, even though there are hundreds, and none have worked.


looking for any help to install os x on my laptop.


gateway 7818u

intel core2 duo t6400@2.00 ghz

code name penryn

motherboard intel 82801IM

keyboard ACPI\PNP0303\4

WIFI intel wifi link 5100 AGN

wired Marvell Yukon 8057b

Audio Conexant HD smartaudio 221

and Intel HD audio HDMI 8086


Been trying for 2 weeks, can get both to boot up, but no keyboard, no internet, no sound.


i hope theres someone out there that can help me.


thank you in advance.

dazed and confused.

Link to comment
Share on other sites


  • Create New...