Jump to content

Mouse Tearing Fix for GMA950 on iATKOS 2


12 posts in this topic

Recommended Posts






If you're having issues with your GMA950 graphics mouse tearing:


1. Install both packages

2. Repair disk permissions and restart.

3. Please report successes and failures and the OSX86/Hackintosh variant you're using. I'm using the iAtkos variant and it fixed my problems. I tried many different methods, but this is the one that did it for me. I hope this works out for you guys.

Link to comment
Share on other sites

i will check the installer, and see what is wrong in it, because i can see some preinstall and post install scripts and usually system involved changes requires root password, so i will check if there is any error in the pkgs, and fix it it if possible... :)

Link to comment
Share on other sites

Here is my device id


Intel GMA 950:


Chipset Model: GMA 950

Type: Display

Bus: Built-In

VRAM (Total): 64 MB of shared system memory

Vendor: Intel (0x8086)

Device ID: 0x27a2

Revision ID: 0x0003



Resolution: 1280 x 800

Depth: 32-bit Color

Built-In: Yes

Core Image: Hardware Accelerated

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Supported

Display Connector:

Status: No display connected

Link to comment
Share on other sites

Hey guys, original poster here, just to let you know that I installed these packages from within iAtkos using Pacifist (don't recall whether I mentioned this). Also, keep in mind that I installed the regular GMA950 package, repaired permissions, restarted, and then installed the second package, repaired permissions, then restarted.


Have you guys tried installing other versions of Leopard? If anybody fails, please be sure to (assuming you have access to a second computer) specify how you went about doing so.

Link to comment
Share on other sites

I ve tried all version of 10.5.2 best one for my system is iatkos v2 on dell 640m.

When I install kexts I use kexthelper easy install because it makes a backup so when I cannot boot I either use leo install on usb disk or I boot to windows on other partition.

In windows I use macdrive.

I navigate to backup folder and put kext back in system/library/extensions folder then I reboot in safe mode and reinstall old kexts with kexthelper and reboot again and back to normal

Link to comment
Share on other sites


  • Create New...