Jump to content

Compaq F500 (GF596UA) os x 10.5 Broadcom 4311

15 posts in this topic

Recommended Posts


If you own a laptop with the Broadcom 4311 chipset and it is in a Mini PCIe slot (maybe others, IDK) and you cannot get it to work, no matter how much you beat on the keyboard, please try this experiment:


1> Boot your favorite OS X dvd (if these exist, I do not know where to get them)

2> Wait for the welcome screen to open

3> Open a Terminal window

4> If you do not see airport symbol in the upper right hand corner of the wait or stop now because it probably wont work.

5> Wait until your flag shows up next to the airport icon.

6> Once you see the flag, right click on the airport icon (I dont know if this step is really needed or not, I'm just reporting what has worked for me so far). Nothing should happen.

7> Left click on the airport icon

8> If your airport is not turned on, try and turn it on. If it wont start stop here

9> Choose "Join other Networks..."

10> At this point for me, wireless networks start to show in the drop-down list.

11> I choose my home network from the list, which is WPA-TKIP enabled

12> I enter the password

13> I am connected to the internet. Ping works, DNS lookups work, cant test HTTP because no browser I can find is functional (I.E. Installed) when the install is only this far along.


But for the life of me, I cannot get it to work under OS X once it is installed. Only when I boot from the install DVD.

The networkinterfaces.plist file shows


Non working airport line from default install :





Working airport IOPathMatch from OS X booted DVD:

"en3"@6,3 <- The device IOPathMatch differs significantly from what is on my installed copy of 10.5.2




Would this work right now, if I just changed the device path once OS X is installed? I'd love to tell you, but what made me discover this miracle was that my machine went down and it is still currently down. I posting this from my (dont hit me) PC.


So, Experiment, post your results here. Additionally, you may end up using the trackpad and the laptop keyboard even if you have a USB set attached externaly as I do. Something about the PS/2 keyboard controller used in our machines? If anyone knows anything about this, PM me, I'd love to have my machine running all the time instead of seizing until I press a key on the laptop keyboard or the power button. Also accepting help with my Nvidia go for anyone who can get me to 1280x800 even without QE/CI, I'd appreciate it.


Another thing I would like to mention, is I tried all the wiring tricks. I used to repair S-100 computers with an oscilliscope and a logic probe, so none of that frightens me.

But for the record,

Taping over Pin 20 did nothing

Bringing pin 20 high (3.3v) did nothing

Bringing pin 20 low (ground) disabled the card.

Bringing Pin 1 high did nothing

Bringing pin 1 low did nothing

Remember, these are for Mini PCIe cards, not Mini PCI.


So if it does work on your machine, then we can put to rest the idea that it is a hardware issue. Because on my machine, after 5 weeks of futzing with it, I at least have a clue as to what to do, and ample evidence, IMHO that at least as far as F500's and V6000's are concerned, there is no hardware issue involved. No wires or pieces of tape are needed. No different extensions, stock IOPCIFamily and IOPCCardFamily are all that are required. I do use ARt + MeDevils Nforce driver though for the motherboard


Here are my specs:

Leo4All 10.5.2v3 (If such a thing exists)

Compaq Presario F500 GF596UA

AMD TK-53 (dual core)

2GB Ram

80gb Hitachi SATA

1280x800 nvidia 6100 running at 1024x768


I will update this post again once I have my install working and I can check the POSSIBLE solution of just changing the IOpath in the networkinterfaces.plist file. If you test it before me and it works, by gosh POST IT NOW!



I did just try changing the IOPathMatch and it did not work. What DID get it working was installing AppleACPIPlatform.kext (1.0.3) and AppleAPIC (1.1.0) from the booted OSX /System/Library/Extensions folder and using kext helper to install them on my live version. Viola!

So now, I have Leo4Allv3 w/9.2.2 and the kext's above with ALL other kexts from the original install and now I have Mini-PCIe Broadcom 4311 working on my compaq.



P.S. Can a programmer figure out what happened to break Mini-PCIe support between the two kexts I replaced?



Kernel 9.2.2

No power management installed.

Experimenting with Macvidia 1.0.7, Nvidia EFI, NVInject 0.2.0c and Nvidia Kexts.


The "stuttering"/freezing that my machine had, was due to a power saving method implemented by the kernel. I blamed it on the keyboard because when the machine would hang, pressing a key on the keyboard would usually bring it back to life. for a short period of time. That is why in the hint above, I reccomended pressing the ctrl and alt keys to unstick the machine. My machine runs so much faster now and it never freezes. the kernel parameter I used is:

idlehalt=0 cpus=2

On my TK-53 those two kernel parms made a huge difference in performance. dunno about battery life. Interesting experiment might be to boot from CD with that flag. I think i am going to try that next.....

I also went back to the MeDevil NForce Test kext in place of the ARt+MeDevil NForce. Much better. All props to both of you for trying to make things better.

Now if someone would just get over it and fix nvinject for shared memory, i'd be rockin Would examining the code or BIOS for PCI/PCIE cards that use shared memory be of any help? I'll buy the card and send it to you so you can examine the bios for gods sake!

Forgive me if I am oversimplifying things. I'm probably just being a flaming troll asking questions like

Why exactly do shared memory cards present such an issue?

What happened to Mini PCIe support for laptops between 1.0.3 and 1.1.0?

I'll be back in a bit. I'm running out of Kerosene and I think I hear someone trying to cross my bridge.



No real need to, but I replaced IOPCIFamily and IOPCICardFamily with Chu-Nan's versions. Once again, all props 2 u my man.


***EDIT*** 07.20.2008

Lots of reports of keyboard and trackpad related issues.


Remove all other kext's in /System/Library/Extension with PS2 as part of the name. Use this to check for them:

ls -lR /System/Library/Extensions/* | grep PS2


Unzip and install this (use kext helper):



Link to comment
Share on other sites

I hope to god this will finaly fix my presario c500 mini pci e bcm4311. I WILL give it a try!





wait, what? I booted w/ iatkos 1.0r2 and there is no airport icon in upper right hand. What do I do? will it work?

I will test anyway.

Link to comment
Share on other sites

How stange this doesn't work for you? I have a Presario V6630 with the BCM4311 and it functions under air port perfectly! I'm using Leo4AllV3 and it is detected natively.


That is absolutely no help to you I know but if it makes you feel anybetter my display is the same and is stuck in 1024x768. Hard on the eyes!

Link to comment
Share on other sites

Did it hang when you left clicked on the airport icon? Did you just try the OSX boot exp first? If your machine appears to lock up when you left click on the airport icon (I know this sounds strange, but bear with me) press the crtl and alt keys, alternately, repeatedly. I think it has something to do with the keyboard controller on the compaq/hp machines.

Link to comment
Share on other sites

It worked for me!

I overwrote networkinterfaces.plist and those 2 kexts and rebooted.

Thanks for sharing the info!

As for having native resolution ( 1440x900 ) I removed the iondrvsupport.kext, installed the lastest nvinjectgo and then some kexts from macvidia project. I don't remember the exact steps, but I guess you cand easily find about it on some other posts. No QE/CI, but it's a lot better than before.. I still have a minor problem with the HDAudio ( only internal speakers working, no input, no SPDIF, no headphones output ). Everything else works out great.


Vista & Leo4Allv3 (custom) on HP Pavilion dv9428nr.

Link to comment
Share on other sites

See my posts about similar problems on the F730US. I've been working on getting that machine going for some time. All my experiences are listed.

Thanks spacklewoof for the heads up on the 'cpuidle=0 cpus=2' kernel parameters. Almost everything works on my machine now. Except for QE/CI on the nvidia go 6100.

Link to comment
Share on other sites

Sorry. I typed cpuidle=0 in my message - but tried idlehalt=0 on my machine. Helped the first few times - but things have gone back to their sttuttering state once again. I'm trying out some other kernel parameters. Will post back if I find something interesting.

Link to comment
Share on other sites

  • 1 month later...



Your fix worked on my HP pavillion dv6363eu, running Kalyway 10.5.2


I had to adapt the networkinterfaces.plist file you mentioned as mine was different


My new file (part of it)

<plist version="1.0">







<key>BSD Name</key>

















Link to comment
Share on other sites

  • 1 month later...

Hey spacklewoof, thanks for your intrepid debugging of this situation. I have a Compaq C500 laptop with the same BCM4311 miniPCIe card, and I could never get it to power on correctly after I installed the iATKOS 1.0i back in November. This give me hope once again, and I'll test it with the latest version of iATKOS.

Link to comment
Share on other sites


  • Create New...