Jump to content

Help required with Leo4All V3 10.5.2

18 posts in this topic

Recommended Posts

Hi guys,


I've tried several "distros" of Leopard so far, but have had no luck. I've come closest with Leo4AllV3 10.5.2. I have 2 hard drives and I formatted the second drive as an OS X drive. I was able to install it using the CPUS=1 flag, but when I try to boot from it, the bootloader hangs. It hangs at the following point "MAC Framework successfully initialized using 15728 buffer headers and 4096 cluster IO buffer headers"


Any thoughts on how I can rectifiy this? I've previously tried installing iATKOS 1.0ir2, Kalyway 10.5.2, and Leo4Allv2. This is the only time I was able to successfuly complete the installation process.


Would Leo4Allv3 be the best build for my system? I plan to dual boot with Vista Home, but I'll use two seperate hard drives rather than partitioning a single drive for simplicity. Are there certain options I should or should not select during install that might help?


I have a HP Pavilion M9150f with the following specs:


Core 2 Quad Q6600 (K) 2.4 GHz (95W)

  • 1066 MHz front side bus
  • Socket 775


Intel G33 Express



Manufacturer: Asus

Motherboard Name: IPIBL-LBHP/Compaq motherboard name: Benicia-GL8E




3GB PC-5300 667MHz Hard Drive:

720 GB (2 x 360) SATA 3G (3.0 Gb/sec)


Optical Drive 1:

16x Dual Layer DVD+/- RW with LightScribe

Optical Drive 2:

2.4x HD DVD-ROM drive


Wireless LAN 802.11 b/g


256MB DDR2 nVidia GeForce 8500GT

Hauppage TV tuner card with FM tuner


Integrated High Definition Audio:

Realtek ALC 888S chipset


Integrated 10/100/1000 Base-T networking interface


15-In-One Memory Card Reader


Firewire and USB 2.0 ports

HP wireless USB keyboard and Mouse

USB infrared remote

Link to comment
Share on other sites

When you install, check the "old ACPIPlatform" option. If you already have it installed use Linux or MacDrive and just get a copy of AppleACPIPlatform.kext off of a JaS 10.4.8 release or extract it from the package on the Leo4All disk. Also, try to keep as much default settings as possible (use the default kernel).

Link to comment
Share on other sites

Hi guys,


Thanks for the advice. Still no luck though. I have my drive formatted as a MBR drive, tried installing using the vanilla 9.2.2 install with Old ACPI platform and used the remove firewire kext as well. Again, the install went normally, but when trying to boot from the drive it fails unless I use cpus=1. If I do that, it gets a little bit further, it gets to a point where it says Darwin kernel 9.2.2 and then just a white cursor and it quits loading.


Any other thoughts?


I changed my BIOS settings for the drives to AHCI as well, in case you're wondering.

Link to comment
Share on other sites



ahci can work with windows easily if you search on google "enable ahci mode after installing windows"





Reinstall windows with AHCI on, takes longer though

Link to comment
Share on other sites

Anyone have any other advice for me? I'd love to get this working. I've seen in the wiki others with similar hardware have gotten this to work. There must be something I'm missing.


Is Tiger more likely to work? I can try that to see if there's any difference.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Toaster, did you ever solve this issue (seems like from other posts, you eventually got it at least booting)? I have the same specs, and am having the same problem -- getting stuck at "MAC Framework successfully initialized, using 2621 buffer headers and 2621 cluster IO buffer headers".



Link to comment
Share on other sites

  • 1 month later...

I have a hp m8430f and the only way i was able to install it was with the kalyway 10.5.1 disk using the cpus=1 command. Oh and when your installing it you have to select the sse3 option. so far i have had to use the cpus=1 command everytime i wanna boot up to osx and i'm having trouble getting my ethernet card working. anyone have any ideas on that? oh and my comp would freeze on reboot everytime untill i removed my graphics card...i have the 8500gt w/ 512mb. oh for sound i never figured out which one of the options would work i just checked them all and apartly one them worked.


HP m8430f

Q6600 Core 2 Duo Quad 2.4ghz

4gigs ram

Geforece 8500gt

Link to comment
Share on other sites


  • Create New...