Jump to content

OSX on Compaq Presario F7xx series laptops

34 posts in this topic

Recommended Posts

@dude998866 - Try booting with the flag -v and see if the AppleNForceATA.kext is giving any messages. On my laptop, the driver gives messages like :-

AppleNForceATA: NVIDIA nForce MCP 51 Serial ATA by MeDevil (CMD 0x30c0, CTR 0x30b4, IRQ 23, BM 0x3090)


You can also open a terminal window and type 'kextstat | grep AppleNfForceATA' to check if the driver is loaded. Also, use the disk utility to prepare your hfsplus partition before you move on to installing OSX. If the driver is loaded - you should see the disk in disk utility.


@thinkbrown : To install PC_EFI on a Linux Machine


1. Copy boot_v8 to the /boot directory

2. Make an entry in grub as follows :-

title Leopard

root (hd0,5) ----> your linux partition with the /boot/boot_v8 file

kernel /boot/boot_v8



If you're using a GUID OSX only system (instructions from PC_EFI v8 readme.txt)

1. Create directory 'iamefi' in the root folder of osx boot disk

2. Copy all included files (in PC_EFI.zip) to this directory (iamefi)

3. Boot into single user mode using F8 followed by -s on boot up

4. Enter following commands :-

a) mount -uw /

b ) cd /iamefi

c) ./startupfiletool /dev/rdiskXsX ./boot_v8 -----> rdiskXsX is the OSX partition OSX style

d) reboot


You should have EFI working.

Link to comment
Share on other sites

  • 2 weeks later...

Thanks for a great thread c_c! I have used most of the fixes you have found/documented with my HP Pavilion dv6110us. Most of the "fixes" worked perfectly, especially the boot flags. The scroll pad fix did not work, but deleting the trackpad kext did the trick. The trackpad is adjustable in the mouse options.


I too have painstakingly documented a detailed install with fixes for the AMD dv6000 series found here:


AMD dv6000 series install

Link to comment
Share on other sites

  • 2 months later...
Updated 10.5.4

Need System.kext from 10.5.2 and Dock.app from 10.5.3. See below for details.



It seems like my earlier post on this topic has disappeared. Seeing that there has been some interest from other posters with this machine I thought I'll re-post an updated status.


This machine has the following hardware :-


1. Processor - AMD Athlon TK-55 works :)

2. SATA HDD - Works with MeDevils nForce SATA driver (check signature). 1 in 10 boot halt at 'waiting for root device'. Half the time pressing the power button causes immediate detection of the drive. (Problem resolved after 10.5.3)

3. DVD Drive PATA - works with and older MeDevil driver. (SAM Mutimedia error with the latest version)

4. USB - works fine with 10.5.3 (if usb drives are not detected 'kextload IOUSBMassController.kext')

5. Sound - Works fine OOB without the ApplePS2Controller.kext loaded. Stutters otherwise. (Resolved with idlehalt=0 cpus=2)

6. Display - GeForce Go 6100 - Managed to get it working at 1280x800 [credit goes to andy.karpov]

(Delete/Move Geforce*.kext, NV*.kext.

Install MacVidia 1.0.81; don't restart; open terminal;

type 'sudo mkdir/NVBackup'

type 'sudo mv /System/Library/Extensions/NV*.bundle /NVBackup'

then type 'sudo mv /System/Library/Extensions/NV*.plugin /NVBackup'

restart - open display properties and get 1280x800.)


7. WiFi - Broadcom 94311 rev 2. Works OOB with 10.5.2. Still working with 10.5.3

8. Touchpad/Keyboard - The biggest grouse. See Below.

9. Ethernet MCP51 - forcedeth-nockd.kext seems to work. Hangs with large downloads.

10. Power Management - Can get battery icon and the estimated %age. Credit to Tom007. No Time.


(Download this and unstuff it into the desktop, which should yield a PowerManagement.bundle. Open /System/Library/SystemConfiguration. Delete the existing one first, then copy in the new one. Open Terminal and run 'chown -R root:wheel /System/Library/SystemConfiguration/PowerManagement.bundle'


Then Reboot. After rebooting, MacOS X (at least Leopard 10.5.1) recognizes you're on a laptop and will display a battery indicator in the top menu bar after you enable it under the options tab of Energy Saver)

Keyboard / Trackpad Status (Updated) After the 10.5.3 update - I had problems getting either to work till I restored the 10.5.2 USBFamily.kext. Now, the Trackpad and Keyboard work fine - but I need to keep a USB device plugged in on the right hand side USB slot during startup for the keyboard and trackpad to get detected. I'm using PC_EFI v8 with ACPIPS2Nub and ApplePS2Controller.


The kernel flags 'idelhalt=0 cpus=2' have resolved the sound stuttering problem I had when the ps2 controller kexts were loaded.


I request feedback on the various experiments people may have tried to get their keyboards / trackpad working. Maybe we'll get a clue to what's the real problem then.


I am also using Fedora Core 9 on this machine. Works with 'noapic irqpoll' except video hardware acceleration (waiting for X 1.5). But, the keyboard and trackpad work perfectly.


So, essentially there are two things that don't work well as of now :- QE/CI on GeForce Go 6100 (which according to some people will not happen) and internal Keyboard/Trackpad which need more work before they're reliable and don't impact anything else.


Of course - sleep and hibernate are a no go till now. Any Ideas?


The above bolded items is the ONLY thing I found all day that fixed my onboard 6150 LE card. Works great now :) Thanks

Link to comment
Share on other sites

  • 4 months later...

Hi guys and gals,


I currently own a Compaq presario F700. As you know it has:


Processor, operating system and memory

Processor type Mobile AMD Sempron™ Processor 3600+

• , Level 2 cache 256 KB, Up to 1600 MHz system bus running at AC/DC Mode 25 Watt

Memory layout (2 x 2048 MB)

Internal storage 120 GB

Hard disk controller SATA Hard Disk Drive

Optical drive type Super Multi DVD Writer (+/-R +/-RW) with Double Layer support

System features

Modem High speed 56K modem

Network interface Ethernet 10/100BT integrated network interface

Wireless technologies 802.11b/g WLAN

Display resolution

1280 x 800

Video RAM

Up to 335 MB Total Available Graphics Memory

Internal audio

3D Sound Blaster Pro compatible sound 16 bit integrated

Pointing device

Touch Pad with On/Off button and dedicated vertical Scroll Up/Down pad, volume control, mute button


I have been trying to install Iatkos v4a for a while now and have not been able to get it installed on the internal HDD. I was able to get it installed on an external HDD, but it is still missing a whole lot of drivers and the sound, network and other things don't work or at the very least don't work the way they should.


I am completely new to OSX and these types of installs so, I apologize right of the bat if I sound like a total Noob, but it may be because I am... Any help or ideas on how to go about doing this the easy way will be greatly appreciated.





Link to comment
Share on other sites

  • 2 weeks later...
What video drivers are you using? I can't get any to work.




I didn't selected any drivers. I just did the install and it took. I'm still missing some of the other drivers and to be honest, I formatted again and went to windows 7 Beta since I wasn't able to get the wifi or the internal drive to work. You know I am not about to mess up the portability of a laptop by having to drag an external HDD everywhere I go. I guess I'll wait until someone does a simple step by step guide for this computer or a disk that has all that we need to get it running properly. Meanwhile, I'm a PC! I know... Ironic, isn't it?

Link to comment
Share on other sites

  • 1 month later...
Quick update: I booted back into my Leo4allv3 DVD and obtained Broadcom.pkg, AzaliaAudio.pkg, and Forcedeth-V.pkg from the Installer folder. Then I booted back into my HDD install of Leopard and found the kexts inside these pkgs.. loaded them with KextHelper (comes with Leo4allv3) and voila! Sound worked instantly, wireless worked after a restart. I'm not sure if ethernet works yet as I have no way to try it but even if it doesn't I think it might be causing the wireless interface to grab the right interface name, so I'll leave it be.


Now if only there were a more efficient way of booting this sucker instead of just idlehalt=0 cpus=2.. this fan running 24/7 is kind of ticking me off, usually a quiet laptop.. let me know how you make out guys.

Can you send me the forcedeth.pkg?

Link to comment
Share on other sites

Can you send me the forcedeth.pkg?


What laptop do you have and what distro? If you have a Presario F7xx (which I assume you do) you can use the kexts I've used. I have chipset, ethernet, and sound working. The only problems I've had are with graphics. You can find the post here. I have only tested them with iAtkos v4a but other distros should work.


Also do you have graphics working? If so, could you tell me how to do it?



Link to comment
Share on other sites


  • Create New...