Jump to content

OSX on Compaq Presario F7xx series laptops

34 posts in this topic

Recommended Posts

Updated 10.5.4

Need System.kext from 10.5.2 and Dock.app from 10.5.3. See below for details.



It seems like my earlier post on this topic has disappeared. Seeing that there has been some interest from other posters with this machine I thought I'll re-post an updated status.


This machine has the following hardware :-


1. Processor - AMD Athlon TK-55 works :P

2. SATA HDD - Works with MeDevils nForce SATA driver (check signature). 1 in 10 boot halt at 'waiting for root device'. Half the time pressing the power button causes immediate detection of the drive. (Problem resolved after 10.5.3)

3. DVD Drive PATA - works with and older MeDevil driver. (SAM Mutimedia error with the latest version)

4. USB - works fine with 10.5.3 (if usb drives are not detected 'kextload IOUSBMassController.kext')

5. Sound - Works fine OOB without the ApplePS2Controller.kext loaded. Stutters otherwise. (Resolved with idlehalt=0 cpus=2)

6. Display - GeForce Go 6100 - Managed to get it working at 1280x800 [credit goes to andy.karpov]


(Delete/Move Geforce*.kext, NV*.kext.

Install MacVidia 1.0.81; don't restart; open terminal;

type 'sudo mkdir/NVBackup'

type 'sudo mv /System/Library/Extensions/NV*.bundle /NVBackup'

then type 'sudo mv /System/Library/Extensions/NV*.plugin /NVBackup'

restart - open display properties and get 1280x800.)


7. WiFi - Broadcom 94311 rev 2. Works OOB with 10.5.2. Still working with 10.5.3

8. Touchpad/Keyboard - The biggest grouse. See Below.

9. Ethernet MCP51 - forcedeth-nockd.kext seems to work. Hangs with large downloads.

10. Power Management - Can get battery icon and the estimated %age. Credit to Tom007. No Time.


(Download this and unstuff it into the desktop, which should yield a PowerManagement.bundle. Open /System/Library/SystemConfiguration. Delete the existing one first, then copy in the new one. Open Terminal and run 'chown -R root:wheel /System/Library/SystemConfiguration/PowerManagement.bundle'


Then Reboot. After rebooting, MacOS X (at least Leopard 10.5.1) recognizes you're on a laptop and will display a battery indicator in the top menu bar after you enable it under the options tab of Energy Saver)

Keyboard / Trackpad Status (Updated) After the 10.5.3 update - I had problems getting either to work till I restored the 10.5.2 USBFamily.kext. Now, the Trackpad and Keyboard work fine - but I need to keep a USB device plugged in on the right hand side USB slot during startup for the keyboard and trackpad to get detected. I'm using PC_EFI v8 with ACPIPS2Nub and ApplePS2Controller.


The kernel flags 'idelhalt=0 cpus=2' have resolved the sound stuttering problem I had when the ps2 controller kexts were loaded.


I request feedback on the various experiments people may have tried to get their keyboards / trackpad working. Maybe we'll get a clue to what's the real problem then.


I am also using Fedora Core 9 on this machine. Works with 'noapic irqpoll' except video hardware acceleration (waiting for X 1.5). But, the keyboard and trackpad work perfectly.


So, essentially there are two things that don't work well as of now :- QE/CI on GeForce Go 6100 (which according to some people will not happen) and internal Keyboard/Trackpad which need more work before they're reliable and don't impact anything else.


Of course - sleep and hibernate are a no go till now. Any Ideas?

Link to comment
Share on other sites

  • 5 weeks later...

Well, martguy bought this post by spacklewoof with the following kernel parameters 'idlehalt=0 cpu=2' to my notice. Well, after all the experimenting I've done - seems like this was just about the only thing that I missed.

These parameters really boost my machines performance. No more stuttering, smooth audio and a far more responsive machine than it has ever been. Great !! Thanks maryguy and spacklewoof.


Another surprising development is that with these kernel parameters and any usb device plugged into the right USB port, the PS/2 keyboard and mouse seem to work fine. Haven't yet had a problem after 5 reboots. Will update this if I do have problems now.


The linked post has some discussions on getting the PCIE 94311 rev2 broadcom wifi chip working. For me, things started working automatically after the 10.5.2 update. Didn't have to do anything special.


Hope this helps.

Link to comment
Share on other sites

Sure. We need more people trying things out to get this (and similar machines) working properly.


I have some bad news though - the stuttering is back even with the kernel parameters. But - thats one method that needs more exploring. Will post results after I try some more things.

Link to comment
Share on other sites

  • 3 weeks later...

c_c, thank god I found this post. You just got me up and running in native resolution on my HP Pavilion dv6404, and I was about to give up. I get some minor tearing whenever I open the Displays preferences.. does this happen to you? It seems that a second display is active @ 1024x768 (i.e. it thinks I have a second display connected perhaps) and maybe this is what is straining it..


Also, I can confirm that idlehalt=0 and cpus=2 drastically improved my boot time from 6min+ to under 2min..


Now I just need to get sound (Azalia perhaps), ethernet (forcedeth) and wireless (bcm4311) working.. I'll try and follow the same route you did.

Link to comment
Share on other sites

Quick update: I booted back into my Leo4allv3 DVD and obtained Broadcom.pkg, AzaliaAudio.pkg, and Forcedeth-V.pkg from the Installer folder. Then I booted back into my HDD install of Leopard and found the kexts inside these pkgs.. loaded them with KextHelper (comes with Leo4allv3) and voila! Sound worked instantly, wireless worked after a restart. I'm not sure if ethernet works yet as I have no way to try it but even if it doesn't I think it might be causing the wireless interface to grab the right interface name, so I'll leave it be.


Now if only there were a more efficient way of booting this sucker instead of just idlehalt=0 cpus=2.. this fan running 24/7 is kind of ticking me off, usually a quiet laptop.. let me know how you make out guys.

Link to comment
Share on other sites

@edgevision - You're welcome.


I had this problem 'It seems that a second display is active @ 1024x768'. I don't remember how I resolved it - but I think it had to do with some other kexts. Try renaming all the GeForce*.kext. NVDA*.kext and IONV*.kext to .kext.bak and reboot with -f. This might solve your problem.


I think that the fact that we need the 'idlehalt=0 cpus=2' kernel parameters on startup indicates that the power management functions on these laptops are not properly supported. It could also be that the ACPIPlatform kexts need to be suitably modified or the BIOS itself needs correction.


I've been trying to look at the differences in the ACPI devices found under Linux and those under MacOSX and it seems to me that linux finds a cooling device. I can't seem to find anything like that under MacOSX. But then - I'm a noob to Mac's - and don't know a lot. Maybe someone with more experience can point us in the right direction.


Also can you post the 'Forcedeth-V.pkg' here? I would like to try it to see if it works.



I tried to upgrade to 10.5.3 using the netkas method. The installer hung and broke my install - so I had to reinstall using brazilmac 10.5 and upgrade to 10.5.3. Managed to do an upgrade after doing the following :-

ran the following scripts in different terminals

1. 'while sleep 1; do rm -rf AppleIntelCPUPowerManagement.kext; done'

2. 'while sleep 1; do mv GeForce.kext GeForce.kext.1053; done'

on completion of the upgrade edited the script '1' to dsmos.kext and rebooted.


Have managed to get to the login screen with 10.5.3 showing.



The major difference is that my keyboard and trackpad don't work anymore. ACPIPS2nub loads up and finds a keyboard and mouse. But - If i include the ApplePS2Controller.kext the laptop hangs without getting to the GUI. Without the ApplePS2Controller.kext - I can get to the GUI. So it seems that something has changed in 10.5.3 that is not allowing the PS2 controller to work. Still trying out older versions of various kexts to see what makes this work. Am using the 9.2.2 kernel.


If anyone has any hints - do point me in the right direction

Link to comment
Share on other sites

Well - Out of desperation I deleted my entire 10.5.3 Extensions folder and copied from a backup of the 10.5.2 Extensions folder.


Surprise - the Keyboard and mouse are now working fine!


So - there are some extensions that have changed in 10.5.3 which are not allowing the ps2 controller to work properly.Haven't figured out which one's though.

I had already replaced the 10.5.3 versions of AppleACPIPlatform, AppleSMBios and System .kext's with the 10.5.2 versions. But there is something else ............


Any Ideas??


Thanks to heXane for showing the way to get sidebar scrolling going on Synaptics Touchpads.

To get your synaptic touchpad's scroll sidebar to work do this


edit '/System/Library/Extensions/ApplePS2Controller.kext/Plugins/ApplePS2Trackpad.kext/info.plist


change the file to

<key>Synaptics TouchPad</key>

<dict> <key>CFBundleIdentifier</key>







<string>PS2MouseDevice</string> </dict>


restart with -v -f


Your trackpad should support scrolling now.

Link to comment
Share on other sites

OK. Problem Solved.

It should have been obvious from the beginning. Anyway - restore the 10.5.2 IOUSBFamily.kext to the 10.5.3 Extensions folder (including the required version of AppleSMBios, AppleACPIPlatform and System.kext) and the keyboard and trackpad start working again with the remaining 10.5.3 extensions.


Hope that helps.

Link to comment
Share on other sites

c_c, thanks for the tips re: the trackpad in 10.5.3, the scrolling fix, and the display issues. I'll probably try to fix the scrolling and the display tearing tonight and then I'll do 10.5.3 update sometime over the course of the week.. a bit scared to update this beast after all I've been through to get to this point, but with a trailblazer like you on the job it doesn't sound like I need much worrying, does it? :)


Before I go ahead with it though, I'd like to look into imaging tools for HFS+ volumes.. I typically use partimage for everything but it has experimental support for HFS and (as far as I know) no support for HFS+, so it's out. Any takers?


Also: does your machine start up into OS X when it's on battery? I think it's related to the ACPI issues, but mine hangs on boot unless I'm plugged in..


I'll keep this thread posted with test results tonight.


Here's the Forcedeth-V.pkg.


Link to comment
Share on other sites



Thanks for the forcedeth package. Will try it and post results.


I replicated the second display phenomenon and I can confirm that it is because one of the NVDANVx0.kext is finding a display differently from the MacVidia driver. Rename all of them to NVDANVx0.kext.bak and the problem disappears. You'll also notice (with -v) that you get Matching Service Count = 0 once you do this. Otherwise you should be getting Matching Service count = 1.


I keep an Install disk bootable partition as backup to install from in case things go wrong. Haven't looked at imaging tools yet.

I've never had a problem starting up on battery. What messages does you machine give ?

I do have problems with sleep and suspend in that they've basically never worked for me. Seems like this machine is not willing to give up yet !


10.5.3 seems to have improved the performance significantly. The system is more responsive, stable and fast. I would recommend the upgrade - once you're settled and comfortable.

Link to comment
Share on other sites

Well, the forcedeth-V package didn't help.


Seems like the forcedeth-nokcd is the best bet till now. It connects at least - and seems to work fine for most of the time. It used to hang the machine in the past - but surprisingly after the 10.5.3 update - this seems to be stable. So - I'm using this kext now and things are working fine.

Link to comment
Share on other sites

I'll keep that information in mind re: forcedeth-nockd.


As for my NVIDIA drivers.. the only kexts I have loaded are NVDriver.kext and NVidia.kext, they both came with the MacVidia driver package.. I don't have anything else with an NV or GeForce prefix. I know there are other display drivers present though, such as the IntelGMAX3100.. I removed those but there may be more. I guess I'll have to poke around. I have a feeling much of the choppiness will be resolved once this part is fixed. Is there some way I can tell which graphics kexts are loaded?


How did you go about upgrading to 10.5.3? Was it netkas that did the job properly? I'm just curious as to the best way to do it. Still haven't found anything for backing this partition up and I really don't want to lose the progress I've made.


Also, it would be really nice to not have this fan running so loud (i.e. not boot with idlehalt=0).. if there's anything I can try out, let me know.


Update: removed IONDRVSupport.kext and the second display went away. ;)

Link to comment
Share on other sites

Sorry - I forgot to mention that IONDRVSupport needs to be removed too.


The most appropriate method I can recommed to update to 10.5.3 is as follows :-


1. Download the 10.5.3 combo update

2. Use Pacifist to extract the combo update to a folder on the desktop

3. Use Mavins AMD patch utility to generate the patches / decrypt files

4. modify the cpuid.txt / decrypt file to change the path from the desktop to the root directory

5. You need to have the GeForce.kext in the /S/L/E's directory else the update stops with an error

6. Modify the GeForce.kext's Info.plist. Under IOPCIMatch delete all the values and leave only one value that does not match your video card. For eg I used 0x0244710de as the only value while my video card is 0x024710de.

7. Create a directory called plist under the root directory. Copy this edited Info.plist file there.

8. run the following script 'while sleep 1; do cp /plist/Info.plist /System/Library/Extensions/GeForce.kext/Contents ; done' in a terminal as super user.

9. run the following script 'while sleep 1; do rm -rf AppleIntelCPUPowerManagement.kext; done' in a second terminal as super user

10. Backup your kernel, system.kext, AppleACPIPlatform.kext and IOUSBFamily.kext.

11. Run the combo update.

12. After the update - DO NOT REBOOT. Run the patcher and apply decrypts from a terminal as super user.

13. Restore the kernel and your kexts.

14. Rename GeForce.kext to GeForce.kext.post.

15. Reboot with -s

16. Reapply the decrypts and the patches.

17. Reboot


You should have a working 10.5.3 install now. Let me know if you run into something new.

Link to comment
Share on other sites

Well, I've updated to 10.5.4 and I must say that it's been the easiest of all the updates till now. I used the modify option in Zpphyroth's AMD Software update.

Of course - I had to use System.kext from 10.5.2 to keep the Trackpad and Keyboard working.

Also, the Dock.app needs to be backed up from 10.5.3 and replaced - which is weird - 'cause the Dock hasn't given problems till now.

The kernel and the ctfsys files need to be replaced too.

I haven't tried the modbin 10.5.4 kernel - so that could change some things. Will try that and post results too.

I can't feel any difference, though, from 10.5.3. Maybe something will show up after some use.

Link to comment
Share on other sites

  • 2 weeks later...

Ok, I have a F756CA and am going half insane trying to get this to work. I tried it with the Kalyway disk and added the hardware ID's to the VIAATA.kext. This got it to recognize the hard drive, but, as soon as I went to format the second partition I have it kept freezing and then the screen became garbled......

So if you could post the specific steps you've fallowed so far to get to work. I know I'm not the only one trying to get this laptop ot work so a set of step by step instiltions for it would be absolutly wonderful.

Link to comment
Share on other sites

If you have a nForce chipset - you chould be using MeDevil's AppleNForceATA.kext to get your SATA HDD recognised. I'm not sure if Kalyway has this kext in it. Please check - you might need to select it to install.


Hope this helps.

Link to comment
Share on other sites

I've tried adding medevils driver to my iso along with other SATA drivers. I have also added my HD ID to the appleviaata.kext. This got it to rrecgnise my drive. However it would freeze as soon as I tried to format it. What should I try next.

Link to comment
Share on other sites

Add MeDevils driver to the IOATAFaimly.kext/Contents/Plugins folder Add you sata controllers id to the Info.plist if it is not already there. Remove the Viaata driver for now. Boot with -v and see what messages the driver is showing - and which driver is seeing your sata drive. Post the messages.

Link to comment
Share on other sites

Dude, use a disc with better support for AMD. Leo4allv3 is a safe bet. There isn't much of a process to it really, the installer either works or it doesn't, and then afterward that's where this thread becomes very handy. I could never get Kalyway to work.

Link to comment
Share on other sites

Ok, I downloaded medevils driver and modified it so that it contained my hardware ID's. Then I used Kalyway's script to add it to the dvd..... The installer see's my DVD driver but not my hard drive. I did not see any error messages apon booting. What should I try next.

Link to comment
Share on other sites


  • Create New...