Jump to content

1 Screenshot

About This File

AMD Radeon GPU pack is a post-installation tool specifically designed for Clover boot loader. The tool contains patches and injectors for various AMD Radeon graphic cards, but also additional plugins for MacPro3,1 and MacPro6,1 SMBIOS specifications and Sandy Bridge CPU-s.

 

Screen%20Shot%202015-06-26%20at%2015.17.48_zpssnjoggdp.png

How it works:

The tool will add just a few FB code lines for proper GPU activation in Clover config.plist file (ATI Connectors Data, ATI Connectors Patch & ATI Connectors Controller).

• Be advised that patches depend on card manufacturers.

The list of patches and injectors are based on certain GPU models and extracted ROM files from them.

• Injectors from this tool will work on most models, but not on all of them.

That’s because certain GPU cards from the same series using the slightly different firmware.

 

Injectors & patches:

 

AMD Radeon HD 6450 (device id - 0x6779)

AMD Radeon HD 6790 (device id - 0x673E)

AMD Radeon HD 6850 (device id - 0x6739)

AMD Radeon HD 6870 (device id - 0x6738)

AMD Radeon HD 7730 (device id - 0x6837)

AMD Radeon HD 7870 (device id - 0x6818)

AMD Radeon R9 270 (device id - 0x6811)

AMD Radeon R9 270X (device id - 0x6810)

AMD Radeon R9 280X (device id - 0x6798)

AMD Radeon R9 290X (device id - 0x67B0)


What's New in Version 1.3   See changelog

Released

  • v1.3 - Verde.kext for HD7730
  • v1.2 - HD7730 patch update
  • v1.1 - Clover UEFI support
  • v1.0 - Clover Legacy support



User Feedback

Recommended Comments

Not all GPUs have the same Sense ID and ports, considering OEMs just like to bash other things in. I think you should state things clear in your tool's desciption that which GPUs of which OEMs that is tested with your tool

Share this comment


Link to comment
Share on other sites

@chris1111

 

That's correct, this pack is for Legacy Clover solution. I will add EFI solution in the pack very soon...

 

[EDIT]

 

It is done. UEFI solution is imported in the pack.

Share this comment


Link to comment
Share on other sites

Well, yes… for many GPU models that is mandatory solution. On the other hand, for some that is a more cosmetically trick, which can resolve wrong GPU signing. Anyway, you can’t lose anything if you try this, because the patch is adding only a few lines in Clover config which you can always manually remove, if something goes wrong!

 

That’s the whole beauty of this patching technique. ;)

Share this comment


Link to comment
Share on other sites

hello Vlada,

do you pls add support for  AMD Radeon HD HD3870x2 (device id - 0x950F)

i couldnt find any other solution for my card.. alternative ways didnt worked for me.

 

it shows only 5M of shadow bios memory, i couldnt access rest of 1024MB.

 

(OsX Maverics 10.9.1 base + AMD kernel 10.9.4 [XNU:13.3.0] V1.0)

 

i can give furter details if you need.

Share this comment


Link to comment
Share on other sites

Well, the real support gives Apple not me, and since they didn’t do that you have a problem. In short, I think that this procedure will not work in your case. As far as I can remember, I had 3870 and it didn’t work. I replace that card with NV GTX275.

 

Although, that was the time when we didn’t have Clover. So you should try to insert fake-id 0x95011002 in ATI field and hope the best.

Share this comment


Link to comment
Share on other sites

WARNING! I installed this tool for my 280x, and now my OS won't boot. After I select the drive in the clover boot screen, it gives me some osxaptipfixdrv error, and ends in "boot failed, sleeping for 10 seconds before exiting". This broke my install. This is what happened.

 

I have a 4790k, z97 Pro Wifi ac, 280x, with yosemite 10.10.4. Since I made this build with clover, it had been running perfect for months and months. Today, I mistakenly decided to install this tool despite everything running smooth in the hopes that it would somehow make things run even smoother. I ran the installer/tool, checked my card in the box, and the repair permissions box, and installed. After i rebooted, it started giving me "osxaptiofix allocation reallocation etc etc.....boot failed, sleeping for 10 seconds before exiting" crashes when i tried to boot with clover. Things i tried that did nothing

1. I unchecked "inject ati" in the clover bootmenu settings.

2. Tried 20 other combinations of clover boot menu settings.

3. Tried safe mode.

4. Tried running with the backup config file from the boot menu.

 

All of these gave me the same error. I dont know what it broke, but even using the backup config that had been working for months gave me this new error. I then booted into my windows 8 drive and then spent an hour figuring out how to make a clover usb stick from windows. After making it, i learned that i couldnt use it since it was not uefi, but mb3, and so it didnt even see my Mac drive in the boot menu. Then i had to spend another 2 hours learning how to created and mount EFI partitions inside windows 8. Finally, i wanted to try to switch some of the drivers64 files in the clover folder. I then learned that the clover stick i made in windows 8 did not have aptiofix2, which is the one that i wanted to switch out. Then i spent an hour trying to see if that file was available as a standalone download, until i went into the chatroom and someone gave it to me. I went into command prompt, launched diskpart, mounted the efi partition again, relaunched windows explorer, and switched out the old aptiofix file with the new one. After rebooting, my computer wouldnt get past the first bios screen. I restarted like 20 times, and nothing. I unplugged all my usb devices, and unplugged the power cord for a minute, and rebooted, and nothing. I finally took apart my computer (took out the video card, 2 pcie devices, all my hard drives (about 5), and all my ram. Finally the bios booted past the screen to the screen that said i was missing drives and keyboards and such. I then installed one ram stick and rebooted, installed one drive, rebooted, etc until everything was back in and booting past the bios screen. I finally booted into yosemite again. Out of curiosity i put back the config file that the tool had modified. I rebooted, and didnt get the aptiofix error, but i got a black screen. I then rebooted and booted into the old config file, and then had to spend 3 hours sorting out my pcie device arrangement since they are very finnicky about going on specific pcie slots in a specific order (multiple blackmagic intensity cards). In all, it probably took about 5-6 hours of my time just to wind up back where i was, and i still have a system profiler that calls my 280x a 7000 series. Its not impossible that it was a coincidence, but i doubt it was. I wonder what went wrong with mine, or why it broke my aptiofix drive if all it did was modify a config file.

Share this comment


Link to comment
Share on other sites

Heh, only God knows what happens in your case, but I seriously doubt that only this tool is responsible for your problem! 

Share this comment


Link to comment
Share on other sites

Hi Vlada, sorry to bother you but the Sandy PM fix doesn't work anymore in El Capitan. It looks like it fails to patch the Mac-F60DEB81FF30ACF6.plist file, so it ends up being a half done fix causing shutdown issues in my case. 

 

Can you take a look at the problem? I can send you the new files if you don't have 10.11 yet.

Share this comment


Link to comment
Share on other sites

Hi. When I install this with a gigabyte radeon r9 270 oc i get stuck after typing password (spinning wheel). What could it be?

Thanks,

blue

Share this comment


Link to comment
Share on other sites

Thank you for this nice tool!

I tried to patch it myself but now i finally got my MSI R9 390x working with 2xDVI using the 'R9 290x' configuration.

Share this comment


Link to comment
Share on other sites

The FB code is changed (again), so the tool doesn't work properly under El Capitan. This is AMD specific issue, it'll take time until we resolve that one. 

Share this comment


Link to comment
Share on other sites

This tool saved my Sapphire Radeon HD 7730 1GB DDR5! Thanks a lot! ==> it works on El Capitan!

 

Anyway, to make it work, i needed to use Futomaki instead of Dashimaki Frame Buffer (black screen) and use Port 04 (I use DVI on my LG226W). 

Just for information, it detect 2 displays instead of only 1! I don't know the reason. Help is welcome!

I have mirrored both of them in order to see only my screen!

Share this comment


Link to comment
Share on other sites

   Hey Vlada,

was having an issue with my  "ClubRoyalR9280X" card  has 2miniports and HDMI and DVI ports, ATI,  you have to use "Active" type adapters to connect additional monitors after two have been connected, my setup works great in windows 10 with "EYEfinity"..3 monitors connected, but when I try it in Yosemite only two monitors are working, would your  version of 1.3 tool work to fix  my issue ? I'm using clover UEFI

Happy New Year man

thanks

Drone4zone 

Share this comment


Link to comment
Share on other sites

Great Tool, for the first time I dont get a black screen after so many manual patches for my Saphir R290X (4GB). Now I can connect 2 screens ;-)

However the system seems not to be 100% stable. I get a lot of "windows-server" errors in the system log and random freezes. 

My card is

Device ID 67B0

Supplier ID 1002

SubSys ID E289

 

and its 4GB VRAM not 8 as in the Patch Utility.

 

Anything I can better fine tune to get a stable config?

Share this comment


Link to comment
Share on other sites

I'm now running El Capitan 10.11.6 as well as using Intel HD4000.

just got an AMD Radeon HD 7730 Graphic Card, then I run this app with no effect.

 

What can I do next?

Share this comment


Link to comment
Share on other sites

OH MY GOD!!

 

I don't know what happened, but it works, it works!

I was added device-id into AMD7000Controller.kext and AMDRadeonX4000.kext, but no luck and black screen.

 

rebuild the Clover Installer(and Bootloader), the use backup un-patched kexts onto Clover Installer, and it works

Replace the patched kexts, then I'll try to boot again.

 

Hope it works.

Share this comment


Link to comment
Share on other sites

Heh, only God knows what happens in your case, but I seriously doubt that only this tool is responsible for your problem! 

Radeon R7 260x 2GB Dual-fan ID 6658 works fine in yosemite and El capitan with ATI Injection and fake id 0x66401002 but never worked with 2 monitors would have like to add FB patch support for this GPU in the future.
 
Thank you

Share this comment


Link to comment
Share on other sites
×