Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

1 Screenshot

About This File


This is EFI-based bootloader for BIOS-based computers created as a replacement to EDK2/Duet bootloader http://www.tianocore.org.

To compile it needs to place Clover sources into edk2/ folder.



  • using UEFI BIOS or own CloverEFI
  • default boot after timeout into previous chosen OS
  • customizable GUI: themes support, own icons, fonts, background image, animated pictures, mouse pointers.
  • F1 - multilingual help, depending on language in config
  • saving preboot.log from GUI by typing F2 and system.log for debug
  • save original (OEM) ACPI tables by pressing F4
  • test DSDT patching with F5
  • save videoBIOS into EFI/misc by pressing F6
  • saving screenshots from GUI typing F10
  • CD/DVD eject by F12 and refresh menu after CD insertion
  • change GUI resolution by PgUp/PgDown
  • save BOOT0000 option to NVRAM (like bcfg in Shell)
  • call to Shell.efi
  • native screen resolution in GUI
  • scroll bar if screen resolution is too low for menu
  • theme database http://clover-wiki.zetam.org/Theme-database

Clover wiki: http://clover-wiki.zetam.org/Home

Clover on ProjectOSX : http://www.projectosx.com/forum/index.php?showtopic=2562

Clover on InsanelyMac: http://www.insanelymac.com/forum/forum/327-clover/

What's New in Version 4414   See changelog


  • [r4414] revert esp installation for old macos and fix two intel graphics in system report

User Feedback

Recommended Comments

problem: after reboot no os found by clover, no entries there every is empty just windows..

if i set custom entries in config.plist juste the same, shows nothing.

i use the function GUI->Custom/Entries and List empty and it found any installed os before!


in older version 3118 everything work fine...


how to fix, i can't boot up only with external usb-pen

Share this comment

Link to comment
Share on other sites

for mine, v3141 was working fine, but after upgrade to v3168 and reboot, I just get this:  "Welcome to Clover 3168  ......... scan entries ... ", and there the boot stays.


Edit 21 Feb 15


Until of course I realised I'd been stupid and let the Clover update replace HFSPlus-64.efi with VBoxHfs-64.efi, but now its back and all is well with booting Yosemite 10.10.2.

Share this comment

Link to comment
Share on other sites

hello all, why clover.iso does not work after mounting in grub4dos?
mounting in grub4dos:
find --set-root /clover.iso
reply (hd0,1)
map --mem /clover.iso (hd32)
map --hook
rootnoverify (hd32)
chainloader (hd32)
the attempted launch is good, but nothing happens.
Thank you for your insightful responses

Share this comment

Link to comment
Share on other sites

Hi Fabio how are you?


Why instead of writing "Clover EFI bootloader 3602" (I'm talking for the title) make it "Clover EFI bootloader, official latest stable release"?

The link bring users to sourceforge at stable release...

Share this comment

Link to comment
Share on other sites