Jump to content

IO80211Family modif 1.0.0


1 Screenshot

About This File

Modified IO80211Family.kext especially who use device based on Atheros40 (the idea came from CtlnaAHCIPort.kext) so we don't need to touch /S/L/E just inject via OpenCore, and we can running Big SUr without open Sealed (no need remove/delete vanilla IO80211Family.kext in /S/L/E)

 

I'm not try in Mojave or Catalina but I'm sure is worked too

 

1. just put 2 kext HS80211Family.kext & AirPortAtheros40.kext  .../OC/Kexts and make sure inject via config.plist

  do not inject IO80211NetBooter in the plist (must do research so i leave there in plugin),  I remove IO80211NetBooter from plugin so as not to confuse

see my pict below just add 2 value

509405553_ScreenShot2020-10-10at10_17_05.png.8100d3f0de3a0564dcb1d943019cc356.png

 

2. you can add value manually VendorID in IONameMatch (atheros40) if your ID not present

 

3. refer to @MaLd0n guide in olarila for working Wifi Atheros AR9565, AR9462, AR9463, AR9485

here is the modification (no need injector)

AR9565 AirPortAtheros40-9565.kext.zip

AR9462 AirPortAtheros40-9462.kext.zip

AR9463 AirPortAtheros40-9463.kext.zip

AR9485 AirPortAtheros40-9485.kext.zip

 

Additional : Fake Locale & Country Code

 

Use this kext WifiLocFix.kext.zip to fix Locale & Country Code (Fake AirPort Location Interface)

 

657559936_ScreenShot2020-10-14at20_39_48.png.e0fd611bc2519555dfd2e1d458aa5744.png

 

You can change it inside WifiLocFix.ket depend on your location

and don't forget to inject in your config.plist

 

 Card Type: AirPort Extreme  (0x168C, 0x3112)

  Firmware Version: Atheros 9380: 4.0.74.0-P2P

  MAC Address: XXXXXXXXXXXXXX

  Locale: ETSI

  Country Code: ID

  Supported PHY Modes: 802.11 a/b/g/n

  Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64

  Wake On Wireless: Supported

  Status: Connected

 

 


What's New in Version 1.0.0   See changelog

Released

No changelog available for this version.

  • Like 14
  • Thanks 15

User Feedback

Recommended Comments



atheros40 missing in mojave, I'll do research why get panic 

  • Like 4
  • Thanks 1
Link to comment
Share on other sites

On 6/9/2021 at 3:27 AM, ellaosx said:

@pico joe

Maybe its time to mod 8011Family of Mojave

I am not sure but I think it does not support Atheros WiFi

Hierra version is the newest one

Link to comment
Share on other sites

@pico joe

If I recall, Mojave's IO80211Family + High Sierra's AirPortAtheros40 worked untill Catalina. I only switched to your modded kext in BigSur, because BigSur wont allow it to load if not modded.

  • Thanks 1
Link to comment
Share on other sites

HS80211Family.kext & AirPortAtheros40.kext Any news for the use of these two kext in Monterey in Big Sur works for me very well with O

 
 
 
 
 

image.png

Edited by kaoskinkae
Link to comment
Share on other sites

1 hour ago, kaoskinkae said:

HS80211Family.kext & AirPortAtheros40.kext Any news for the use of these two kext in Monterey in Big Sur works for me very well with O

I would like to understand why it does not crash and restart to you while we who use them only happens with Monterey while Big Sur no problem.
Can you tell us which bootloader you are using?

image.png

I would like to understand why it does not crash and restart to you while we who use them only happens with Monterey while Big Sur no problem.
Can you tell us which bootloader you are using?

Link to comment
Share on other sites

4 hours ago, ludox said:

I would like to understand why it does not crash and restart to you while we who use them only happens with Monterey while Big Sur no problem.
Can you tell us which bootloader you are using?

I need the C to come out, my bootloader is OpenCore with Big Sur without problems and indeed I have three mounted systems M2 Bis Sur, MSATA Monterey and HD WINDOWS 10 to star i Have creaeted a boostable USB desactivating those two keys to be able start Monterey

Link to comment
Share on other sites

I think its the end of atheros in Monterey :(

Edited by ellaosx
Link to comment
Share on other sites

3 hours ago, ellaosx said:

I think its the end of atheros in Monterey :(

 

Link to comment
Share on other sites

IO80211Family.kext был переименован в IO80211FamilyLegacy.kext. Я добавил к нему AirPortAtheros40, но это не сработало.

If earlier the panic was on IO80211Family.kext, then right now the panic is not on this kext. I deleted IO80211FamilyLegacy.kext anyway panic.

Edited by prud28
Link to comment
Share on other sites

It is the atheros that is causing the panic, not the hs80211family.

Link to comment
Share on other sites

The kext that does not work an startup is the AirPortAtheros40.kext since I just tried the other kext to activate is HS80211Family.kext and the system boots withourt wifi but boots.

Link to comment
Share on other sites

1 hour ago, kaoskinkae said:

The kext that does not work an startup is the AirPortAtheros40.kext since I just tried the other kext to activate is HS80211Family.kext and the system boots withourt wifi but boots.

 

Link to comment
Share on other sites

i am having trouble making this work with ar5b195 bluettoh wifi combo (ar9285+ ar3011)

i put both  HS80211Family.kext & AirPortAtheros40.kext in OC/kexts but no wireless interface shows up

is there something i am missing? can someone help me or share their plists/efi as example?

Thank you!

Link to comment
Share on other sites

2 hours ago, gemep said:

i am having trouble making this work with ar5b195 bluettoh wifi combo (ar9285+ ar3011)

i put both  HS80211Family.kext & AirPortAtheros40.kext in OC/kexts but no wireless interface shows up

is there something i am missing? can someone help me or share their plists/efi as example?

Thank you!

 

Did you add the kexts in your config under Kernel -> Add as you've done with the other kexts your system loads?

Link to comment
Share on other sites

7 hours ago, Shaneee said:

 

Did you add the kexts in your config under Kernel -> Add as you've done with the other kexts your system loads?

Actually i solved this, i  tried to use the kexts included in this comment by PG7 and it worked!
thank your for your help anyway

Link to comment
Share on other sites

3 hours ago, ellaosx said:

the only difference is the 2b being injected in info.plist. rest are identical with @pico joe's kext

today I will try with my atheros 9565 let's see if it activates

4 hours ago, gemep said:

Actually i solved this, i  tried to use the kexts included in this comment by PG7 and it worked!
thank your for your help anyway

cmq is excellent news which means that the atheros cards can work with Monterey, now you have to do the necessary configuration for the various models that are used ..

Link to comment
Share on other sites

pci168c,2b is value for 9285 (that I forget to insert before) and I think @gemep not in Monterey, I do experiment with broken sealed, create new snapshot and rebuild kernel but still not load 

Link to comment
Share on other sites

20 hours ago, pico joe said:

pci168c,2b is value for 9285 (that I forget to insert before) and I think @gemep not in Monterey, I do experiment with broken sealed, create new snapshot and rebuild kernel but still not load 

no need for snapshot

you may load by sudo kexload AirPortAtheros40.kext etc

but it does not work ((

IO80211Family is incompatible

Link to comment
Share on other sites

1 hour ago, Rodion2010 said:

no need for snapshot

you may load by sudo kexload AirPortAtheros40.kext etc

but it does not work ((

IO80211Family is incompatible

Yes .. I know with sudo kextload but not load, so I'm playing with prelinkedkernel and BootKernelExtensions but still no luck

Link to comment
Share on other sites

Big Sur bets have been released for both developers and public, so it is assumed that the next one will soon be Monterey, which we hope can activate the Atheros cards

Link to comment
Share on other sites

"Out of curiosity", I created a folder in /usr/local/bin and  placed  the 3 modified kext (CtlnaAHCIPort, HS80211Family & MO80211Family) along with my other backup kext, then ugrade it to Monterey,  to my suprise,  only the 3 kext were deleted on-the-fly during the updrade. This happen too on a clean install. It will also be deleted no matter where you put it in the target disk during install.

It looks like those apple's modified kext are being scanned and deleted or blocked if it was modified.

This didnt happen in BigSur.
 

Edited by ellaosx
Link to comment
Share on other sites

Ciao a tutti, con il nuovo aggiornamento Monterey beta 2 è stato risolto il problema di attivazione del WiFi atheros?

Link to comment
Share on other sites

Hello
I installed Big Sur 11.4
But I have a WiFi problem
Do you have a video on YouTube that I install according to the video of the WiFi driver?
Because according to this text tutorial, I can not install in the topic and I am a beginner.
My WiFi model is also 9565.

Link to comment
Share on other sites


×
×
  • Create New...