Jump to content

Dell Laptops Post-installer - XPS, Inspiron, Vostro, Lattitude


  • Please log in to reply
1016 replies to this topic

#941
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany
btw. those of you trying to load 32bit through com.apple.boot.plist, the correct way to do it is via a key, not a string under kernel flags:

<key>arch</key>
<string>i386</string>
thanks to Kabyl who pointed this out to me.

#942
TheKing

TheKing

    InsanelyMac Protégé

  • Donators
  • 34 posts
  • Gender:Male
  • Location:United States
IMPORTANT:
I am directly moving to the 2.0 (Snow Leopard) Version, so I am waiting for your submissions of drivers, DSDT Patches, Fixes, Any Other Patches for Snow Leopard.
Please use the following template when you are submitting:

Type of Submission: ANSWER HERE
Dell Laptop Model: ANSWER HERE
Fully working? - ANSWER HERE
x32 or x64 or both? - ANSWER HERE
Thanks to (the creator of the driver/fix/etc...): ANSWER HERE


Thanks in advance.

#943
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

IMPORTANT:
I am directly moving to the 2.0 (Snow Leopard) Version, so I am waiting for your submissions of drivers, DSDT Patches, Fixes, Any Other Patches for Snow Leopard.
Please use the following template when you are submitting:

Thanks in advance.


well, it's a start:

Type of Submission: 10.6.1 links
Dell Laptop Model: E1505/6400
Fully working? - fully, cpus=2, thanks to voodooTSCSync by cosmo1t
x32 or x64 or both? - only x32 because there are no gma950 64bit kexts
Thanks to noob766 for his guide. Note that you only need to follow instructions for the hidden EFI partition. One requirement is that you have to have OSX (e.g. Leopard) already installed on another partition.

Because gma950 still has wake/sleep problem at login you need to use screen sleeper solution. Use an external monitor to apply sleep/wake display activate in expose and install this script, also disable autologin.
If you have a Core2Duo the system will boot into 64bit by default. You need to add
<key>arch</key>
<string>i386</string>
to your com.apple.boot.plist (preferably on the EFI partition) to force it to 32bit. Otherwise your gma950 kexts will not load and you only get default vga, no qe, ci and only 1024x768.

Extra kexts I am using:
-> voodoohda for sound. Works just like under leopard
-> voodoops2controller, need to load this in Extra of EFI partition to get mouse and keyboard working from the getgo.
-> voodoosdhc allows reading/writing of SDHC cards
-> voodoopower to get speedstep
-> voodooTSCSync enables both cores on C2D
thanks to the voodoo team!

with noob's guide I personally do not think a postinstaller is necessary, especially since there is no distro out there at all at the moment. Noob766 has an Inspiron E1505 himself.
Noob766 made a generic 132boot iso for the E1505/6400 already: Inspiron6400.iso.zip
Note that he uses an older IOGraphics kext and Frambuffer.kext to boot without gma950 problems. You will later need to remove these (they will be located on the EFI partition) and use the stock kexts to avoid artifacts and apply the above screen sleeper patch.
attached is my com.apple.boot.plist which loads gma950 EFI string. Note that without the EFI string the system will KP before login. (if you use it remove cpus=1 unless you need it, with voodooTSCSync not necessary). If you would like to have a look at contents of my EFI partition, it's located here. including a DSDT.aml for my particular hardware config.

good luck
edit: no problems whatsoever upgrading to 10.6.2
but rarely using it. almost 0. using Windows 7 64bit.

Attached Files



#944
G30RG3

G30RG3

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hi all,
I have a few issues getting my Inspiron E1505 OSx86 install to work correctly.
Specs:
ATI Mobility Radeon X1400 Graphics
Intel Core 2 Duo 1.8 GHz
Sigmatel 9200 C-Major HD Audio
Ricoh 3-1 Memory Card Reader
Dell W1390 Wireless Mini Card

I installed iATKOS v7 (Leopard 10.5.7)
Graphics: No QE/CI Support & resolution at 1024 x 768 :(
Sleep & Shutdown: Do not Work
Sound: Works after patching
SD Reader: Works after patching
Trackpad/Keyboard: Work fine
Network: Dell Wireless 1390 Works fine

So my question is: is anyone willing to help me get my radeon x1400, and sleep/hibernate working?
Thanks

#945
maleorderbride

maleorderbride

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 291 posts
  • Gender:Male
I have a question about mach_kernels. I am currently booting with cpus=1 on a Dell Precision M90.

I have a Core 2 Duo and am running 10.5.8. I have a mach_kernel that is supposed to be for 10.5.8. I was planning on designating that kernel in the Boot.plist using Chameleon 2 RC2.

Other than this mach_kernel, and key/string to execute it, what else do I need to do, if anything, to have dual-core support under 10.5.8?

#946
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

I have a question about mach_kernels. I am currently booting with cpus=1 on a Dell Precision M90.

I have a Core 2 Duo and am running 10.5.8. I have a mach_kernel that is supposed to be for 10.5.8. I was planning on designating that kernel in the Boot.plist using Chameleon 2 RC2.

Other than this mach_kernel, and key/string to execute it, what else do I need to do, if anything, to have dual-core support under 10.5.8?


if you use the kernel in this post 9.8 you can boot without cpus=1 and get both cores, no other key string to use.


btw. looks like cosmo managed the TSC sync for SL. Link here.

Thank you Cosmo!!! :thumbsup_anim:

edit: confirmed working. No more cpus=1 on SL, both cores working!

#947
rohizzle121

rohizzle121

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts
  • Gender:Male
  • Location:The Woodlands , Texas

if you use the kernel in this post 9.8 you can boot without cpus=1 and get both cores, no other key string to use.


btw. looks like cosmo managed the TSC sync for SL. Link here.

Thank you Cosmo!!! :)

edit: confirmed working. No more cpus=1 on SL, both cores working!




one question, what is TSC Sync?

#948
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

one question, what is TSC Sync?


in simple terms it's syncing up all CPUs to the same moment in a multicore system. for Dell core2duos and core duos the vanilla kernel would lead to stuttering because of inproper syncing. the stuttering is so bad that it's really only possible to either set the bios to one core or via boot.plist. the solution is a patched kernel or a kext.

#949
rohizzle121

rohizzle121

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 159 posts
  • Gender:Male
  • Location:The Woodlands , Texas

in simple terms it's syncing up all CPUs to the same moment in a multicore system. for Dell core2duos and core duos the vanilla kernel would lead to stuttering because of inproper syncing. the stuttering is so bad that it's really only possible to either set the bios to one core or via boot.plist. the solution is a patched kernel or a kext.


oh that makes so much more sense! I knew exactly why we couldn't use the se vanillia kernel. So is it somthing that's always gonna have to be patched? Or can there be such a autopatcher?

#950
icecold

icecold

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

well, it's a start:

Type of Submission: 10.6.1 links
Dell Laptop Model: E1505/6400
Fully working? - fully, cpus=2, thanks to voodooTSCSync by cosmo1t
x32 or x64 or both? - only x32 because there are no gma950 64bit kexts
Thanks to noob766 for his guide:

Because gma950 still has wake/sleep problem at login you need to use screen sleeper solution. Use an external monitor to apply sleep/wake display activate in expose and install this script, also disable autologin.
If you have a Core2Duo the system will boot into 64bit by default. You need to add
<key>arch</key>
<string>i386</string>
to your com.apple.boot.plist (preferably on the EFI partition) to force it to 32bit. Otherwise your gma950 kexts will not load and you only get default vga, no qe, ci and only 1024x768.

Extra kexts I am using:
-> voodoohda for sound. Works just like under leopard
-> voodoops2controller, need to load this in Extra of EFI partition to get mouse and keyboard working from the getgo.
-> voodoosdhc allows reading/writing of SDHC cards
-> voodoopower to get speedstep
-> voodooTSCSync enables both cores on C2D
thanks to the voodoo team!

with noob's guide I personally do not think a postinstaller is necessary, especially since there is no distro out there at all at the moment. Noob766 has an Inspiron E1505 himself.
Noob766 made a generic 132boot iso for the E1505/6400 already: Inspiron6400.iso.zip
Note that he uses an older IOGraphics kext and Frambuffer.kext to boot without gma950 problems. You will later need to remove these (they will be located on the EFI partition) and use the stock kexts to avoid artifacts and apply the above screen sleeper patch.
attached is my com.apple.boot.plist which loads gma950 EFI string. Note that without the EFI string the system will KP before login. (if you use it remove cpus=1 unless you need it, with voodooTSCSync not necessary).

good luck



Would you mind posting a brief install guide, i got SL to instal using his boot iso (laptop is same specs as yours) just having trouble with the boot from hard drive EFI etc.
Mainly just the order in which you installed things, where they were installed too, terminal commands and any other useful bits and pieces.


Ice

#951
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas
Look in his post in reference to noobs guide... it shows you how he installed it.. I used the same guide and have SL running on my e1505 as well... Thanks GreatDeciever :-)

Would you mind posting a brief install guide, i got SL to instal using his boot iso (laptop is same specs as yours) just having trouble with the boot from hard drive EFI etc.
Mainly just the order in which you installed things, where they were installed too, terminal commands and any other useful bits and pieces.


Ice



#952
icecold

icecold

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Look in his post in reference to noobs guide... it shows you how he installed it.. I used the same guide and have SL running on my e1505 as well... Thanks GreatDeciever :-)


would you mind posting a link to it? Have just been through 20+ pages and can't find it.


Ice

#953
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

would you mind posting a link to it? Have just been through 20+ pages and can't find it.


Ice


you start with the "Hidden EFI Partition Method" here: http://www.insanelym...howtopic=182227
you could also just click the noob link in my sig. Btw. do not get scared away by the massive contents of the guide. you only need to follow the hidden EFI stuff, which is a third of the entire guide.

#954
icecold

icecold

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

you start with the "Hidden EFI Partition Method" here: http://www.insanelym...howtopic=182227
you could also just click the noob link in my sig. Btw. do not get scared away by the massive contents of the guide. you only need to follow the hidden EFI stuff, which is a third of the entire guide.


Awesome, I've done that and am successfully booting into SL now.
The display is causing problems, i copied your EFI partition files, and applied the sleeper fix, but when i boot it flashes white then goes dead, if i plug in an external display i get my login etc on the external. How do i fix this to get the internal display to work?

Cheers,

Ice

#955
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

Awesome, I've done that and am successfully booting into SL now.
The display is causing problems, i copied your EFI partition files, and applied the sleeper fix, but when i boot it flashes white then goes dead, if i plug in an external display i get my login etc on the external. How do i fix this to get the internal display to work?

Cheers,

Ice

not sure if your hardware is actually identical, not being able to see it. I assume you have gma950 grapx card?

#956
snowspeeder

snowspeeder

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I find this project so hard to deal with. Maybe someone can point me in the right direction.

I have a Inspiron 6400. Intel core duo, Geforce go 7300 (128), Dell wifi, bluetooth, azila audio.

I have tried installing Iaktos 10.5.5 and using the Post-Installer.

After manually having to apply some kexts I had a semi working system.

I was able to update to 10.5.8 successfully.

The things that were not working were sleep and usb.

USB would always work fro keyboard/mouse, but would only work for other devices (iphone, pen drive) if it were attached while the system was booting.

I tired to apply some fix i found for sleep and caused a kernel panic. Time machine would restore correctly so here I am reinstalling again.

Any Ideas where I can get the right drivers for this stuff? I have such a hard time locating what I need.

#957
icecold

icecold

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

not sure if your hardware is actually identical, not being able to see it. I assume you have gma950 grapx card?



Got it all working now. Screen just sleeps very quick during login.

How did you get your sleep working? I put it to sleep and it won't wake / not sure how to wake it...


Ice

#958
Yuriy Havryliv

Yuriy Havryliv

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Ukraine, Lviv
Hi,

I'm ready to install Snow Leopard to my dell 6400. I want to have native Exchange support in Mail :D

Currently I'm using Leopard 10.5.7
My HDD has 2 partitions one for OS and one for Data.

Looks like it's not possible to install Snow Leopard with current partitions. I don't want to reformat Data partition so i need to kill Leopard split its partition into 2 parts and after install Leo again on second partition and finally Snow Leo to first.

Or should I try some tools to cut a live OS partotion without re installation?

Does it make sense? Please help.

#959
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

Got it all working now. Screen just sleeps very quick during login.

How did you get your sleep working? I put it to sleep and it won't wake / not sure how to wake it...


Ice


sleep never worked on gma950. only deep sleep will work (hibernatemode=1)

Hi,

I'm ready to install Snow Leopard to my dell 6400. I want to have native Exchange support in Mail :(

Currently I'm using Leopard 10.5.7
My HDD has 2 partitions one for OS and one for Data.

Looks like it's not possible to install Snow Leopard with current partitions. I don't want to reformat Data partition so i need to kill Leopard split its partition into 2 parts and after install Leo again on second partition and finally Snow Leo to first.

Or should I try some tools to cut a live OS partotion without re installation?

Does it make sense? Please help.

your job will be a piece of cake if you have a second hdd that you can put into a USB enclosure. That's how I installed mine. used extra hdd in USB enclosure, made three partitions on it. I copied (via disktutility restore) Leo to one of them and the install DVD to another, kept third one empty for SL installation. Then swapped hdds, booted into Leo and installed SL.
You could also use the second hdd as a temporary place holder and move everything back to main internal. Several ways that way and you won't loose anything via diskutility restore.

#960
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas
Just noticed that I have no battery meter at the top.. any suggestions? thanks..





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy